Loading ...
Sorry, an error occurred while loading the content.

Re: short delay after quitting command-line-mode

Expand Messages
  • Marcin Szamotulski
    ... I am using more vim than gvim and I got used to , though I have remapped to in insert mode since triggers InsertLeave, while
    Message 1 of 8 , Jul 14, 2013
    • 0 Attachment
      On 00:21 Mon 15 Jul , Johannes Deutsch wrote:
      > On Sun, 14 Jul 2013 23:30:55 +0400
      > Nikolay Pavlov <zyx.vim@...> wrote:
      >
      > > On Jul 14, 2013 11:11 PM, "Johannes Deutsch" <j_deutsch@...> wrote:
      > > >
      > > > On Sun, 14 Jul 2013 22:55:47 +0400
      > > > Nikolay Pavlov <zyx.vim@...> wrote:
      > > >
      > > > > On Jul 14, 2013 10:47 PM, "Johannes Deutsch" <j_deutsch@...>
      > > > > wrote:
      > > > > >
      > > > > > Hi all,
      > > > > >
      > > > > > recently i switched from gvim to vim to enjoy the benefits of
      > > > > > the interaction between vim and tmux.
      > > > > >
      > > > > > Soon after i worked some time with vim I encountered a short
      > > > > > delay after pressing <ESC> to leave command-line-mode. This
      > > > > > short delay is completly gone if i press <CTRL>-C in order to
      > > > > > leave command-line-mode.
      > > > > >
      > > > > > Because of this, i suspected <ESC>-<Some key> to be mapped. I
      > > > > > checked it with :cmap but there are no such mappings.
      > > > > >
      > > > > > Maybe someone knows how to remove the observed delay.
      > > > > >
      > > > > > Thanks for your effort and with best regards
      > > > > >
      > > > > > Johannes
      > > > >
      > > > > Set 'ttimeoutlen' to a lesser value (e.g. 10 ms). Vim waits for
      > > > > keys to be typed and escape is the first character terminal sends
      > > > > when you type arrows, FN, Home and so on.
      > > >
      > > > Thanks a lot for your quick reply and the reasoned explanation.
      > > >
      > > > I tried to correct the value of 'ttimeoutlen'. Unfortunately the
      > > > delay is still observable for ttimeoutlen=1. Probably i should
      > > > learn to use <CTRL>-C!?
      > >
      > > Then it must be something else. Do you observe it for command mode
      > > only?
      >
      > Yes! Switching from normal- to insert-mode works without any delay.
      >
      > > 'ttimeoutlen' should alter the behavior for all modes at once.
      > > If you were talking about insert mode I would suspect InsertLeave
      > > autocommands, but there is nothing like this for command mode.
      > >
      > > Does this happen with
      > >
      > > vim -u NONE -N -c 'set ttimeout timeout ttimeoutlen=10'
      > > ?
      >
      > Executing
      >
      > set ttimeout timeout ttimeoutlen=10
      >
      > in a running vim instance removes the delay. It will go into my .vimrc
      > immediately.
      >
      > Thanks a lot for your help and best regards...

      I am using more vim than gvim and I got used to <c-c>, though I have
      remapped <c-c> to <esc> in insert mode since <esc> triggers InsertLeave,
      while <c-c> not.

      Since I don't like the timeout at all, I try to keep only one map
      starting with a given key with some exceptions like leader keys and
      I set: notimeout, ttimeout and ttimeoutlen=10.

      Cheers,
      Marcin

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Johannes Deutsch
      On Sun, 14 Jul 2013 21:47:02 +0100 ... Interesting! Thanks for your contribution ... -- -- You received this message from the vim_use maillist. Do not
      Message 2 of 8 , Jul 15, 2013
      • 0 Attachment
        On Sun, 14 Jul 2013 21:47:02 +0100
        Marcin Szamotulski <mszamot@...> wrote:

        > On 00:21 Mon 15 Jul , Johannes Deutsch wrote:
        > > On Sun, 14 Jul 2013 23:30:55 +0400
        > > Nikolay Pavlov <zyx.vim@...> wrote:
        > >
        > > > On Jul 14, 2013 11:11 PM, "Johannes Deutsch" <j_deutsch@...>
        > > > wrote:
        > > > >
        > > > > On Sun, 14 Jul 2013 22:55:47 +0400
        > > > > Nikolay Pavlov <zyx.vim@...> wrote:
        > > > >
        > > > > > On Jul 14, 2013 10:47 PM, "Johannes Deutsch"
        > > > > > <j_deutsch@...> wrote:
        > > > > > >
        > > > > > > Hi all,
        > > > > > >
        > > > > > > recently i switched from gvim to vim to enjoy the benefits
        > > > > > > of the interaction between vim and tmux.
        > > > > > >
        > > > > > > Soon after i worked some time with vim I encountered a short
        > > > > > > delay after pressing <ESC> to leave command-line-mode. This
        > > > > > > short delay is completly gone if i press <CTRL>-C in order
        > > > > > > to leave command-line-mode.
        > > > > > >
        > > > > > > Because of this, i suspected <ESC>-<Some key> to be mapped.
        > > > > > > I checked it with :cmap but there are no such mappings.
        > > > > > >
        > > > > > > Maybe someone knows how to remove the observed delay.
        > > > > > >
        > > > > > > Thanks for your effort and with best regards
        > > > > > >
        > > > > > > Johannes
        > > > > >
        > > > > > Set 'ttimeoutlen' to a lesser value (e.g. 10 ms). Vim waits
        > > > > > for keys to be typed and escape is the first character
        > > > > > terminal sends when you type arrows, FN, Home and so on.
        > > > >
        > > > > Thanks a lot for your quick reply and the reasoned explanation.
        > > > >
        > > > > I tried to correct the value of 'ttimeoutlen'. Unfortunately the
        > > > > delay is still observable for ttimeoutlen=1. Probably i should
        > > > > learn to use <CTRL>-C!?
        > > >
        > > > Then it must be something else. Do you observe it for command mode
        > > > only?
        > >
        > > Yes! Switching from normal- to insert-mode works without any delay.
        > >
        > > > 'ttimeoutlen' should alter the behavior for all modes at once.
        > > > If you were talking about insert mode I would suspect InsertLeave
        > > > autocommands, but there is nothing like this for command mode.
        > > >
        > > > Does this happen with
        > > >
        > > > vim -u NONE -N -c 'set ttimeout timeout ttimeoutlen=10'
        > > > ?
        > >
        > > Executing
        > >
        > > set ttimeout timeout ttimeoutlen=10
        > >
        > > in a running vim instance removes the delay. It will go into
        > > my .vimrc immediately.
        > >
        > > Thanks a lot for your help and best regards...
        >
        > I am using more vim than gvim and I got used to <c-c>, though I have
        > remapped <c-c> to <esc> in insert mode since <esc> triggers
        > InsertLeave, while <c-c> not.
        >
        > Since I don't like the timeout at all, I try to keep only one map
        > starting with a given key with some exceptions like leader keys and
        > I set: notimeout, ttimeout and ttimeoutlen=10.

        Interesting!

        Thanks for your contribution

        > Cheers,
        > Marcin
        >

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Johannes Deutsch
        On Mon, 15 Jul 2013 00:21:11 +0200 ... Yesterday i played with tmux s escape-time option too. This means that i changed the escape-time before i invoked
        Message 3 of 8 , Jul 15, 2013
        • 0 Attachment
          On Mon, 15 Jul 2013 00:21:11 +0200
          Johannes Deutsch <j_deutsch@...> wrote:

          > On Sun, 14 Jul 2013 23:30:55 +0400
          > Nikolay Pavlov <zyx.vim@...> wrote:
          >
          > > On Jul 14, 2013 11:11 PM, "Johannes Deutsch" <j_deutsch@...>
          > > wrote:
          > > >
          > > > On Sun, 14 Jul 2013 22:55:47 +0400
          > > > Nikolay Pavlov <zyx.vim@...> wrote:
          > > >
          > > > > On Jul 14, 2013 10:47 PM, "Johannes Deutsch" <j_deutsch@...>
          > > > > wrote:
          > > > > >
          > > > > > Hi all,
          > > > > >
          > > > > > recently i switched from gvim to vim to enjoy the benefits of
          > > > > > the interaction between vim and tmux.
          > > > > >
          > > > > > Soon after i worked some time with vim I encountered a short
          > > > > > delay after pressing <ESC> to leave command-line-mode. This
          > > > > > short delay is completly gone if i press <CTRL>-C in order to
          > > > > > leave command-line-mode.
          > > > > >
          > > > > > Because of this, i suspected <ESC>-<Some key> to be mapped. I
          > > > > > checked it with :cmap but there are no such mappings.
          > > > > >
          > > > > > Maybe someone knows how to remove the observed delay.
          > > > > >
          > > > > > Thanks for your effort and with best regards
          > > > > >
          > > > > > Johannes
          > > > >
          > > > > Set 'ttimeoutlen' to a lesser value (e.g. 10 ms). Vim waits for
          > > > > keys to be typed and escape is the first character terminal
          > > > > sends when you type arrows, FN, Home and so on.
          > > >
          > > > Thanks a lot for your quick reply and the reasoned explanation.
          > > >
          > > > I tried to correct the value of 'ttimeoutlen'. Unfortunately the
          > > > delay is still observable for ttimeoutlen=1. Probably i should
          > > > learn to use <CTRL>-C!?
          > >
          > > Then it must be something else. Do you observe it for command mode
          > > only?
          >
          > Yes! Switching from normal- to insert-mode works without any delay.
          >
          > > 'ttimeoutlen' should alter the behavior for all modes at once.
          > > If you were talking about insert mode I would suspect InsertLeave
          > > autocommands, but there is nothing like this for command mode.
          > >
          > > Does this happen with
          > >
          > > vim -u NONE -N -c 'set ttimeout timeout ttimeoutlen=10'
          > > ?
          >
          > Executing
          >
          > set ttimeout timeout ttimeoutlen=10
          >
          > in a running vim instance removes the delay. It will go into my .vimrc
          > immediately.
          >
          > Thanks a lot for your help and best regards...
          >

          Yesterday i played with tmux's 'escape-time' option too. This means
          that i changed the 'escape-time' before i invoked

          set ttimeout timeout ttimeoutlen=10

          in vim.

          Today realized that i have to set both

          set -s escape-time 0

          in tmux and

          set ttimeoutlen=10

          in vim to remove the delay. If only one of these options is set the
          delay remains.

          Best regards



          > > Also I do not observe this either inside or outside tmux, but can
          > > tmux be responsible? Check out the delay for CTRL-V then ESC in
          > > command mode, ^[ should appear immediately after you type ESC no
          > > matter whether you have any mappings or what is *timeout* setting.
          > >
          > > > > > --
          > > > > > --
          > > > > > You received this message from the "vim_use" maillist.
          > > > > > Do not top-post! Type your reply below the text you are
          > > > > > replying to. For more information, visit
          > > > > > http://www.vim.org/maillist.php
          > > > > >
          > > > > > ---
          > > > > > You received this message because you are subscribed to the
          > > > > > Google Groups
          > > > > "vim_use" group.
          > > > > > To unsubscribe from this group and stop receiving emails from
          > > > > > it, send an
          > > > > email to vim_use+unsubscribe@....
          > > > > > For more options, visit
          > > > > > https://groups.google.com/groups/opt_out.
          > > > > >
          > > > > >
          > > > >
          > > >
          > > > --
          > > > --
          > > > You received this message from the "vim_use" maillist.
          > > > Do not top-post! Type your reply below the text you are replying
          > > > to. For more information, visit http://www.vim.org/maillist.php
          > > >
          > > > ---
          > > > You received this message because you are subscribed to the Google
          > > > Groups
          > > "vim_use" group.
          > > > To unsubscribe from this group and stop receiving emails from it,
          > > > send an
          > > email to vim_use+unsubscribe@....
          > > > For more options, visit https://groups.google.com/groups/opt_out.
          > > >
          > > >
          > >
          >

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.