Loading ...
Sorry, an error occurred while loading the content.

Re: Default IME mode when entering Vim insert mode (Windows)

Expand Messages
  • kohanyi.robert@...
    ... Thanks for the reply it worked like a charm! -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text
    Message 1 of 3 , Jul 13, 2013
    • 0 Attachment
      On Saturday, July 6, 2013 7:52:07 PM UTC+2, sche...@... wrote:
      > On Tuesday, July 2, 2013 10:38:53 AM UTC-5, kohanyi...@... wrote:
      >
      > > I'm using Vim on Windows[1] with Microsoft's Japanese IME "enabled" all the time and when I enter insert mode the default input mode (the IME's input mode, not Vim's) changes to Japanese. I took two pictures to illustrate what I see before I enter insert mode[2] (notice the capital 'A' beside the red thingy on the tray) and after I've entered insert mode[3] (notice that the 'A' changed into a Japanese character). After the input mode has changed to Hiragana then when I type full-width Japanese characters are 'printed'.
      >
      > >
      >
      > >
      >
      > >
      >
      > > So, basically, when I open up Vim and I want to enter some text then first I have to switch back to the default IME input mode (half-width alphanumeric) which is all good (I can do this with a Windows shortcut), but sometimes I forget this and ... well, sometimes it's frustrating. What's worse is that if I load a new file into a buffer and switch over to that and enter insert mode I have to switch the IME's input mode again, which is really-really frustrating when I try to work with multiple files.
      >
      > >
      >
      > >
      >
      > >
      >
      > > My question is: can I instruct Vim so that it won't change the IME input mode when I enter insert mode? (It's not option for me to switch Windows's keyboard language/layout to another language when I work with Vim because I have to type Japanese text sometimes and switching between languages is more frustrating than this whole shebang :).
      >
      > >
      >
      > >
      >
      > >
      >
      > > Thanks for the input in advance.
      >
      > >
      >
      > >
      >
      > >
      >
      > > Regards,
      >
      > >
      >
      > > Kohányi Róbert
      >
      > >
      >
      > >
      >
      > >
      >
      > > [1] http://tuxproject.de/projects/vim/
      >
      > >
      >
      > > [2] http://img163.imageshack.us/img163/8808/dht8.png
      >
      > >
      >
      > > [3] http://img577.imageshack.us/img577/8066/nzpr.png
      >
      >
      >
      > Try setting the following:
      >
      >
      >
      > set iminsert=0
      >
      > set imsearch=-1

      Thanks for the reply it worked like a charm!

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.