Loading ...
Sorry, an error occurred while loading the content.
 

Re: permanent insert mode in compiled vim on debian/kubuntu

Expand Messages
  • Tony Mechelynck
    ... It seems that you got caught in the so-called easy mode. Check that the executable was compiled with the default vim name (not evim ). Try leaving the
    Message 1 of 5 , Jul 9, 2013
      On 09/07/13 01:15, ethician wrote:
      > Hi there,
      >
      > It is quite embarrassing but I couldn't figure this one out.
      >
      > Building vim (7.3.1314 or 7.4beta) on Debian 7.1.0 wheezy and Kubuntu 13.04
      > with necessary (so that it compiles) dependencies and the following
      > configure options:
      >
      > --enable-pythoninterp
      > --enable-multibyte
      > --with-features=huge
      > --enable-gui=no
      > --without-x
      > --disable-nls
      > --with-tlib=ncurses
      >
      > leads to a version where one cannot exit the insert mode. After hitting ESC,
      > vim reverts to insert mode on its own after ~1 sec and rings a bell. Hitting
      > ESC and a colon in a quick succession enters the insert mode and inserts a
      > colon. ".vimrc" settings seem to not matter (could be a false lead though).
      > It doesn't matter whether it is run from within an x terminal or a console.
      >
      > Could anybody point me in the right direction?
      >
      > All help is appreciated!
      >
      > PS: If more information is needed, please let me know.
      >
      > -eth
      >
      It seems that you got caught in the so-called "easy" mode. Check that
      the executable was compiled with the default "vim" name (not "evim").
      Try leaving the so-called easy mode by

      <Ctrl-O>:set noim

      This should make <Esc> go back to the usual "normal" mode. Or, instead
      of unsetting 'insertmode', you could use <Ctrl-L> to get temporarily
      into the usual normal mode until <Esc> gets you back yo Insert mode.

      Also, see what bash answers to

      type -a vim

      Maybe you unwittingly got an alias, or a softlink early in the $PATH,
      that redirects vim to evim ?


      See
      :help 'insertmode'
      :help evim
      :help -y



      Best regards,
      Tony.
      --
      Double-Blind Experiment, n.:
      An experiment in which the chief researcher believes he is
      fooling both the subject and the lab assistant. Often accompanied by a
      belief in the tooth fairy.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • ethician
      Thanks much Tony! The behavior of being stuck in the insert mode truly was due to the so-called easy mode being active. Best regards, Tom -eth -- View this
      Message 2 of 5 , Jul 9, 2013
        Thanks much Tony! The behavior of "being stuck" in the insert mode truly was
        due to the so-called "easy" mode being active.

        Best regards,
        Tom

        -eth



        --
        View this message in context: http://vim.1045645.n5.nabble.com/permanent-insert-mode-in-compiled-vim-on-debian-kubuntu-tp5716334p5716347.html
        Sent from the Vim - General mailing list archive at Nabble.com.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Benji Fisher
        ... I suspect that a system vimrc file is to blame. To help diagnose, ... HTH --Benji Fisher -- -- You received this message from the vim_use maillist. Do
        Message 3 of 5 , Jul 9, 2013
          On Tue, Jul 9, 2013 at 8:17 AM, ethician <ethicius@...> wrote:
          Thanks much Tony! The behavior of "being stuck" in the insert mode truly was
          due to the so-called "easy" mode being active.

          Best regards,
          Tom

          -eth

          I suspect that a system vimrc file is to blame.  To help diagnose,

          :scriptnames
          :verbose set im?
          :help startup

          HTH  --Benji Fisher 

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        Your message has been successfully submitted and would be delivered to recipients shortly.