Loading ...
Sorry, an error occurred while loading the content.
 

Re: Can't delete char before the cursor when RE-in INSERT mode

Expand Messages
  • Nikolay Pavlov
    ... into INSERT mode from NORMAL (by pressing `i`, `A`, `a`, `s` or `c`) ... the vimrc and relaunch vim without loading any third-party plugin, BUT the bug
    Message 1 of 3 , Jul 7, 2013


      On Jul 8, 2013 8:24 AM, "UncleBill" <billbill290@...> wrote:
      >
      > Hi guys,
      >
      > Do you see this bug: chars before cursor can't be deleted when you switch into INSERT mode from NORMAL (by pressing `i`, `A`, `a`, `s` or `c`)
      >
      > I have tried <delete>, <c-h>, <c-w> and <c-u>, none of these keys worked.
      >
      > I thought it was a bug of my vimrc or plugins I installed, so I commented the vimrc and relaunch vim without loading any third-party plugin, BUT the bug wasn't gone.

      This is default behavior. Check out :h 'backspace'. Unsure about delete though.

      > --
      > --
      > You received this message from the "vim_use" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.php
      >
      > ---
      > You received this message because you are subscribed to the Google Groups "vim_use" group.
      > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      > For more options, visit https://groups.google.com/groups/opt_out.
      >
      >

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • UncleBill
      在 2013年7月8日星期一UTC+8下午12时33分17秒,ZyX写道: ... Thanks ZyX, I set backspace=2, that s the behaviour I want. -- -- You received this
      Message 2 of 3 , Jul 8, 2013
        在 2013年7月8日星期一UTC+8下午12时33分17秒,ZyX写道:
        > On Jul 8, 2013 8:24 AM, "UncleBill" <billb...@...> wrote:
        >
        > >
        >
        > > Hi guys,
        >
        > >
        >
        > > Do you see this bug: chars before cursor can't be deleted when you switch into INSERT mode from NORMAL (by pressing `i`, `A`, `a`, `s` or `c`)
        >
        > >
        >
        > > I have tried <delete>, <c-h>, <c-w> and <c-u>, none of these keys worked.
        >
        > >
        >
        > > I thought it was a bug of my vimrc or plugins I installed, so I commented the vimrc and relaunch vim without loading any third-party plugin, BUT the bug wasn't gone.
        >
        > This is default behavior. Check out :h 'backspace'. Unsure about delete though.
        >
        > > --
        >
        > > --
        >
        > > You received this message from the "vim_use" maillist.
        >
        > > Do not top-post! Type your reply below the text you are replying to.
        >
        > > For more information, visit http://www.vim.org/maillist.php
        >
        > >
        >
        > > ---
        >
        > > You received this message because you are subscribed to the Google Groups "vim_use" group.
        >
        > > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+u...@....
        >
        > > For more options, visit https://groups.google.com/groups/opt_out.
        >
        > >
        >
        > >

        Thanks ZyX, I set backspace=2, that's the behaviour I want.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.