Loading ...
Sorry, an error occurred while loading the content.

Terminal escape sequence ^[[A

Expand Messages
  • David Fishburn
    Sorry to ask this here, it is just a terminal question, unrelated to Vim. I don t subscribe to anything Linux related. On most of my machines that I ssh into
    Message 1 of 4 , Jun 28, 2013
    • 0 Attachment
      Sorry to ask this here, it is just a terminal question, unrelated to Vim.  I don't subscribe to anything Linux related.

      On most of my machines that I ssh into (usually from either a Cygwin Terminal or Putty) and I type a command and hit the up arrow, I get my command back.

      When I launch a console application where I can type a command, think an Interactive SQL console application where I would type:
      SELECT * FROM T1

      Though 2 different servers I connect to which always show ^[[A instead of the previous command and I have to re-type my command.

      Yet on other servers, the same program, the up arrow shows the previous command.

      Most of my Google searches say TERM is responsible, but xterm and screen I assume are Ok.  Other says to use bash, which I am.

      Not really sure what to check for.

      If I exit the application and hit the up arrow I get back my command which launched the program.

      Anyway, I grab the ENV output hoping this might be enough for someone to give me suggestions.

      One of the server is running SUSE Enterprise.



      ENV in a Cygwin Terminal

      TERM=xterm
      SHELL=/bin/bash
      HISTSIZE=1000
      SSH_TTY=/dev/pts/1
      LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
      EC2_HOME=/home/ec2
      INPUTRC=/etc/inputrc
      PWD=/home/dfishbur
      JAVA_HOME=/usr/java/default
      LANG=en_US.UTF-8
      SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
      SHLVL=1
      HOME=/home/dfishbur
      LOGNAME=dfishbur
      CVS_RSH=ssh
      LESSOPEN=|/usr/bin/lesspipe.sh %s
      G_BROKEN_FILENAMES=1
      _=/bin/env


      ENV from within SCREEN

      TERM=screen
      SHELL=/bin/bash
      HISTSIZE=1000
      SSH_TTY=/dev/pts/3
      USER=dfishbur
      LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.sh=01;32:*.csh=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tz=01;31:*.rpm=01;31:*.cpio=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.xbm=01;35:*.xpm=01;35:*.png=01;35:*.tif=01;35:
      EC2_HOME=/home/ec2
      TERMCAP=SC|screen|VT 100/ANSI X3.64 virtual terminal:\
              :DO=\E[%dB:LE=\E[%dD:RI=\E[%dC:UP=\E[%dA:bs:bt=\E[Z:\
              :cd=\E[J:ce=\E[K:cl=\E[H\E[J:cm=\E[%i%d;%dH:ct=\E[3g:\
              :do=^J:nd=\E[C:pt:rc=\E8:rs=\Ec:sc=\E7:st=\EH:up=\EM:\
              :le=^H:bl=^G:cr=^M:it#8:ho=\E[H:nw=\EE:ta=^I:is=\E)0:\
              :li#60:co#146:am:xn:xv:LP:sr=\EM:al=\E[L:AL=\E[%dL:\
              :cs=\E[%i%d;%dr:dl=\E[M:DL=\E[%dM:dc=\E[P:DC=\E[%dP:\
              :im=\E[4h:ei=\E[4l:mi:IC=\E[%d@:ks=\E[?1h\E=:\
              :ke=\E[?1l\E>:vi=\E[?25l:ve=\E[34h\E[?25h:vs=\E[34l:\
              :ti=\E[?1049h:te=\E[?1049l:us=\E[4m:ue=\E[24m:so=\E[3m:\
              :se=\E[23m:mb=\E[5m:md=\E[1m:mr=\E[7m:me=\E[m:ms:\
              :Co#8:pa#64:AF=\E[3%dm:AB=\E[4%dm:op=\E[39;49m:AX:\
              :vb=\Eg:G0:as=\E(0:ae=\E(B:\
              :ac=\140\140aaffggjjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~..--++,,hhII00:\
              :po=\E[5i:pf=\E[4i:Z0=\E[?3h:Z1=\E[?3l:k0=\E[10~:\
              :k1=\EOP:k2=\EOQ:k3=\EOR:k4=\EOS:k5=\E[15~:k6=\E[17~:\
              :k7=\E[18~:k8=\E[19~:k9=\E[20~:k;=\E[21~:F1=\E[23~:\
              :F2=\E[24~:F3=\EO2P:F4=\EO2Q:F5=\EO2R:F6=\EO2S:\
              :F7=\E[15;2~:F8=\E[17;2~:F9=\E[18;2~:FA=\E[19;2~:kb=:\
              :K2=\EOE:kB=\E[Z:kF=\E[1;2B:kR=\E[1;2A:*4=\E[3;2~:\
              :*7=\E[1;2F:#2=\E[1;2H:#3=\E[2;2~:#4=\E[1;2D:%c=\E[6;2~:\
              :%e=\E[5;2~:%i=\E[1;2C:kh=\E[1~:@1=\E[1~:kH=\E[4~:\
              :@7=\E[4~:kN=\E[6~:kP=\E[5~:kI=\E[2~:kD=\E[3~:ku=\EOA:\
              :kd=\EOB:kr=\EOC:kl=\EOD:km:
      STY=17204.pts-3.sapmdmsaaslabdb
      INPUTRC=/etc/inputrc
      PWD=/home/dfishbur
      JAVA_HOME=/usr/java/default
      LANG=en_US.UTF-8
      SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
      SHLVL=3
      HOME=/home/dfishbur
      LOGNAME=dfishbur
      WINDOW=3
      CVS_RSH=ssh
      LESSOPEN=|/usr/bin/lesspipe.sh %s
      G_BROKEN_FILENAMES=1
      _=/bin/env


      If you can suggest a good place to ask this and work with someone I am all ears.

      Thanks,
      David



      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Tim Chase
      ... There are two possibilities that occur to me. One is that the arrow keys aren t properly interpreted on the server-end; the other is that the server-end
      Message 2 of 4 , Jun 28, 2013
      • 0 Attachment
        On 2013-06-28 20:43, David Fishburn wrote:
        > On most of my machines that I ssh into (usually from either a Cygwin
        > Terminal or Putty) and I type a command and hit the up arrow, I get
        > my command back.
        >
        > When I launch a console application where I can type a command,
        > think an Interactive SQL console application where I would type:
        > SELECT * FROM T1
        >
        > Though 2 different servers I connect to which always show ^[[A
        > instead of the previous command and I have to re-type my command.

        There are two possibilities that occur to me. One is that the arrow
        keys aren't properly interpreted on the server-end; the other is that
        the server-end doesn't have readline functionality (which is what
        backs this functionality).

        I'd start by issuing control+P to recall the previous command (a
        synonym for <up> in most default shell configurations with history
        recall). If it recalls successfully, then you have a shell with
        readline support and need to chase down why your $TERM settings aren't
        interpreting your arrow presses properly. If control+P doesn't bring
        up the previous line, then it's likely that your shell doesn't have
        readline support. You might check whether you're running a stripped
        down shell, or you can launch an alternate shell. You might also try
        opening Vim and seeing if Vim properly sees the arrow keys (which, if
        it does, might confirm the shell-sans-readline situation)

        Just a few shot-in-the-dark ideas,

        -tim




        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Tim Chase
        ... Okay, other possibilities occurred about 3sec after I hit . I don t know if you have either an /etc/inputrc or ~/.inputrc that is interfering with
        Message 3 of 4 , Jun 28, 2013
        • 0 Attachment
          On 2013-06-28 20:40, Tim Chase wrote:
          > There are two possibilities that occur to me.

          Okay, other possibilities occurred about 3sec after I hit <send>. I
          don't know if you have either an /etc/inputrc or ~/.inputrc that is
          interfering with your commands, but I know the readline libs check
          those for settings, so you might try moving one or both of those out
          of the way and testing again in order to get back to factory defaults.

          Also, though you mention that one is running SUSE, if the other is
          running some flavor of BSD, they tend to use editline rather than
          readline which might introduce additional oddities.

          -tim


          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • shawn wilson
          See terminfo / termcap also make sure you re using, exporting, and that the emulator knows what terminal it should be emulating. Another hint, the search path
          Message 4 of 4 , Jun 28, 2013
          • 0 Attachment

            See terminfo / termcap also make sure you're using, exporting, and that the emulator knows what terminal it should be emulating. Another hint, the search path for terminfo (iirc) is: $TERMPATH, ~/.terminfo, /etc/terminfo, /usr/share/terminfo - if you don't have a compiled terminfo file with the right name in one of those places, don't try setting the terminal to the name as it won't work.

            It might also help to subscribe to some Unix related lists (or one for cygwin or putty) or get on IRC. There's a technical reason for this - when I Google (or search my email) for info related to this subject, if I see a link or email related to vim in my search, I'm probably going to pass it by thinking the question was misplaced and the responses probably a waste of time. Ie, don't keep your questions on topic because the people reading that forum might not care about or be ignorant of the topic, but because, when you forget the answer and go to search for it again, it'll be way off here in this forum you'd never think to look for it.

            On Jun 28, 2013 8:44 PM, "David Fishburn" <dfishburn.vim@...> wrote:
            Sorry to ask this here, it is just a terminal question, unrelated to Vim.  I don't subscribe to anything Linux related.

            On most of my machines that I ssh into (usually from either a Cygwin Terminal or Putty) and I type a command and hit the up arrow, I get my command back.

            When I launch a console application where I can type a command, think an Interactive SQL console application where I would type:
            SELECT * FROM T1

            Though 2 different servers I connect to which always show ^[[A instead of the previous command and I have to re-type my command.

            Yet on other servers, the same program, the up arrow shows the previous command.

            Most of my Google searches say TERM is responsible, but xterm and screen I assume are Ok.  Other says to use bash, which I am.

            Not really sure what to check for.

            If I exit the application and hit the up arrow I get back my command which launched the program.

            Anyway, I grab the ENV output hoping this might be enough for someone to give me suggestions.

            One of the server is running SUSE Enterprise.



            ENV in a Cygwin Terminal

            TERM=xterm
            SHELL=/bin/bash
            HISTSIZE=1000
            SSH_TTY=/dev/pts/1
            LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
            EC2_HOME=/home/ec2
            INPUTRC=/etc/inputrc
            PWD=/home/dfishbur
            JAVA_HOME=/usr/java/default
            LANG=en_US.UTF-8
            SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
            SHLVL=1
            HOME=/home/dfishbur
            LOGNAME=dfishbur
            CVS_RSH=ssh
            LESSOPEN=|/usr/bin/lesspipe.sh %s
            G_BROKEN_FILENAMES=1
            _=/bin/env


            ENV from within SCREEN

            TERM=screen
            SHELL=/bin/bash
            HISTSIZE=1000
            SSH_TTY=/dev/pts/3
            USER=dfishbur
            LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.sh=01;32:*.csh=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tz=01;31:*.rpm=01;31:*.cpio=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.xbm=01;35:*.xpm=01;35:*.png=01;35:*.tif=01;35:
            EC2_HOME=/home/ec2
            TERMCAP=SC|screen|VT 100/ANSI X3.64 virtual terminal:\
                    :DO=\E[%dB:LE=\E[%dD:RI=\E[%dC:UP=\E[%dA:bs:bt=\E[Z:\
                    :cd=\E[J:ce=\E[K:cl=\E[H\E[J:cm=\E[%i%d;%dH:ct=\E[3g:\
                    :do=^J:nd=\E[C:pt:rc=\E8:rs=\Ec:sc=\E7:st=\EH:up=\EM:\
                    :le=^H:bl=^G:cr=^M:it#8:ho=\E[H:nw=\EE:ta=^I:is=\E)0:\
                    :li#60:co#146:am:xn:xv:LP:sr=\EM:al=\E[L:AL=\E[%dL:\
                    :cs=\E[%i%d;%dr:dl=\E[M:DL=\E[%dM:dc=\E[P:DC=\E[%dP:\
                    :im=\E[4h:ei=\E[4l:mi:IC=\E[%d@:ks=\E[?1h\E=:\
                    :ke=\E[?1l\E>:vi=\E[?25l:ve=\E[34h\E[?25h:vs=\E[34l:\
                    :ti=\E[?1049h:te=\E[?1049l:us=\E[4m:ue=\E[24m:so=\E[3m:\
                    :se=\E[23m:mb=\E[5m:md=\E[1m:mr=\E[7m:me=\E[m:ms:\
                    :Co#8:pa#64:AF=\E[3%dm:AB=\E[4%dm:op=\E[39;49m:AX:\
                    :vb=\Eg:G0:as=\E(0:ae=\E(B:\
                    :ac=\140\140aaffggjjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~..--++,,hhII00:\
                    :po=\E[5i:pf=\E[4i:Z0=\E[?3h:Z1=\E[?3l:k0=\E[10~:\
                    :k1=\EOP:k2=\EOQ:k3=\EOR:k4=\EOS:k5=\E[15~:k6=\E[17~:\
                    :k7=\E[18~:k8=\E[19~:k9=\E[20~:k;=\E[21~:F1=\E[23~:\
                    :F2=\E[24~:F3=\EO2P:F4=\EO2Q:F5=\EO2R:F6=\EO2S:\
                    :F7=\E[15;2~:F8=\E[17;2~:F9=\E[18;2~:FA=\E[19;2~:kb=:\
                    :K2=\EOE:kB=\E[Z:kF=\E[1;2B:kR=\E[1;2A:*4=\E[3;2~:\
                    :*7=\E[1;2F:#2=\E[1;2H:#3=\E[2;2~:#4=\E[1;2D:%c=\E[6;2~:\
                    :%e=\E[5;2~:%i=\E[1;2C:kh=\E[1~:@1=\E[1~:kH=\E[4~:\
                    :@7=\E[4~:kN=\E[6~:kP=\E[5~:kI=\E[2~:kD=\E[3~:ku=\EOA:\
                    :kd=\EOB:kr=\EOC:kl=\EOD:km:
            STY=17204.pts-3.sapmdmsaaslabdb
            INPUTRC=/etc/inputrc
            PWD=/home/dfishbur
            JAVA_HOME=/usr/java/default
            LANG=en_US.UTF-8
            SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
            SHLVL=3
            HOME=/home/dfishbur
            LOGNAME=dfishbur
            WINDOW=3
            CVS_RSH=ssh
            LESSOPEN=|/usr/bin/lesspipe.sh %s
            G_BROKEN_FILENAMES=1
            _=/bin/env


            If you can suggest a good place to ask this and work with someone I am all ears.

            Thanks,
            David



            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          Your message has been successfully submitted and would be delivered to recipients shortly.