Loading ...
Sorry, an error occurred while loading the content.

Re: Indentation issue

Expand Messages
  • Steve
    Hi, Just for the record, maybe someone will need this one day. For the fo+=2 option to work well, one needs to turn autoindenting off. I tried putting set
    Message 1 of 8 , Jun 25, 2013
    • 0 Attachment
      Hi,

      Just for the record, maybe someone will need this one day. For the
      fo+=2 option to work well, one needs to turn autoindenting off. I tried
      putting 'set noautoindent' in several files but it didn't work
      (something somewhere just activated it back on). So I finally found how
      to do it properly. Create a file called ~/.vim/indent/mail.vim (if you
      don't want this for writing emails, for html, it would be html.vim for
      ex.) with this one line:

      let b:did_indent = 1

      and you're done. The reason it works is given here:

      http://vim.wikia.com/wiki/How_to_stop_auto_indenting

      Have a nice day,
      steve


      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.