Loading ...
Sorry, an error occurred while loading the content.

Re: Where to put "set iskeyword+=_" or remove "iskeyword-=_

Expand Messages
  • Paul
    Ben, thanks for pointing out the need to modify my rtp after setting $HOME: let $HOME=$USERPROFILE. /Documents set rtp^=$HOME/vimfiles set
    Message 1 of 16 , Jun 21, 2013
    • 0 Attachment
      Ben, thanks for pointing out the need to modify my rtp after setting $HOME:

      let $HOME=$USERPROFILE."/Documents"
      set rtp^=$HOME/vimfiles
      set rtp+=$HOME/vimfiles/after

      The file $HOME/vimfiles/after/syntax/tex.vim is now executed when syntax is enabled in a tex file:

      setg isk+=_
      setlocal isk+=_

      I don't want to mess around with $HOME in the larger Windows 7 environment because I don't control how IT works around here. If it doesn't break something now, it could break something in the distant future when I've all but forgotten about this little customization. So I will localize the customization to vim.

      Gary, being the weekend warrior that I am, I don't think I can respond authoritatively about when rtp is set relative to the sourcing of _vimrc, but here's my take.

      In ":help startup", step 4 uses :runtime. The help for :runtime sounds like it presumes that rtp is already set. So it looks like there isn't really basis for assuming that rtp is set at step 4. I can't find documentation on where it is set, but it could very well be set before any of the numbered startup steps. For that matter, the default value for rtp might be captured early on as well, which could explain why "set rtp&" still gets you the rtp resulting from the $HOME that is in effect when vim is executed.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.