Loading ...
Sorry, an error occurred while loading the content.

txtfmt not starting the prompt on \i

Expand Messages
  • ankur
    Hello, I have extracted the tar file for txtfmt and then open a new file with vim. ... Now I was hoping to get the pompt after typing - i (in the normal mode)
    Message 1 of 6 , Jun 18, 2013
    • 0 Attachment
      Hello,

      I have extracted the tar file for txtfmt and then open a new file with vim.
      Then I tried following commands:
      :set ft=txtfmt
      :let maplocalleader = "-"
      :map -\ \DoItNow

      Now I was hoping to get the pompt after typing -\i (in the normal mode) to
      allow me change the color etc. But typing -\i or \i gets me into the Insert
      mode of vim. The :MakeTestPage command is showing me different colors and
      formats, (but I couldn't do the same in a new file or the scratch space
      opened with MakeTestPage).

      Can someone recommend me steps to activate the prompt using <LocalLeader>.

      Ankur



      --
      View this message in context: http://vim.1045645.n5.nabble.com/txtfmt-not-starting-the-prompt-on-i-tp5716065.html
      Sent from the Vim - General mailing list archive at Nabble.com.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Assuming txtfmt is set up to follow the local leader, try setting filetype AFTER setting the localleader. Also try typing -i instead of - i, the local
      Message 2 of 6 , Jun 18, 2013
      • 0 Attachment
        On Tuesday, June 18, 2013 2:16:03 AM UTC-5, ankur gupta wrote:
        > Hello,
        >
        >
        >
        > I have extracted the tar file for txtfmt and then open a new file with vim.
        >
        > Then I tried following commands:
        >
        > :set ft=txtfmt
        >
        > :let maplocalleader = "-"
        >
        > :map -\ \DoItNow
        >
        >
        >
        > Now I was hoping to get the pompt after typing -\i (in the normal mode) to
        >
        > allow me change the color etc. But typing -\i or \i gets me into the Insert
        >
        > mode of vim. The :MakeTestPage command is showing me different colors and
        >
        > formats, (but I couldn't do the same in a new file or the scratch space
        >
        > opened with MakeTestPage).
        >
        >
        >
        > Can someone recommend me steps to activate the prompt using <LocalLeader>.
        >

        Assuming txtfmt is set up to follow the local leader, try setting filetype AFTER setting the localleader. Also try typing -i instead of -\i, the local leader REPLACES the \, it does not PRECEDE the \.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • ankur
        Hi, Thanks for clarifying the localleader concept. Since I have just extracted the tar file of the package in my ~/.vim directory, I am not sure how to set the
        Message 3 of 6 , Jun 18, 2013
        • 0 Attachment
          Hi,
          Thanks for clarifying the localleader concept. Since I have just extracted
          the tar file of the package in my ~/.vim directory, I am not sure how to set
          the txtfmt to follow the local leader, so that when I type -i (or similar)
          it shows me prompt to enter formatting commands... (such as cg for green
          color text)

          The steps I followed after extracting the tar file
          :let maplocalleader = "-"
          :set ft=txtfmt

          I am not sure if following is also needed
          :map - \DoItNow

          Basically I am trying to find a way, such that, typing <LocalLeader>i will
          not lead to insert mode, rather prompts me to type more txtfmt tokens..

          Thanks for quick reply,
          Ankur



          --
          View this message in context: http://vim.1045645.n5.nabble.com/txtfmt-not-starting-the-prompt-on-i-tp5716065p5716093.html
          Sent from the Vim - General mailing list archive at Nabble.com.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Brett Stahlman
          ... Ankur, I did... let maplocalleader = - set ft=txtfmt ...just as you did, and -i brings up the Txtfmt prompt for me. Things to check... Do you have
          Message 4 of 6 , Jun 18, 2013
          • 0 Attachment
            On Tuesday, June 18, 2013 11:20:18 AM UTC-5, ankur gupta wrote:
            > Hi,
            >
            > Thanks for clarifying the localleader concept. Since I have just extracted
            >
            > the tar file of the package in my ~/.vim directory, I am not sure how to set
            >
            > the txtfmt to follow the local leader, so that when I type -i (or similar)
            >
            > it shows me prompt to enter formatting commands... (such as cg for green
            >
            > color text)
            >
            >
            >
            > The steps I followed after extracting the tar file
            >
            > :let maplocalleader = "-"
            >
            > :set ft=txtfmt
            >
            >
            >
            > I am not sure if following is also needed
            >
            > :map - \DoItNow
            >
            >
            >
            > Basically I am trying to find a way, such that, typing <LocalLeader>i will
            >
            > not lead to insert mode, rather prompts me to type more txtfmt tokens..

            Ankur,
            I did...
            let maplocalleader = "-"
            set ft=txtfmt
            ...just as you did, and -i brings up the Txtfmt prompt for me.

            Things to check...

            Do you have filetype plugins enabled: e.g., a line similar to...
            :filetype plugin on
            ...somewhere in your vimrc?

            Do you see ftplugin/txtfmt.vim in the output of...
            :scriptnames
            ...after you set ft=txtfmt?

            Brett S.

            >
            >
            >
            > Thanks for quick reply,
            >
            > Ankur
            >
            >
            >
            >
            >
            >
            >
            > --
            >
            > View this message in context: http://vim.1045645.n5.nabble.com/txtfmt-not-starting-the-prompt-on-i-tp5716065p5716093.html
            >
            > Sent from the Vim - General mailing list archive at Nabble.com.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • ankur
            Thanks Brett, My filetype plugin wasn t on. After setting it on, I could now get txtfmt prompt and use it to color/format text in my files... Thanks a lot for
            Message 5 of 6 , Jun 19, 2013
            • 0 Attachment
              Thanks Brett,

              My filetype plugin wasn't on. After setting it on, I could now get txtfmt
              prompt and use it to color/format text in my files...

              Thanks a lot for developing the plugin/package.. I have two unrelated
              issues..

              First, (general vim syntax related) can I define multiple comments, ie, to
              let the colorscheme recognize multiple markers at the start of line (say #
              to color blue and * to color red).
              Secondly not directly related to txtfmt, but to notes plugin. I want to
              apply 'notes' plugin to any random directory, but following allows me to
              specify those directories.
              :let g:notes_directories = ['~/Documents/Notes', '~/Dropbox/Shared Notes']
              Is there a way to atleast allow me to use directory structure (upto any
              level) within a specified directory..

              Ankur




              --
              View this message in context: http://vim.1045645.n5.nabble.com/txtfmt-not-starting-the-prompt-on-i-tp5716065p5716135.html
              Sent from the Vim - General mailing list archive at Nabble.com.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Stahlman%20Family
              ... No problem. I m glad you find it useful. ... If I understand what you re after, you want to be able to specify a path like... ~/BaseDir/** ... Brett S. ...
              Message 6 of 6 , Jun 19, 2013
              • 0 Attachment
                ----- Original Message -----
                > From: "ankur" <guptaankur1583@...>
                > To: vim@...
                > Sent: Wednesday, June 19, 2013 5:14:43 AM
                > Subject: Re: txtfmt not starting the prompt on \i
                > Thanks Brett,
                >
                > My filetype plugin wasn't on. After setting it on, I could now get
                > txtfmt
                > prompt and use it to color/format text in my files...
                >
                > Thanks a lot for developing the plugin/package..

                No problem. I'm glad you find it useful.

                > I have two unrelated issues..
                >
                > First, (general vim syntax related) can I define multiple comments,
                > ie, to
                > let the colorscheme recognize multiple markers at the start of line
                > (say #
                > to color blue and * to color red).
                > Secondly not directly related to txtfmt, but to notes plugin. I want
                > to
                > apply 'notes' plugin to any random directory, but following allows me
                > to
                > specify those directories.
                > :let g:notes_directories = ['~/Documents/Notes', '~/Dropbox/Shared
                > Notes']
                > Is there a way to atleast allow me to use directory structure (upto
                > any
                > level) within a specified directory..

                If I understand what you're after, you want to be able to specify a path like...
                ~/BaseDir/**
                ...to have all directories below BaseDir included in the search? Vim supports the `**' syntax, but I'm not sure how the notes plugin does its search. Perhaps the plugin author will weigh in...
                :help **

                Brett S.

                >
                > Ankur
                >
                >
                >
                >
                > --
                > View this message in context:
                > http://vim.1045645.n5.nabble.com/txtfmt-not-starting-the-prompt-on-i-tp5716065p5716135.html
                > Sent from the Vim - General mailing list archive at Nabble.com.
                >
                > --
                > --
                > You received this message from the "vim_use" maillist.
                > Do not top-post! Type your reply below the text you are replying to.
                > For more information, visit http://www.vim.org/maillist.php
                >
                > ---
                > You received this message because you are subscribed to the Google
                > Groups "vim_use" group.
                > To unsubscribe from this group and stop receiving emails from it, send
                > an email to vim_use+unsubscribe@....
                > For more options, visit https://groups.google.com/groups/opt_out.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.