Loading ...
Sorry, an error occurred while loading the content.

error M:\_viminfo!

Expand Messages
  • steve
    Im using vim on windows 7 this is in a domain environment. Sometimes when the M: network drive is not conencted I get this error when IM exiting the program.
    Message 1 of 11 , Jun 16, 2013
    • 0 Attachment
      Im using vim on windows 7 this is in a domain environment.

      Sometimes when the M: network drive is not conencted I get this error when IM exiting the program. This is odd because started VIM on the C:\ drive.

      I know that you can set up local configuration files that set up where the tmp file goes an I suppose 100's of other settings.
      M:\_viminfo!

      The version I use is I want the temp files etc to be on the c drive. For many reasons but one of my concerns is that the tmp files that are created are left behind on the M: drive thus creating a security risk, when I use the -x option.

      Anyway can anyone tell me how to stop this and maybe why its trying to do things on M:

      VIM - Vi IMproved

      version 7.2
      by Bram Moolenaar et al.
      Vim is open source and freely distributable

      Sponsor Vim development!
      type :help sponsor<Enter> for information

      type :q<Enter> to exit
      type :help<Enter> or <F1> for on-line help
      type :help version7<Enter> for version info


      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... By default _viminfo goes into whatever Vim sees as $HOME . This is the same place used for your _vimrc and vimfiles directories. You can fix this in a
      Message 2 of 11 , Jun 16, 2013
      • 0 Attachment
        On Sunday, June 16, 2013 6:02:10 AM UTC-5, steve wrote:
        > Im using vim on windows 7 this is in a domain environment.
        >
        > Sometimes when the M: network drive is not conencted I get this error when IM exiting the program. This is odd because started VIM on the C:\ drive.
        >
        > I know that you can set up local configuration files that set up where the tmp file goes an I suppose 100's of other settings.
        > M:\_viminfo!
        >
        > The version I use is I want the temp files etc to be on the c drive. For many reasons but one of my concerns is that the tmp files that are created are left behind on the M: drive thus creating a security risk, when I use the -x option.
        >
        > Anyway can anyone tell me how to stop this and maybe why its trying to do things on M:

        By default _viminfo goes into whatever Vim sees as "$HOME". This is the same place used for your _vimrc and vimfiles directories.

        You can fix this in a couple ways.

        First, you could set the HOME environment variable in Windows, to point to somewhere on your C: drive. This will make Vim look in the C: drive for your config files like _vimrc and vimfiles/plugin and such. In my experience Vim is much faster with local config files. Where I work it can take up to 40 seconds for Vim to launch when my config files are on a network share (depending on network load) where it only takes 1-3 seconds when they are stored on my hard drive.

        If you don't want to set HOME, you could add an "n" flag with the path you want to your 'viminfo' option. See :help 'viminfo' for details.

        >
        > VIM - Vi IMproved
        >
        > version 7.2
        > by Bram Moolenaar et al.
        > Vim is open source and freely distributable
        >
        > Sponsor Vim development!
        > type :help sponsor<Enter> for information
        >
        > type :q<Enter> to exit
        > type :help<Enter> or <F1> for on-line help
        > type :help version7<Enter> for version info

        This is a VERY old version. Try 7.3.829 from http://sourceforge.net/projects/cream/files/Vim/ (currently the most recent available from that project). Although, 7.4 should be out soon-ish too.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Stevew
        It has taken me some time to get to this and investigate. Unfortuetely the two helpfull suggestions given I cant really do. I cant change the $HOME in the
        Message 3 of 11 , Sep 20, 2013
        • 0 Attachment
          It has taken me some time to get to this and investigate.

          Unfortuetely the two helpfull suggestions given I cant really do.
          I cant change the $HOME in the Windows computer and the -n flag actually turns off the swap file from what I read. I do want a swap file if there is a crash or something I want to recover the file.

          so is there another way of setting up the swap file so taht it will set it to c:\temp for exemaple. Instead of the $HOME that windows users.
          Thanks.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Ben Fritz
          ... Then you read it wrong. ... If the last thing in your viminfo option is an n character followed by a path to a file, Vim will use that file as the
          Message 4 of 11 , Sep 20, 2013
          • 0 Attachment
            On Friday, September 20, 2013 1:37:15 PM UTC-5, Stevew wrote:
            > the -n flag actually turns off the swap file from what I read. I do want a swap file if there is a crash or something I want to recover the file.
            >

            Then you read it wrong.

            :help 'viminfo' gives you a list of flags that can go in the option.

            If the last thing in your 'viminfo' option is an 'n' character followed by a path to a file, Vim will use that file as the viminfo file.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Stevew
            ... Unfortunetely the help file does not seem to be installed. I went on-line and found this below. Perhaps I dont understand it or the version of vim Im using
            Message 5 of 11 , Sep 20, 2013
            • 0 Attachment
              > Then you read it wrong.

              Unfortunetely the help file does not seem to be installed.
              I went on-line and found this below.
              Perhaps I dont understand it or the version of vim Im using is different.

              However please note " No swap file will be used. Recovery after a crash will be
              impossible."

              Regards

              Full Quote:

              No swap file will be used. Recovery after a crash will be
              impossible. Handy if you want to view or edit a file on a
              very slow medium (e.g., a floppy).
              Can also be done with ":set updatecount=0". You can switch it
              on again by setting the 'updatecount' option to some value,
              e.g., ":set uc=100".
              NOTE: Don't combine -n with -b, making -nb, because that has a
              different meaning: |-nb|.
              'updatecount' is set to 0 AFTER executing commands from a
              vimrc file, but before the GUI initializations. Thus it
              overrides a setting for 'updatecount' in a vimrc file, but not
              in a gvimrc file. See |startup|.
              When you want to reduce accesses to the disk (e.g., for a
              laptop), don't use "-n", but set 'updatetime' and
              'updatecount' to very big numbers, and type ":preserve" when
              you want to save your work. This way you keep the possibility
              for crash recovery.
              {not in Vi}

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Stevew
              Ok after several failed attempts this seems to work. set viminfo+=nc: temp _viminfo When you said flag I thought you meant something like ... vi -n thanks.
              Message 6 of 11 , Sep 20, 2013
              • 0 Attachment
                Ok after several failed attempts this seems to work.

                set viminfo+=nc:\\temp\\_viminfo

                When you said flag I thought you meant something like ...
                vi -n

                thanks.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Ben Fritz
                ... So...:help viminfo gives an error? What error? I have no idea how somebody on a Windows system managed to get an install with the help documents. Vim s
                Message 7 of 11 , Sep 20, 2013
                • 0 Attachment
                  On Friday, September 20, 2013 3:08:43 PM UTC-5, Stevew wrote:
                  > > Then you read it wrong.
                  >
                  > Unfortunetely the help file does not seem to be installed.

                  So...:help 'viminfo' gives an error? What error?

                  I have no idea how somebody on a Windows system managed to get an install with the help documents. Vim's :help system is one of the best things about the editor, I suggest you fix this problem ASAP.

                  What does :echo $VIMRUNTIME tell you? Does that directory exist? Is there a "doc" folder there?

                  What does :set runtimepath? tell you? Is that $VIMRUNTIME directory there?

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                • Gooderam
                  The copy of Vi Im using has no docs folder etc. To tell you the truth of the matter is that I have been using vi for many years. Im unclear if years ago on
                  Message 8 of 11 , Sep 27, 2013
                  • 0 Attachment
                    The copy of Vi Im using has no docs folder etc. To tell you the truth of the matter is that I have been using vi for many years. Im unclear if years ago on Unix when I started using it, if there was much of a sofisticated help as you have described. Certainly you could not get it via f keys accept if you did some magic which I dont know. So really I have plugged along without all the nice features, which probably are helpfull.

                    The reason I like vi is because I can put that one program on a floppy disk, usb stick or anywhere and then I cant edit files with some attitute.
                    Im unclear if I installaed this vi from a proper windows install or just copyed it from one computer to another, because I just like it.

                    I suppose I should look into it to get the most out of it.

                    I do have a question though. Vi has worked well for me on this computer for many years. (windows 7) But now when I press ESC to exit from the text mode. It does not work. I have discovered that F1 sort of works. But it gives me an error as well, E433: No tags file and E149: Sorry, no help for help.txt and Press Enter or type command to continue. Then I am it the right mode like I press ed ESC. I dont know why this has changed. I dont recall changing anything.

                    Is there any way to get back my ESC.

                    --
                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php

                    ---
                    You received this message because you are subscribed to the Google Groups "vim_use" group.
                    To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                    For more options, visit https://groups.google.com/groups/opt_out.
                  • Ben Fritz
                    ... What DOES happen when you hit ESC in insert mode? ESC is an extremely basic feature and it should always work. Unless, of course: 1. You have an
                    Message 9 of 11 , Sep 27, 2013
                    • 0 Attachment
                      On Friday, September 27, 2013 9:43:18 AM UTC-5, Gooderam wrote:
                      >
                      > I do have a question though. Vi has worked well for me on this computer for many years. (windows 7) But now when I press ESC to exit from the text mode. It does not work. I have discovered that F1 sort of works. But it gives me an error as well, E433: No tags file and E149: Sorry, no help for help.txt and Press Enter or type command to continue. Then I am it the right mode like I press ed ESC. I dont know why this has changed. I dont recall changing anything.
                      >
                      > Is there any way to get back my ESC.

                      What DOES happen when you hit ESC in insert mode? ESC is an extremely basic feature and it should always work.

                      Unless, of course:
                      1. You have an insert-mode mapping for <ESC>
                      2. You have the option 'insertmode' set
                      3. You are using Vim in "easy mode" (i.e. your Vim is named "evim", or you launch it as "vim -y" or "gvim -y")

                      Are any of these true?

                      --
                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      ---
                      You received this message because you are subscribed to the Google Groups "vim_use" group.
                      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                      For more options, visit https://groups.google.com/groups/opt_out.
                    • Stevew
                      Ok well you caused me to think about things a bit and I think I resolved it. Here is what I did. There is one file that I opwn every day and use all the time.
                      Message 10 of 11 , Sep 27, 2013
                      • 0 Attachment
                        Ok well you caused me to think about things a bit and I think I resolved it.
                        Here is what I did.
                        There is one file that I opwn every day and use all the time. This is the file that had the problem. It is an encrypted file -X.
                        I decided to open it and then do a :w out.txt
                        then exit and then open the out.txt with a -X Now the problem went away. Maybe this file had some characters in it that caused the problems.

                        Second thing I did. I went to the _vimrc file. I had been using # comment out lines. I figured it was the same as a script file on linux or unix. Its been that way for some time. Well I guess I was wrong It's suppose to be
                        " Programing type comment.
                        Correct me if Im wrong?
                        I discovered this because even with me rewriting the file out, while fixed, now when it was opening it was showing odd things at the bottom in the information :command line.

                        I think that has fixed it. Ive used this program for so long, many of these things are new to me when I went to windows. In fact at some point when I did install the vim.exe on windows (as I recall somewhere) I was at the time thinking to myself (angrily) cant they just leave it alone and just provde simple VI.exe
                        Let see if everything works now. Or if you have seen some error in my ways.
                        thanks.

                        --
                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        ---
                        You received this message because you are subscribed to the Google Groups "vim_use" group.
                        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                        For more options, visit https://groups.google.com/groups/opt_out.
                      • Charles Campbell
                        Stevew wrote: Second thing I did. I went to the _vimrc file. I had been using # comment out lines. I figured it was the same as a script file on linux or unix.
                        Message 11 of 11 , Sep 27, 2013
                        • 0 Attachment
                          Stevew wrote:

                          Second thing I did. I went to the _vimrc file. I had been using # comment out lines. I figured it was the same as a script file on linux or unix. Its been that way for some time. Well I guess I was wrong It's suppose to be
                          " Programing type comment.
                          Correct me if Im wrong?
                          I discovered this because even with me rewriting the file out, while fixed, now when it was opening it was showing odd things at the bottom in the information :command line.

                          VIm's comments similarly in the sense that a single character starts a
                          comment, but uses a leading double-quote (") instead of a hash mark (#).

                          Regards,
                          C Campbell

                          --
                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php

                          ---
                          You received this message because you are subscribed to the Google Groups "vim_use" group.
                          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                          For more options, visit https://groups.google.com/groups/opt_out.
                        Your message has been successfully submitted and would be delivered to recipients shortly.