Loading ...
Sorry, an error occurred while loading the content.

Re: Tab completion for argdo, bufdo, and tabdo

Expand Messages
  • Ben Fritz
    ... It s not a regular expression, it s a literal tab character (equivalent to the ASCII code for CTRL+I). -- -- You received this message from the vim_use
    Message 1 of 5 , Jun 12, 2013
    • 0 Attachment
      On Wednesday, June 12, 2013 3:04:49 PM UTC-5, Jean-Marcel Belmont wrote:
      > Hello:
      >
      > Is there any way to make Vim do tab completion in the command window actually
      > do tab completion with argdo, bufdo, and tabdo. I have noticed that when I
      > press tab in Vim command line window after entering tabdo that the regular
      > expression ^I appears. Also for commands like argdo I cannot use filename completion at all. Can anyone please explain what is happening?
      >

      It's not a regular expression, it's a literal tab character (equivalent to the ASCII code for CTRL+I).

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Jean-Marcel Belmont
      I see thanks for the clarification. ... -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are
      Message 2 of 5 , Jun 12, 2013
      • 0 Attachment
        I see thanks for the clarification.


        On Wed, Jun 12, 2013 at 6:14 PM, Ben Fritz <fritzophrenic@...> wrote:
        On Wednesday, June 12, 2013 3:04:49 PM UTC-5, Jean-Marcel Belmont wrote:
        > Hello:
        >
        > Is there any way to make Vim do tab completion in the command window actually
        > do tab completion with argdo, bufdo, and tabdo. I have noticed that when I
        > press tab in Vim command line window after entering tabdo that the regular
        > expression ^I appears. Also for commands like argdo I cannot use filename completion at all. Can anyone please explain what is happening?
        >

        It's not a regular expression, it's a literal tab character (equivalent to the ASCII code for CTRL+I).

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.



        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      Your message has been successfully submitted and would be delivered to recipients shortly.