Loading ...
Sorry, an error occurred while loading the content.

Re: Tab completion for argdo, bufdo, and tabdo

Expand Messages
  • Dominique Pellé
    ... Maybe I misunderstand what you re saying, but for me, pressing after :argdo or :bufdo completes as expected. However, it does not complete after
    Message 1 of 5 , Jun 12, 2013
    • 0 Attachment
      Jean-Marcel Belmont wrote:

      > Is there any way to make Vim do tab completion
      > in the command window actually
      > do tab completion with argdo, bufdo, and tabdo.

      Maybe I misunderstand what you're saying, but
      for me, pressing <tab> after :argdo or :bufdo
      completes as expected. However, it does not
      complete after tabdo. Attached patch fixes it.

      > Also for commands like argdo I cannot use filename completion
      > at all. Can anyone please explain what is happening?

      What command are you trying to complete with
      <tab> and what is expected?

      Dominique

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Jean-Marcel Belmont
      thanks for the patch. I was trying to do filename-completion with tabdo. On Wed, Jun 12, 2013 at 4:31 PM, Dominique Pellé ... -- -- You received this message
      Message 2 of 5 , Jun 12, 2013
      • 0 Attachment
        thanks for the patch. I was trying to do filename-completion with tabdo.


        On Wed, Jun 12, 2013 at 4:31 PM, Dominique Pellé <dominique.pelle@...> wrote:
        Jean-Marcel Belmont wrote:

        > Is there any way to make Vim do tab completion
        > in the command window actually
        > do tab completion with argdo, bufdo, and tabdo.

        Maybe I misunderstand what you're saying, but
        for me, pressing <tab> after :argdo or :bufdo
        completes as expected.  However, it does not
        complete after tabdo. Attached patch fixes it.

        > Also for commands like argdo I cannot use filename completion
        > at all. Can anyone please explain what is happening?

        What command are you trying to complete with
        <tab> and what is expected?

        Dominique

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.



        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • Ben Fritz
        ... It s not a regular expression, it s a literal tab character (equivalent to the ASCII code for CTRL+I). -- -- You received this message from the vim_use
        Message 3 of 5 , Jun 12, 2013
        • 0 Attachment
          On Wednesday, June 12, 2013 3:04:49 PM UTC-5, Jean-Marcel Belmont wrote:
          > Hello:
          >
          > Is there any way to make Vim do tab completion in the command window actually
          > do tab completion with argdo, bufdo, and tabdo. I have noticed that when I
          > press tab in Vim command line window after entering tabdo that the regular
          > expression ^I appears. Also for commands like argdo I cannot use filename completion at all. Can anyone please explain what is happening?
          >

          It's not a regular expression, it's a literal tab character (equivalent to the ASCII code for CTRL+I).

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Jean-Marcel Belmont
          I see thanks for the clarification. ... -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are
          Message 4 of 5 , Jun 12, 2013
          • 0 Attachment
            I see thanks for the clarification.


            On Wed, Jun 12, 2013 at 6:14 PM, Ben Fritz <fritzophrenic@...> wrote:
            On Wednesday, June 12, 2013 3:04:49 PM UTC-5, Jean-Marcel Belmont wrote:
            > Hello:
            >
            > Is there any way to make Vim do tab completion in the command window actually
            > do tab completion with argdo, bufdo, and tabdo. I have noticed that when I
            > press tab in Vim command line window after entering tabdo that the regular
            > expression ^I appears. Also for commands like argdo I cannot use filename completion at all. Can anyone please explain what is happening?
            >

            It's not a regular expression, it's a literal tab character (equivalent to the ASCII code for CTRL+I).

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.



            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          Your message has been successfully submitted and would be delivered to recipients shortly.