Loading ...
Sorry, an error occurred while loading the content.

polish characters

Expand Messages
  • Mikołaj Mańczak
    Hi, I ve got a problem with vim on my windows8 (64bit): i can t see all polish characters. I set encoding=utf-8 in _vimrc file but only some polish letters
    Message 1 of 4 , Jun 12, 2013
    • 0 Attachment
      Hi,
      I've got a problem with vim on my windows8 (64bit):
      i can't see all polish characters. I set encoding=utf-8 in _vimrc file but only some polish letters work("ć"; "ź"; "ę"). I've spent many hours on trying to fix it. Could you help?
      Thanks in advence.

      Regards, Mikołaj Mańczak

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Are you using a font that has glyphs for those characters? I m fond of Deja Vu fonts myself, they have a wide variety of glyphs. See
      Message 2 of 4 , Jun 12, 2013
      • 0 Attachment
        On Wednesday, June 12, 2013 10:59:37 AM UTC-5, Mikołaj Mańczak wrote:
        > Hi,
        >
        > I've got a problem with vim on my windows8 (64bit):
        >
        > i can't see all polish characters. I set encoding=utf-8 in _vimrc file but only some polish letters work("ć"; "ź"; "ę"). I've spent many hours on trying to fix it. Could you help?
        >

        Are you using a font that has glyphs for those characters?

        I'm fond of "Deja Vu" fonts myself, they have a wide variety of glyphs.

        See http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI and http://vim.wikia.com/wiki/Change_font if you need help setting a new font.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Marcin Szamotulski
        ... Hi, I use djvu fonts and they contain all the polish special letters ą , ę . I also stick to the default utf-8 in enc . Since I mostly use terminal
        Message 3 of 4 , Jun 13, 2013
        • 0 Attachment
          On 10:28 Wed 12 Jun , Ben Fritz wrote:
          > On Wednesday, June 12, 2013 10:59:37 AM UTC-5, Mikołaj Mańczak wrote:
          > > Hi,
          > >
          > > I've got a problem with vim on my windows8 (64bit):
          > >
          > > i can't see all polish characters. I set encoding=utf-8 in _vimrc file but only some polish letters work("ć"; "ź"; "ę"). I've spent many hours on trying to fix it. Could you help?
          > >
          >
          > Are you using a font that has glyphs for those characters?
          >
          > I'm fond of "Deja Vu" fonts myself, they have a wide variety of glyphs.
          >
          > See http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI and http://vim.wikia.com/wiki/Change_font if you need help setting a new font.
          >
          > --
          > --
          > You received this message from the "vim_use" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >
          > ---
          > You received this message because you are subscribed to the Google Groups "vim_use" group.
          > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          > For more options, visit https://groups.google.com/groups/opt_out.
          >

          Hi,

          I use djvu fonts and they contain all the polish special letters "ą",
          "ę". I also stick to the default utf-8 in 'enc'. Since I mostly use
          terminal vim I had to set the font for the terminal for that. If you
          use gvim you have to set guifont. Apparently the my guifont is set to:

          set guifont=Bitstream\ Vera\ Sans\ Mono\ 12,Bitstream\ Vera\ Sans\ Mono\ Oblique\ 12,DejaVu\ Sans\ Mono\ 12

          Polish letters also works with these fonts.

          Best regards,
          Marcin

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Axel Bender
          Czesc Mikolaj, no problems here (see attached pics); I m on Windows 7 (64 bit), and use DejaVuSansMono.ttf from SourceForge. Encoding is set to UTF-8. Can
          Message 4 of 4 , Jun 14, 2013
          • 0 Attachment
            Czesc Mikolaj,

            no problems here (see attached pics); I'm on Windows 7 (64 bit), and use "DejaVuSansMono.ttf" from SourceForge. Encoding is set to UTF-8. Can you provide a sample - non working - text?

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.