Loading ...
Sorry, an error occurred while loading the content.
 

Re: How to echo to stdout?

Expand Messages
  • Christian Brabandt
    Hi Peng! ... #v+ ~$ cat main.vimrc set t_ti= t_te= echo Hello world q ~$ vim -S main.vimrc Hello world ~$ #v- Alternatively, tell vim you are using a dumb
    Message 1 of 7 , Jun 2, 2013
      Hi Peng!

      On Sa, 01 Jun 2013, Peng Yu wrote:

      > Hi,
      >
      > The following command does not echo anything to stdout.
      >
      > ~/linux/bin/xplat/src/vim/vimS/main$ cat main.vimrc
      > :echo "Hello world"
      > :q
      > ~/linux/bin/xplat/src/vim/vimS/main$ vim -S main.vimrc

      :h xterm-screens

      #v+
      ~$ cat main.vimrc set t_ti= t_te=
      echo "Hello world"
      q
      ~$ vim -S main.vimrc
      Hello world
      ~$
      #v-

      Alternatively, tell vim you are using a dumb terminal (then you don't
      need to reset t_ti and t_te):

      #v+
      ~$ TERM=dumb vim -S main.vimrc

      Hello world
      ~$
      #v-

      regards,
      Christian
      --
      Es gibt Tiere, die kein Fleisch fressen, z.B. unsere Kühe. Wenn wir
      das Experiment machen könnten, eine Ochsenherde mit Fleisch zu
      füttern, so würden die Ochsen verrückt.
      -- Rudolf Steiner

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Peng Yu
      ... I m not sure what you meant here. Did you mean the following? vim -c set t_ti= t_te= -S main.vimrc But then I see many empty lines (more than a screen)
      Message 2 of 7 , Jun 2, 2013
        > #v+
        > ~$ cat main.vimrc set t_ti= t_te=
        > echo "Hello world"
        > q
        > ~$ vim -S main.vimrc
        > Hello world
        > ~$
        > #v-

        I'm not sure what you meant here. Did you mean the following?

        vim -c 'set t_ti= t_te=' -S main.vimrc

        But then I see many empty lines (more than a screen) printed before
        "Hello World" is printed.

        --
        Regards,
        Peng

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christian Brabandt
        Hi Peng! ... The email got messed up. ... Yes of course, because Vim draws a screen when starting. Try using the dumb terminal as I have show. This seems to
        Message 3 of 7 , Jun 2, 2013
          Hi Peng!

          On So, 02 Jun 2013, Peng Yu wrote:

          > > #v+
          > > ~$ cat main.vimrc set t_ti= t_te=
          > > echo "Hello world"
          > > q
          > > ~$ vim -S main.vimrc
          > > Hello world
          > > ~$
          > > #v-
          >
          > I'm not sure what you meant here. Did you mean the following?
          >
          > vim -c 'set t_ti= t_te=' -S main.vimrc

          The email got messed up.

          > But then I see many empty lines (more than a screen) printed before
          > "Hello World" is printed.

          Yes of course, because Vim draws a screen when starting. Try using the
          dumb terminal as I have show. This seems to work.


          regards,
          Christian
          --
          Bürokommunikation? Schreibtischgelaber!

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • John Little
          ... How about: $ cat main.vimrc redir! /tmp/main.out echo hello set ft? echo redir END q $ vim -S main.vimrc $ cat /tmp/main.out Regards, John Little --
          Message 4 of 7 , Jun 2, 2013
            On Sunday, June 2, 2013 11:29:04 PM UTC+12, Peng Yu wrote:
            > That is not what I'm looking for. I need to somehow redirect that
            > output that is not to stdout to stdout.
            >
            > For example, I want to see the output of "set filetype" on stdout.

            How about:

            $ cat main.vimrc
            redir! > /tmp/main.out
            echo "hello"
            set ft?
            echo ""
            redir END
            q
            $ vim -S main.vimrc
            $ cat /tmp/main.out

            Regards, John Little

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.