Loading ...
Sorry, an error occurred while loading the content.

VIM(Mercurial) +python3.2 on Debian wheezy: Could not load library function PySys_SetArgv

Expand Messages
  • paleywiener
    ./configure --enable-python3interp=dynamic --enable-gui=gtk2 --with-python3-config-dir=/usr/lib/python3.1/ make src/vim --version|grep pyth +cryptv
    Message 1 of 2 , Jun 1, 2013
    • 0 Attachment
      ./configure --enable-python3interp=dynamic --enable-gui=gtk2 --with-python3-config-dir=/usr/lib/python3.1/
      make
      src/vim --version|grep pyth

      +cryptv +linebreak -python +viminfo
      -cscope +lispindent +python3/dyn +vreplace

      but if i do: :python3 print('hi') I get:

      E448: Could not load library function PySys_SetArgv
      E263: Sorry, this command is disabled, the Python library could not be loaded.

      I've also tried 'static' and calling it with python3.2 with no luck.

      What am i doing wrong? I checked src/auto/ and this is what I see:


      configure:5035: checking --enable-perlinterp argument
      configure:5044: result: no
      configure:5221: checking --enable-pythoninterp argument
      configure:5230: result: no
      configure:5521: checking --enable-python3interp argument
      configure:5530: result: dynamic
      configure:5537: checking for python3
      configure:5555: found /usr/bin/python3
      configure:5567: result: /usr/bin/python3
      configure:5580: checking Python version
      configure:5589: result: 3.2
      configure:5592: checking Python's abiflags
      configure:5606: result: mu
      configure:5609: checking Python's install prefix
      configure:5618: result: /usr
      configure:5621: checking Python's execution prefix
      configure:5630: result: /usr
      configure:5652: checking Python's configuration directory
      configure:5673: result: /usr/lib/python3.2/config
      configure:5719: checking if -pthread should be used
      configure:5746: gcc -o conftest -g -O2 -pthread -I/usr/local/include -L/usr/local/lib conftest.c >&5
      configure:5746: $? = 0
      configure:5747: result: yes
      configure:5762: checking if compile and link flags for Python 3 are sane
      configure:5779: gcc -o conftest -g -O2 -I/usr/include/python3.2mu -DPYTHON3_HOME=L\"/usr\" -pthread -I/usr/l
      ocal/include -L/usr/local/lib conftest.c -L/usr/lib/python3.2/config -lpython3.2mu -lpthread -ldl -lutil -
      lm >&5
      <command-line>:0:16: warning: missing terminating " character [enabled by default]
      configure:5779: $? = 0
      configure:5780: result: yes
      configure:5970: checking --enable-tclinterp argument
      configure:5979: result: no

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • paleywiener
      fixed. i nuked the trailing / in --with-python3-config-dir=/usr/lib/python3.1/ Of course, I still can t get static to compile and gtk2.. -- -- You
      Message 2 of 2 , Jun 2, 2013
      • 0 Attachment
        fixed. i nuked the trailing '/' in '--with-python3-config-dir=/usr/lib/python3.1/'
        Of course, I still can't get 'static' to compile and gtk2..

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.