Loading ...
Sorry, an error occurred while loading the content.

Re: how to debug file type recognition

Expand Messages
  • Matteo Cavalleri
    ... the content of ~/.vim/bundle/vim2hs/ftdetect/heist.vim is just: autocmd BufNewFile,BufRead *.tpl setlocal filetype=heist the content of
    Message 1 of 9 , May 23, 2013
    • 0 Attachment
      > so the culprit is known, but the question is why? why the first file gets recognized one way and the second another way?

      the content of ~/.vim/bundle/vim2hs/ftdetect/heist.vim is just:

      autocmd BufNewFile,BufRead *.tpl setlocal filetype=heist

      the content of ~/.vim/ftplugin/smarty.vim is:

      au BufRead,BufNewFile *.tpl set filetype=smarty

      (plus some other code fir match it)

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Matteo Cavalleri
      ok, i finally found this in the documentation: When the same extension is used for two filetypes, Vim tries to guess what kind of file it is. This doesn t
      Message 2 of 9 , May 23, 2013
      • 0 Attachment
        ok, i finally found this in the documentation: "When the same extension is used for two filetypes, Vim tries to guess what kind of file it is. This doesn't always work." and "The files in the "ftdetect" directory are used after all the default checks, thus they can overrule a previously detected file type"

        so i suppose i should have done my homework a little bit harder. sorry for this, i'll try not to spam this group any longer :) thanks for your help

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Ben Fritz
        ... Files in the ftplugin directory should not be setting the filetype. That may be the culprit of your multiple loads as well. ftplugin/smarty.vim should only
        Message 3 of 9 , May 23, 2013
        • 0 Attachment
          On Thursday, May 23, 2013 3:36:57 AM UTC-5, Matteo Cavalleri wrote:
          > > so the culprit is known, but the question is why? why the first file gets recognized one way and the second another way?
          >
          > the content of ~/.vim/bundle/vim2hs/ftdetect/heist.vim is just:
          >
          > autocmd BufNewFile,BufRead *.tpl setlocal filetype=heist
          >
          > the content of ~/.vim/ftplugin/smarty.vim is:
          >
          > au BufRead,BufNewFile *.tpl set filetype=smarty
          >
          > (plus some other code fir match it)

          Files in the ftplugin directory should not be setting the filetype. That may be the culprit of your multiple loads as well. ftplugin/smarty.vim should only be running when you do "set ft=smarty" so setting it again is unnecessary at best.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Matteo Cavalleri
          ... looking back at my dotfiles git log i found that to be my first attempt to fix this issue, and that clearly shows that i didn t understand at all vim
          Message 4 of 9 , May 23, 2013
          • 0 Attachment
            > Files in the ftplugin directory should not be setting the filetype. That may be the culprit of your multiple loads as well. ftplugin/smarty.vim should only be running when you do "set ft=smarty" so setting it again is unnecessary at best.

            looking back at my dotfiles git log i found that to be my first attempt to fix this issue, and that clearly shows that i didn't understand at all vim plugins/filetypes ^__^ at least i should have learned something new.

            btw, after some tries i was able to fix the problem by removing that line from ftplugin/ and putting it inside ~/.vim/after/ftdetect/smarty.vim, ~/.vim/ftdetect/ wasn't enough to get my settings win over the other plugin ftdetect

            regarding my multiple loads i won't be at office till next monday, so i'll be unable to test this. i can try to replicate the issue here at home on my mac though. supposing os / system performance don't matter, i should be able to get the same result i have on my linux box

            thanks again for the help

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.