Loading ...
Sorry, an error occurred while loading the content.

Re: Fortran comments not continued

Expand Messages
  • Nicolas Bock
    They were set to formatoptions=tcql I added ro now, and it works. Beautiful! Thanks so much for your help, nick ... -- -- You received this message from the
    Message 1 of 3 , May 21, 2013
    • 0 Attachment
      They were set to

      formatoptions=tcql

      I added 'ro' now, and it works. Beautiful!

      Thanks so much for your help,

      nick


      On Tue, May 21, 2013 at 3:38 PM, Ben Fritz <fritzophrenic@...> wrote:
      On Tuesday, May 21, 2013 11:24:00 AM UTC-5, Nicolas Bock wrote:
      > Hi,
      >
      > When editing Fortran I
      >
      > set comments=s:!>,m:!!,e:!!,:!
      >
      > unfortunately, vim refuses to print the middle comment leader '!!' when I start a comment with '!>' or a simple '!' continuing a comment started with '!'. I don't understand why.
      >

      What are your 'formatoptions' set to? Specifically, do they include 'c' as well as 'o' and/or 'r'?

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.



      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    Your message has been successfully submitted and would be delivered to recipients shortly.