Loading ...
Sorry, an error occurred while loading the content.

Vim opens perl files slowly everytime

Expand Messages
  • Jean-Marcel Belmont
    Hello: Whenever I open a Perl file in vim with .pl file extension it takes many seconds for vim to open and when vim does open I see the following message in
    Message 1 of 6 , May 19, 2013
    • 0 Attachment
      Hello:

      Whenever I open a Perl file in vim with .pl file extension it takes many seconds for vim to open
      and when vim does open I see the following message in the vim command line
      Please install scripts to ~/.vim/bin

      This message appears whenever I open any Perl file in vim. Why is this occurring every time?
      I am using Mac OS X 10.7 and Vim 7.3 version in the terminal

      Sincerely,

      Jean-Marcel Belmont

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tony Mechelynck
      ... Which patchlevel? (When you do :version, does the reply include a line Included patches: near the top?) See http://ftp.vim.org/pub/vim/patches/7.3/README
      Message 2 of 6 , May 19, 2013
      • 0 Attachment
        On 20/05/13 00:22, Jean-Marcel Belmont wrote:
        > Hello:
        >
        > Whenever I open a Perl file in vim with .pl file extension it takes many seconds for vim to open
        > and when vim does open I see the following message in the vim command line
        > Please install scripts to ~/.vim/bin
        >
        > This message appears whenever I open any Perl file in vim. Why is this occurring every time?
        > I am using Mac OS X 10.7 and Vim 7.3 version in the terminal

        Which patchlevel? (When you do :version, does the reply include a line
        "Included patches:" near the top?) See
        http://ftp.vim.org/pub/vim/patches/7.3/README for a one-line description
        of each of the almost 1000 patches so far.

        >
        > Sincerely,
        >
        > Jean-Marcel Belmont
        >
        Best regards,
        Tony.
        --
        If you stick a stock of liquor in your locker,
        It is slick to stick a lock upon your stock.
        Or some joker who is slicker,
        Will trick you of your liquor,
        If you fail to lock your liquor with a lock.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Jean-Marcel Belmont
        ... Hello: When I ran the :version command in the command-line window there was no line for include patches. I have not run any patches in my vim version. I
        Message 3 of 6 , May 19, 2013
        • 0 Attachment
          On Sunday, May 19, 2013 7:05:04 PM UTC-4, Tony Mechelynck wrote:
          > On 20/05/13 00:22, Jean-Marcel Belmont wrote:
          >
          > > Hello:
          >
          > >
          >
          > > Whenever I open a Perl file in vim with .pl file extension it takes many seconds for vim to open
          >
          > > and when vim does open I see the following message in the vim command line
          >
          > > Please install scripts to ~/.vim/bin
          >
          > >
          >
          > > This message appears whenever I open any Perl file in vim. Why is this occurring every time?
          >
          > > I am using Mac OS X 10.7 and Vim 7.3 version in the terminal
          >
          >
          >
          > Which patchlevel? (When you do :version, does the reply include a line
          >
          > "Included patches:" near the top?) See
          >
          > http://ftp.vim.org/pub/vim/patches/7.3/README for a one-line description
          >
          > of each of the almost 1000 patches so far.
          >
          >
          >
          > >
          >
          > > Sincerely,
          >
          > >
          >
          > > Jean-Marcel Belmont
          >
          > >
          >
          > Best regards,
          >
          > Tony.
          >
          > --
          >
          > If you stick a stock of liquor in your locker,
          >
          > It is slick to stick a lock upon your stock.
          >
          > Or some joker who is slicker,
          >
          > Will trick you of your liquor,
          >
          > If you fail to lock your liquor with a lock.

          Hello:

          When I ran the :version command in the command-line window
          there was no line for include patches. I have not run any patches in my vim version. I recently recompiled vim in February 2013 to the /usr/local/ directory but have never ran a patch in vim before. Should I install a patch and which one if so, and how do I install as well?

          Many Thanks for any help,

          Jean-Marcel Belmont

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Tony Mechelynck
          ... You can get the Vim source and runtime files, with all 973 patches to date, by means of Mercurial, see
          Message 4 of 6 , May 20, 2013
          • 0 Attachment
            On 20/05/13 01:38, Jean-Marcel Belmont wrote:
            > On Sunday, May 19, 2013 7:05:04 PM UTC-4, Tony Mechelynck wrote:
            >> On 20/05/13 00:22, Jean-Marcel Belmont wrote:
            >>
            >>> Hello:
            >>
            >>>
            >>
            >>> Whenever I open a Perl file in vim with .pl file extension it takes many seconds for vim to open
            >>
            >>> and when vim does open I see the following message in the vim command line
            >>
            >>> Please install scripts to ~/.vim/bin
            >>
            >>>
            >>
            >>> This message appears whenever I open any Perl file in vim. Why is this occurring every time?
            >>
            >>> I am using Mac OS X 10.7 and Vim 7.3 version in the terminal
            >>
            >>
            >>
            >> Which patchlevel? (When you do :version, does the reply include a line
            >>
            >> "Included patches:" near the top?) See
            >>
            >> http://ftp.vim.org/pub/vim/patches/7.3/README for a one-line description
            >>
            >> of each of the almost 1000 patches so far.
            >>
            >>
            >>
            >>>
            >>
            >>> Sincerely,
            >>
            >>>
            >>
            >>> Jean-Marcel Belmont
            >>
            >>>
            >>
            >> Best regards,
            >>
            >> Tony.
            >>
            >> --
            >>
            >> If you stick a stock of liquor in your locker,
            >>
            >> It is slick to stick a lock upon your stock.
            >>
            >> Or some joker who is slicker,
            >>
            >> Will trick you of your liquor,
            >>
            >> If you fail to lock your liquor with a lock.
            >
            > Hello:
            >
            > When I ran the :version command in the command-line window
            > there was no line for include patches. I have not run any patches in my vim version. I recently recompiled vim in February 2013 to the /usr/local/ directory but have never ran a patch in vim before. Should I install a patch and which one if so, and how do I install as well?
            >
            > Many Thanks for any help,
            >
            > Jean-Marcel Belmont
            >
            You can get the Vim source and runtime files, with all 973 patches to
            date, by means of Mercurial, see
            http://vim.wikia.com/wiki/Getting_the_Vim_source_with_Mercurial

            To compile Vim on Unix-like systems, see
            http://users.skynet.be/antoine.mechelynck/vim/compunix.htm

            For a Vim GUI running on Mac OS X without the need for X11, there exists
            the MacVim port about which I hardly know anything (I'm on Linux). See
            http://www.vim.org/download.php#mac


            Best regards,
            Tony.
            --
            Systems have sub-systems and sub-systems have sub-systems and so on ad
            infinitum -- which is why we're always starting over.
            -- Epigrams in Programming, ACM SIGPLAN Sept. 1982

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Christian Brabandt
            Hi Jean-Marcel! ... Try using the --startuptime option to find out what causes this. I doubt, a newer Vim version will be considerably faster as I don t recall
            Message 5 of 6 , May 20, 2013
            • 0 Attachment
              Hi Jean-Marcel!

              On So, 19 Mai 2013, Jean-Marcel Belmont wrote:

              > Hello:
              >
              > Whenever I open a Perl file in vim with .pl file extension it takes many seconds for vim to open
              > and when vim does open I see the following message in the vim command line
              > Please install scripts to ~/.vim/bin
              >
              > This message appears whenever I open any Perl file in vim. Why is this occurring every time?
              > I am using Mac OS X 10.7 and Vim 7.3 version in the terminal

              Try using the --startuptime option to find out what causes this. I
              doubt, a newer Vim version will be considerably faster as I don't recall
              seeing patches that make vim load faster.

              My guess is, this is caused by the perlomni plugin. There is also an
              issue about a slow opening of perl files at
              https://github.com/c9s/perlomni.vim/pull/15
              which suggests, this has been successfully resolved, so you might also
              try to update the plugin. If a newer plugin doesn't help, you should
              probably reopen this issue, assuming the perl-omni plugin is really the
              culprit.

              regards,
              Christian
              --
              An und für sich ist jeder originell, weil er individuell ist; aber
              nicht jeder hat den Mut, er selber zu sein und zu scheinen; nur der
              Kräftige oder Berühmte oder Reiche hat ihn, weil er des Scheins
              entübrigt sein kann.
              -- Jean Paul

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Jean-Marcel Belmont
              Hello Christian: Many thanks for the suggestion, perlomni was the culprit for the slow startup time and message Please install scripts to ~/.vim/bin I have
              Message 6 of 6 , May 20, 2013
              • 0 Attachment
                Hello Christian:

                Many thanks for the suggestion, perlomni was the culprit for the slow startup time and message "Please install scripts to ~/.vim/bin"
                I have now went with the Perl support plugin from Fritz Mehner for Perl programming.

                Thank you,

                Jean-Marcel Belmont


                On Mon, May 20, 2013 at 7:33 AM, Christian Brabandt <cblists@...> wrote:
                Hi Jean-Marcel!

                On So, 19 Mai 2013, Jean-Marcel Belmont wrote:

                > Hello:
                >
                > Whenever I open a Perl file in vim with .pl file extension it takes many seconds for vim to open
                > and when vim does open I see the following message in the vim command line
                > Please install scripts to ~/.vim/bin
                >
                > This message appears whenever I open any Perl file in vim. Why is this occurring every time?
                > I am using Mac OS X 10.7 and Vim 7.3 version in the terminal

                Try using the --startuptime option to find out what causes this. I
                doubt, a newer Vim version will be considerably faster as I don't recall
                seeing patches that make vim load faster.

                My guess is, this is caused by the perlomni plugin. There is also an
                issue about a slow opening of perl files at
                https://github.com/c9s/perlomni.vim/pull/15
                which suggests, this has been successfully resolved, so you might also
                try to update the plugin. If a newer plugin doesn't help, you should
                probably reopen this issue, assuming the perl-omni plugin is really the
                culprit.

                regards,
                Christian
                --
                An und für sich ist jeder originell, weil er individuell ist; aber
                nicht jeder hat den Mut, er selber zu sein und zu scheinen; nur der
                Kräftige oder Berühmte oder Reiche hat ihn, weil er des Scheins
                entübrigt sein kann.
                                -- Jean Paul

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.



                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
                 
                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
                 
                 
              Your message has been successfully submitted and would be delivered to recipients shortly.