Loading ...
Sorry, an error occurred while loading the content.

kubuntu 13.04 green has changed

Expand Messages
  • John Little
    Hi all I recently upgraded my Kubuntu to 13.04, Raring Ringtail, and it has had a weird effect on gvim: the meaning of green in highlight statements has
    Message 1 of 4 , May 19, 2013
    • 0 Attachment
      Hi all

      I recently upgraded my Kubuntu to 13.04, Raring Ringtail, and it has had a weird effect on gvim: the meaning of "green" in highlight statements has changed, from #00FF00 to #008000. "blue" is still #0000FF and red is still #FF0000, but "green" is half as bright. "green1" remains #00FF00.

      Green is the only colour I've noticed, and I've checked a few with a colour picker; f.ex. "dark slate grey" is still what runtime/rgb.txt says it is, #2F4F4F.

      /usr/share/X11/rgb.txt still has "0 255 0 green".

      I've tried changing colour schemes, and other system settings, but nothing affects the colours gvim uses.

      Now I can easily work around this by replacing "green" with #00FF00, or "green1", but it's strange.

      Regards, John Little

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • pansz
      So you should mail to ubuntu group instead? (rgb.txt does not belong to kubuntu so you should ask ubuntu devs for that, or fire a bug on launchpad.net) ... --
      Message 2 of 4 , May 19, 2013
      • 0 Attachment
        So you should mail to ubuntu group instead? (rgb.txt does not belong to kubuntu so you should ask ubuntu devs for that, or fire a bug on launchpad.net)


        On Sun, May 19, 2013 at 7:30 PM, John Little <John.B.Little@...> wrote:
        Hi all

        I recently upgraded my Kubuntu to 13.04, Raring Ringtail, and it has had a weird effect on gvim: the meaning of "green" in highlight statements has changed, from #00FF00 to #008000. "blue" is still #0000FF and red is still #FF0000, but "green" is half as bright. "green1" remains #00FF00.

        Green is the only colour I've noticed, and I've checked a few with a colour picker; f.ex. "dark slate grey" is still what runtime/rgb.txt says it is, #2F4F4F.

        /usr/share/X11/rgb.txt still has "0 255   0             green".

        I've tried changing colour schemes, and other system settings, but nothing affects the colours gvim uses.

        Now I can easily work around this by replacing "green" with #00FF00, or "green1", but it's strange.

        Regards, John Little

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.



        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • John Little
        ... I m thinking surely there must be another gvim user using Kubuntu Raring, or Ubuntu Raring, and I wonder if their gvim green has changed. I will pose my
        Message 3 of 4 , May 19, 2013
        • 0 Attachment
          On Monday, May 20, 2013 2:29:32 PM UTC+12, pansz wrote:
          > So you should mail to ubuntu group instead? (rgb.txt does not belong to kubuntu so you should ask ubuntu devs for that, or fire a bug on launchpad.net)

          I'm thinking surely there must be another gvim user using Kubuntu Raring, or Ubuntu Raring, and I wonder if their gvim green has changed. I will pose my question on a Kubuntu forum, but because gvim is a GTK app, I don't expect much attention.

          If I use the colour picker in a KDE app, such as kate or konsole, and use the "named colours" selection, "green" is still #00FF00, aka 0 255 0.

          (I happen to use green a lot, a habit gained in the days of poor quality CGA monitors; because green is the middle phosphor of R G and B, using green would be less blurry.)

          Regards, John Little

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Christian Brabandt
          Hi John! ... Please check the output of showrgb |grep green It seems to me, that your X server now uses a different green definition (W3C instead of X11
          Message 4 of 4 , May 21, 2013
          • 0 Attachment
            Hi John!

            On So, 19 Mai 2013, John Little wrote:

            > On Monday, May 20, 2013 2:29:32 PM UTC+12, pansz wrote:
            > > So you should mail to ubuntu group instead? (rgb.txt does not belong to kubuntu so you should ask ubuntu devs for that, or fire a bug on launchpad.net)
            >
            > I'm thinking surely there must be another gvim user using Kubuntu Raring, or Ubuntu Raring, and I wonder if their gvim green has changed. I will pose my question on a Kubuntu forum, but because gvim is a GTK app, I don't expect much attention.
            >
            > If I use the colour picker in a KDE app, such as kate or konsole, and use the "named colours" selection, "green" is still #00FF00, aka 0 255 0.
            >
            > (I happen to use green a lot, a habit gained in the days of poor quality CGA monitors; because green is the middle phosphor of R G and B, using green would be less blurry.)

            Please check the output of showrgb |grep green

            It seems to me, that your X server now uses a different green definition
            (W3C instead of X11 definition). If this is the case, this should likely
            be reported to Ubuntu.

            regards,
            Christian
            --

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.