Loading ...
Sorry, an error occurred while loading the content.

Opening large files

Expand Messages
  • Rajesh Kannan
    G day, I recently saw mails in the group with regards to a new release and lots of people responsing with their suggestions. I lost that mail chain and hence I
    Message 1 of 7 , May 16 11:38 PM
    • 0 Attachment
      G'day,

      I recently saw mails in the group with regards to a new release and lots of people responsing with their suggestions. I lost that mail chain and hence I am writing a separate one with a suggestion.

      Could the programatically contributing members please try to make Vim faster when opening large files? Even when I open a file of say 2 megs it takes 3-4 seconds more than say Ultraedit. Larger text files, say about a 100 megs, take minutes to open.

      I am so used to Vim since my early days, I by default open everything editable in it. The only problem I see is when I open such large text files. Else I feel absolutely at home working with this wonderful editor.

      Cheers!
      RK

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Claus Atzenbeck
      ... There is the plugin LargeFile . Does this solve your issue to some extent? Best, Claus -- -- You
      Message 2 of 7 , May 16 11:54 PM
      • 0 Attachment
        On Fri, 17 May 2013 at 12:08pm +0530, Rajesh Kannan wrote:

        > Could the programatically contributing members please try to make Vim
        > faster when opening large files? Even when I open a file of say 2 megs it
        > takes 3-4 seconds more than say Ultraedit. Larger text files, say about a
        > 100 megs, take minutes to open.

        There is the plugin "LargeFile"
        <http://www.vim.org/scripts/script.php?script_id=1506>. Does this solve
        your issue to some extent?

        Best,
        Claus

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Rajesh Kannan
        I knew of it but never took the time to use that plugin as I have the option to open the larger files in Uedit. While trying to open the link you sent, the
        Message 3 of 7 , May 17 12:23 AM
        • 0 Attachment
          I knew of it but never took the time to use that plugin as I have the option to open the larger files in Uedit.

          While trying to open the link you sent, the website returns the an error opening that page.
          ---------
          Vim Online Error
          script:Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
          ---------
          Will try a little while later and see if this plugin helps as you seem to suggest.

          Regards.


          --
          Kind Regards,
          Rajesh Kannan
          =============
          The best index to a person's character is
          a) how he treats people who can't do him any good and
          b) how he treats people who can't fight back.
                                  -- Abigail Van Buren
          =============



          On 17 May 2013 12:24, Claus Atzenbeck <claus.atzenbeck@...> wrote:
          On Fri, 17 May 2013 at 12:08pm +0530, Rajesh Kannan wrote:

          Could the programatically contributing members please try to make Vim
          faster when opening large files? Even when I open a file of say 2 megs it
          takes 3-4 seconds more than say Ultraedit. Larger text files, say about a
          100 megs, take minutes to open.

          There is the plugin "LargeFile" <http://www.vim.org/scripts/script.php?script_id=1506>. Does this solve your issue to some extent?

          Best,
          Claus

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          --- You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@googlegroups.com.
          For more options, visit https://groups.google.com/groups/opt_out.



          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • Claus Atzenbeck
          ... Try again later. It works for me. You may also use as an alternative URI. ... I have never tested it myself, but
          Message 4 of 7 , May 17 12:31 AM
          • 0 Attachment
            On Fri, 17 May 2013 at 12:53pm +0530, Rajesh Kannan wrote:

            > While trying to open the link you sent, the website returns the an error
            > opening that page.

            Try again later. It works for me.

            You may also use <https://github.com/vim-scripts/LargeFile> as an
            alternative URI.

            > Will try a little while later and see if this plugin helps as you seem to
            > suggest.

            I have never tested it myself, but knew that it exists. Let me know it
            works for you.

            Best,
            Claus

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • John Beckett
            ... I just noticed that problem myself, and came here to see if there was a discussion. I will investigate the situation in an hour, if I get time, otherwise
            Message 5 of 7 , May 17 1:12 AM
            • 0 Attachment
              Rajesh Kannan wrote:
              > ---------
              > Vim Online Error
              > script:Can't connect to local MySQL server through socket
              > '/var/lib/mysql/mysql.sock' (2)
              > ---------

              I just noticed that problem myself, and came here to see if
              there was a discussion. I will investigate the situation in an
              hour, if I get time, otherwise not until tomorrow. There was a
              similar problem a couple of weeks ago.

              Re the script, you can probably find it by searching for
              LargeFile at the author's site:
              http://www.drchip.org/astronaut/vim/

              John

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • John Little
              ... 2 megs is not a large file these days; it should not take 3 or 4 seconds to load. On my 7 year old desktop it takes 700 ms to load a 4 MB text file, with
              Message 6 of 7 , May 17 1:18 AM
              • 0 Attachment
                On Friday, May 17, 2013 6:38:04 PM UTC+12, Rajesh Kannan wrote:
                >
                > Could the programatically contributing members please try to make Vim faster when opening large files? Even when I open a file of say 2 megs it takes 3-4 seconds more than say Ultraedit. Larger text files, say about a 100 megs, take minutes to open.

                2 megs is not a large file these days; it should not take 3 or 4 seconds to load. On my 7 year old desktop it takes 700 ms to load a 4 MB text file, with start up logging on, though I'd just created it so would be coming out of disc cache.

                I suggest diagnosing the problem by starting vim with the --startuptime command line option. F.ex.,

                gvim --startuptime time.txt file.txt

                and look at time.txt to find out where the delay is.

                I do use and like the large file plugin. By default it defines "large" as "20MB". Setting this to 200, so that the large file plugin is not used, a 100 MB text file I've just created took 4.3 s to load. With the large file plugin active, it takes a second longer, because a message appears for a second. From this I expect the plugin won't help you.

                I recall reports on this list of slowness starting vim on windows systems where the swap file is put on a network share. See :help 'directory'.

                Regards, and HTH, John Little

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • John Beckett
                ... The problem has been corrected, not by me, and vim.org works. John -- -- You received this message from the vim_use maillist. Do not top-post! Type your
                Message 7 of 7 , May 17 2:35 AM
                • 0 Attachment
                  >> ---------
                  >> Vim Online Error
                  >> script:Can't connect to local MySQL server through socket
                  >> '/var/lib/mysql/mysql.sock' (2)
                  >> ---------
                  >
                  > I just noticed that problem myself, and came here to see if
                  > there was a discussion. I will investigate the situation in
                  > an hour, if I get time, otherwise not until tomorrow. There
                  > was a similar problem a couple of weeks ago.

                  The problem has been corrected, not by me, and vim.org works.

                  John

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                Your message has been successfully submitted and would be delivered to recipients shortly.