Loading ...
Sorry, an error occurred while loading the content.

Re: Setting &titleold does not work

Expand Messages
  • Paul
    ... I see something similar with konsole. I have it set to Window title as set by shell (%w) , but when exiting vim, the title gets set to the name of the
    Message 1 of 6 , May 16, 2013
    • 0 Attachment
      On Thursday, 16 May, 2013 at 02:38:57 BST, Ryan wrote:
      >> > The title string works just fine. But, the title old does not appear to work. I am using xterm in
      >> >
      >> > Yakuake
      >> > Version 2.9.6
      >> > KDE Dev Platform 4.4.5
      >> >
      >> > The title after a quit is "Yakuake".
      >>
      >> to me this seems to be correct. ":help 'titleold'" says that this option
      >> is *only* used "if the original title cannot be restored".

      I see something similar with konsole. I have it set to "Window title as set by shell (%w)", but when exiting vim, the title gets set to the name of the konsole profile instead of the output produced by PROMPT_COMMAND. I think it's a bug in konsole, because PROMPT_COMMAND is being run, and I don't see this in other terminals, including xterm.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.