Loading ...
Sorry, an error occurred while loading the content.

Re: Setting &titleold does not work

Expand Messages
  • Paul
    ... Shouldn t you be setting it instead of letting it? -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the
    Message 1 of 6 , May 15, 2013
    • 0 Attachment
      On Tuesday, 14 May, 2013 at 23:48:26 BST, Ryan wrote:
      >I've tried to set the title as shown in the docs:
      >
      >set title
      >let &titlestring = "titlestring"
      >let &titleold = "titleold"

      Shouldn't you be setting it instead of letting it?

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Gary Johnson
      ... let &name is the same as set name . See ... Regards, Gary -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply
      Message 2 of 6 , May 15, 2013
      • 0 Attachment
        On 2013-05-15, Paul wrote:
        > On Tuesday, 14 May, 2013 at 23:48:26 BST, Ryan wrote:
        > >I've tried to set the title as shown in the docs:
        > >
        > >set title
        > >let &titlestring = "titlestring"
        > >let &titleold = "titleold"
        >
        > Shouldn't you be setting it instead of letting it?

        "let &name" is the same as "set name". See

        :help :let-&

        Regards,
        Gary

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Ryan
        ... That s not the original title as set by me in my precmd and jobcmd alias. So, I would say technically that it is not. I found a hack around on the net: set
        Message 3 of 6 , May 15, 2013
        • 0 Attachment
          On Wednesday, May 15, 2013 8:07:06 PM UTC+12, Jürgen Krämer wrote:
          > Hi,
          >
          >
          >
          > Ryan wrote:
          >
          > >
          >
          > > I've tried to set the title as shown in the docs:
          >
          > >
          >
          > > set title
          >
          > > let &titlestring = "titlestring"
          >
          > > let &titleold = "titleold"
          >
          > >
          >
          > > The title string works just fine. But, the title old does not appear to work. I am using xterm in
          >
          > >
          >
          > > Yakuake
          >
          > > Version 2.9.6
          >
          > > KDE Dev Platform 4.4.5
          >
          > >
          >
          > > The title after a quit is "Yakuake".
          >
          >
          >
          > to me this seems to be correct. ":help 'titleold'" says that this option
          >
          > is *only* used "if the original title cannot be restored".
          >
          >
          >
          > Regards,
          >
          > J�rgen
          >
          >
          >
          > --
          >
          > Sometimes I think the surest sign that intelligent life exists elsewhere
          >
          > in the universe is that none of it has tried to contact us. (Calvin)

          That's not the original title as set by me in my precmd and jobcmd alias. So, I would say technically that it is not.

          I found a hack around on the net:

          set title " show title in title bar
          let &titlestring = v:progname . " - " . " [" . $FILM . " " . $SCENE . " " . $SHOT . "]"
          auto BufEnter * let &titlestring = v:progname . " - " . expand("%:p") . " [" . $FILM . " " . $SCENE . " " . $SHOT . "]"
          function! ResetTitle()
          " disable vim's ability to set the title and let the precmd do it
          exec "set title t_ts='' t_fs=''"
          endfunction
          autocmd VimLeave * silent call ResetTitle()

          Of course when vim job is suspended this does not work. I need to investigate whether there is an autocommand for that case as well.





          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Paul
          ... I see something similar with konsole. I have it set to Window title as set by shell (%w) , but when exiting vim, the title gets set to the name of the
          Message 4 of 6 , May 16, 2013
          • 0 Attachment
            On Thursday, 16 May, 2013 at 02:38:57 BST, Ryan wrote:
            >> > The title string works just fine. But, the title old does not appear to work. I am using xterm in
            >> >
            >> > Yakuake
            >> > Version 2.9.6
            >> > KDE Dev Platform 4.4.5
            >> >
            >> > The title after a quit is "Yakuake".
            >>
            >> to me this seems to be correct. ":help 'titleold'" says that this option
            >> is *only* used "if the original title cannot be restored".

            I see something similar with konsole. I have it set to "Window title as set by shell (%w)", but when exiting vim, the title gets set to the name of the konsole profile instead of the output produced by PROMPT_COMMAND. I think it's a bug in konsole, because PROMPT_COMMAND is being run, and I don't see this in other terminals, including xterm.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.