Loading ...
Sorry, an error occurred while loading the content.

Re: vim consume huge memory and can cause oom stty rows/columns 65535

Expand Messages
  • John Little
    ... Interesting. Are you sure that s vim? On my Kubuntu 13.04, vi gives me vim 7.3.547 Huge version with GTK2 GUI Modified by
    Message 1 of 4 , May 13, 2013
    • 0 Attachment
      On Tuesday, May 14, 2013 7:57:45 AM UTC+12, jimmywang wrote:

      > With the following setting, vi can consume up to 40GB on my Linux (64 bit) machine:
      >
      > stty rows 65535
      > stty columns 65535
      > vi /tmp/foo

      Interesting.
      Are you sure that's vim? On my Kubuntu 13.04, vi gives me vim 7.3.547 "Huge version with GTK2 GUI" "Modified by pkg-vim-maintainers@..." and it clips lines to 1000 and columns to 10000, and only uses about 150 kiB.

      So, which Linux distro? And when you run "vi", what does

      :ver

      say? What does (in your shell)

      ls -l /etc/alternatives/vi

      say?

      Regards, John Little

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • jimmywang
      ... John, This comes from redhat linux distro/CentOS. VIM - Vi IMproved 7.0 (2006 May 7, compiled Jun 12 2009 07:08:36) Included patches: 1, 3-4, 7-9, 11,
      Message 2 of 4 , May 14, 2013
      • 0 Attachment
        On Monday, May 13, 2013 11:19:46 PM UTC-4, John Little wrote:
        > On Tuesday, May 14, 2013 7:57:45 AM UTC+12, jimmywang wrote:
        >
        > > With the following setting, vi can consume up to 40GB on my Linux (64 bit) machine:
        > >
        > > stty rows 65535
        > > stty columns 65535
        > > vi /tmp/foo
        >
        > Interesting.
        > Are you sure that's vim? On my Kubuntu 13.04, vi gives me vim 7.3.547 "Huge version with GTK2 GUI" "Modified by pkg-vim-maintainers@..." and it clips lines to 1000 and columns to 10000, and only uses about 150 kiB.
        >
        > So, which Linux distro? And when you run "vi", what does
        >
        > :ver
        >
        > say? What does (in your shell)
        >
        > ls -l /etc/alternatives/vi
        >
        > say?
        >
        > Regards, John Little

        John,

        This comes from redhat linux distro/CentOS.

        VIM - Vi IMproved 7.0 (2006 May 7, compiled Jun 12 2009 07:08:36)
        Included patches: 1, 3-4, 7-9, 11, 13-17, 19-26, 29-31, 34-44, 47, 50-56, 58-64, 66-73, 75, 77-92, 94-107, 109, 202, 234-237
        Modified by <bugzilla@...>
        Compiled by <bugzilla@...>
        Huge version without GUI. Features included (+) or not (-):

        Thanks
        Jieming

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christian Brabandt
        Hi jimmywang! ... I see this too. Well, don t set your rows and columns to those insane values then. regards, Christian -- Heute muß man seine Leute
        Message 3 of 4 , May 14, 2013
        • 0 Attachment
          Hi jimmywang!

          On Mo, 13 Mai 2013, jimmywang wrote:

          > vi developers,
          >
          > With the following setting, vi can consume up to 40GB on my Linux (64 bit) machine:
          >
          > stty rows 65535
          > stty columns 65535
          > vi /tmp/foo
          >
          > Please don't run as root as you may bring down your Linux machine (due to Out Of Memory).
          >
          > I think this need to be fixed. Let me know your thoughts.

          I see this too. Well, don't set your rows and columns to those insane
          values then.

          regards,
          Christian
          --
          Heute muß man seine Leute motivieren, anbrüllen allein nützt nichts mehr.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.