Loading ...
Sorry, an error occurred while loading the content.

Re: OutlookVim 8 and Outlook 2007: "Please install the plugin OutlookVim from www.vim.org to continue" -- SOLVED

Expand Messages
  • Gary Johnson
    ... I started looking more closely at the Visual Basic code, not that I know anything about Visual Basic, and saw that it had to have found an instance of gvim
    Message 1 of 4 , May 9 6:38 PM
    • 0 Attachment
      On 2013-05-09, Gary Johnson wrote:
      > I just downloaded and installed OutlookVim version 8 for use with
      > Outlook 2007 running on a Windows XP system. I followed the
      > instructions for installing the macro to step 12, the last sub-step
      > for Outlook 2007: "Click on the new button in the Quick Access
      > Toolbar". The result is a pop-up window titled "Microsoft Office
      > Outlook" and containing the message:
      >
      > OutlookVim: Please install the plugin OutlookVim from
      > www.vim.org to continue
      >
      > I found that this message is displayed by OutlookVim.bas if
      >
      > exists('g:loaded_outlook')
      >
      > is false. But, I can open gvim from its Desktop icon, execute
      > that command and see that it returns 1.
      >
      > I found the Wiki page that discusses this error. It suggests that
      > the files are installed in the wrong locations. Mine are here:
      >
      > ~/vimfiles/plugin/OutlookVim.bas
      > ~/vimfiles/plugin/outlook.vim
      > ~/vimfiles/plugin/outlookvim.js
      >
      > I tried putting outlook.vim in C:\Program Files\vim\vimfiles\plugin
      > in case gvim couldn't find my $HOME. No difference.
      >
      > I am running Vim 7.3.762.
      >
      > What can I do to fix this or to troubleshoot it?

      I started looking more closely at the Visual Basic code, not that I
      know anything about Visual Basic, and saw that it had to have found
      an instance of gvim running but that that gvim instance had not
      loaded the outlookvim.vim file.

      Then it dawned on me that I always have an instance of gvim running
      on that machine for keeping notes. That instance had been running
      since before I installed the outlookvim.vim plugin, so if
      OutlookVim.bas was asking _that_ instance if it had
      g:loaded_outlook, the answer would be no.

      I exited that gvim instance, made sure no others were running, and
      tried again. Voilà!

      Sorry for the noise, but maybe this will help someone else.

      Regards,
      Gary

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • David Fishburn
      ... Good Morning Gary. Unfortunately, only one instance of Vim can register as an OLE service at a time. So yes, this is expected. Glad you have it working
      Message 2 of 4 , May 10 5:29 AM
      • 0 Attachment
        ...

        I started looking more closely at the Visual Basic code, not that I
        know anything about Visual Basic, and saw that it had to have found
        an instance of gvim running but that that gvim instance had not
        loaded the outlookvim.vim file.


        Good Morning Gary.

        Unfortunately, only one instance of Vim can register as an OLE service at a time.
        So yes, this is expected.
        Glad you have it working now.

        I will update the error message displayed in Outlook to indicate which Vim instance it had connected to when it found the plugin missing.  That should help future users.

        I am putting the final touches on 9.0 which should complete the multi-byte support.  So this message will be part of it.

        Thanks for the feedback.

        David

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • Gary Johnson
        ... David, Thanks for your reply. I am using Outlook in a corporate environment where almost all e-mail is in HTML and replies to HTML messages are expected to
        Message 3 of 4 , May 10 11:10 AM
        • 0 Attachment
          On 2013-05-10, David Fishburn wrote:
          > ...
          >
          >
          > I started looking more closely at the Visual Basic code, not that I
          > know anything about Visual Basic, and saw that it had to have found
          > an instance of gvim running but that that gvim instance had not
          > loaded the outlookvim.vim file.
          >
          >
          >
          > Good Morning Gary.
          >
          > Unfortunately, only one instance of Vim can register as an OLE service at a
          > time.
          > So yes, this is expected.
          > Glad you have it working now.
          >
          > I will update the error message displayed in Outlook to indicate which Vim
          > instance it had connected to when it found the plugin missing. That should
          > help future users.
          >
          > I am putting the final touches on 9.0 which should complete the multi-byte
          > support. So this message will be part of it.
          >
          > Thanks for the feedback.

          David,

          Thanks for your reply.

          I am using Outlook in a corporate environment where almost all
          e-mail is in HTML and replies to HTML messages are expected to be in
          HTML. I read in OutlookVim.bas that you had tried detecting and
          editing HTML messages and that it had worked, but was inconvenient
          because of Outlook's horrible use of HTML.

          If it's not too much trouble, would you please send me or post the
          code you used to edit the HTML body?

          Thanks,
          Gary

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.