Loading ...
Sorry, an error occurred while loading the content.

Re: can't use vimrc

Expand Messages
  • Marc Weber
    ... I don t know. Somebody else should reply to this question. You might want to try assigning the property even though the font is not ... where the
    Message 1 of 12 , May 7, 2013
    • 0 Attachment
      > let me ask a new question: I found my gvim 7.0 use font
      > "San/Regular/size 12" but I can't find this font in gvim 7.1. How can
      > I copy this font "library" from gvim7.0 and install it to gvim7.1?
      > thanks.
      I don't know. Somebody else should reply to this question.
      You might want to try assigning the property even though the font is not
      listed:
      :set guifont='the string'

      where 'the string'is echo &guifont from the other version .

      You may want to use strace. You may want to check :version to see
      whether the gui being used is the same. Eg vim can be compiled against
      gtk, ...

      The font is not that important to me - as long as its readable.

      Marc Weber

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • huubby zhou
      ... You can try :version in vim, see what s your user vimrc file and what s your user gvimrc file . For some variables like $HOME , $VIM , you can
      Message 2 of 12 , May 7, 2013
      • 0 Attachment

        >Hi experts,
        >
        >my system administrator has changed original gvim path from
        >/usr/bin/gvim to /grid/common/bin/gvim. In this case, I found I can't
        >load my setup file which locates at ~/.vimrc. Every time when I launch
        >gvim, a default setup for gvim was load which annoy me much. Can
        >anybody help me to find how to load my original setup? thanks.

        You can try ":version" in vim, see what's your "user vimrc file" and
        what's your "user gvimrc file". For some variables like "$HOME", "$VIM",
        you can verify them by ":echo $HOME". The thought on top of my head, you
        have a wrong $HOME setting.


        On Tue, May 7, 2013 at 10:02 AM, skyworld <chenyong20000@...> wrote:
        Hi experts,

        my system administrator has changed original gvim path from /usr/bin/gvim to /grid/common/bin/gvim. In this case, I found I can't load my setup file which locates at ~/.vimrc. Every time when I launch gvim, a default setup for gvim was load which annoy me much. Can anybody help me to find how to load my original setup? thanks.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.



        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • skyworld
        Hi, thanks for your kind information. I checked the way you showed me and I can now confirm that gvim7.1 has loaded my old settings. The reason why I can t
        Message 3 of 12 , May 8, 2013
        • 0 Attachment
          Hi,
          thanks for your kind information. I checked the way you showed me and I can now confirm that gvim7.1 has loaded my old settings. The reason why I can't find those my familiar setting in gvim7.1 is that I found some font are not installed in gvim7.1 but installed in gvim7.0. I have to find a way to install them:-)

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Christian Brabandt
          ... Please show us the output of :version for both gvim versions. Remember, different gui flavors need different font settings and I suspect, this could be
          Message 4 of 12 , May 8, 2013
          • 0 Attachment
            On Wed, May 8, 2013 10:12, skyworld wrote:
            > Hi,
            > thanks for your kind information. I checked the way you showed me and I
            > can now confirm that gvim7.1 has loaded my old settings. The reason why I
            > can't find those my familiar setting in gvim7.1 is that I found some font
            > are not installed in gvim7.1 but installed in gvim7.0. I have to find a
            > way to install them:-)

            Please show us the output of :version
            for both gvim versions.

            Remember, different gui flavors need different font settings
            and I suspect, this could be your problem.

            regards,
            Christian

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • skyworld
            在 2013年5月8日星期三UTC+8下午4时51分48秒,Christian Brabandt写道: ... VIM - Vi IMproved 7.1 (2007 May 12, compiled Jun 1 2011 18:27:06)
            Message 5 of 12 , May 8, 2013
            • 0 Attachment
              在 2013年5月8日星期三UTC+8下午4时51分48秒,Christian Brabandt写道:
              > On Wed, May 8, 2013 10:12, skyworld wrote: > Hi, > thanks for your kind information. I checked the way you showed me and I > can now confirm that gvim7.1 has loaded my old settings. The reason why I > can't find those my familiar setting in gvim7.1 is that I found some font > are not installed in gvim7.1 but installed in gvim7.0. I have to find a > way to install them:-) Please show us the output of :version for both gvim versions. Remember, different gui flavors need different font settings and I suspect, this could be your problem. regards, Christian

              thanks. Here is my results for gvim7.1:
              :version
              VIM - Vi IMproved 7.1 (2007 May 12, compiled Jun 1 2011 18:27:06)
              Compiled by satish@gridsync4
              Normal version with GTK GUI. Features included (+) or not (-):
              -arabic +autocmd +balloon_eval +browse +builtin_terms +byte_offset +cindent +clientserver +clipboard
              +cmdline_compl +cmdline_hist +cmdline_info +comments +cryptv +cscope +cursorshape +dialog_con_gui +diff
              +digraphs +dnd -ebcdic -emacs_tags +eval +ex_extra +extra_search -farsi +file_in_path +find_in_path
              +folding -footer +fork() -gettext -hangul_input -iconv +insert_expand +jumplist -keymap -langmap +libcall
              +linebreak +lispindent +listcmds +localmap +menu +mksession +modify_fname +mouse +mouseshape -mouse_dec
              +mouse_gpm -mouse_jsbterm -mouse_netterm +mouse_xterm -multi_byte +multi_lang -mzscheme +netbeans_intg
              -osfiletype +path_extra -perl +postscript +printer -profile -python +quickfix +reltime -rightleft -ruby
              +scrollbind +signs +smartindent -sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static
              -tag_any_white -tcl +terminfo +termresponse +textobjects +title +toolbar +user_commands +vertsplit
              +virtualedit +visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows +writebackup +X11
              -xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
              system vimrc file: "$VIM/vimrc"
              user vimrc file: "$HOME/.vimrc"
              user exrc file: "$HOME/.exrc"
              system gvimrc file: "$VIM/gvimrc"
              user gvimrc file: "$HOME/.gvimrc"
              system menu file: "$VIMRUNTIME/menu.vim"
              fall-back for $VIM: "/grid/common/pkgs/vim/v7.1/share/vim"
              Compilation: /grid/common/pkgs/gcc/v4.1.2p2/bin/gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/
              include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib64/glib/include -I/usr/X11R6/include -I/grid/common/pkgs
              /glib/v2.22.4/include -I/grid/common/pkgs/gtk+/v2.10.14/include -I/grid/common/pkgs/ncurses/v5.6/include -
              I/grid/common/pkgs/flex/v2.5.4a/include -I/grid/common/pkgs/xpm/v3.4k/include -I/grid/common/pkgs/glib/v2
              .22.4/include -I/grid/common/pkgs/gtk+/v2.10.14/include -I/grid/common/pkgs/ncurses/v5.6/include -I/grid/c
              ommon/pkgs/flex/v2.5.4a/include -I/grid/common/pkgs/xpm/v3.4k/include -I/usr/X11R6/include
              Linking: /grid/common/pkgs/gcc/v4.1.2p2/bin/gcc -L/usr/X11R6/lib64 -L/grid/common/pkgs/glib/v2.22.4/lib
              -L/grid/common/pkgs/gtk+/v2.10.14/lib -Wl,-rpath,/grid/common/pkgs/glib/v2.22.4/lib -Wl,-rpath,/grid/comm
              on/pkgs/gtk+/v2.10.14/lib -L/grid/common/pkgs/xpm/v3.4k/lib -Wl,-rpath,/grid/common/pkgs/xpm/v3.4k/lib -L/
              usr/local/lib -o vim -L/usr/lib64 -L/usr/X11R6/lib64 -lgtk -lgdk -rdynamic -lgmodule -lglib -lXi -lXext
              -lm -lXt -lncurses -lacl -lgpm

              Here is my result for gvim7.0:
              :version
              VIM - Vi IMproved 7.0 (2006 May 7, compiled Jun 12 2009 07:07:08)
              Included patches: 1, 3-4, 7-9, 11, 13-17, 19-26, 29-31, 34-44, 47, 50-56, 58-64, 66-73, 75, 77-92, 94-107, 109, 202, 234-237
              Modified by <bugzilla@...>
              Compiled by <bugzilla@...>
              Huge version with GTK2 GUI. Features included (+) or not (-):
              +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset +cindent +clientserver +clipboard +cmdline_compl
              +cmdline_hist +cmdline_info +comments +cryptv +cscope +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic +emacs_tags
              +eval +ex_extra +extra_search +farsi +file_in_path +find_in_path +folding -footer +fork() +gettext -hangul_input +iconv
              +insert_expand +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap +menu +mksession +modify_fname
              +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm +mouse_netterm +mouse_xterm +multi_byte +multi_lang -mzscheme
              -netbeans_intg -osfiletype +path_extra +perl +postscript +printer +profile +python +quickfix +reltime +rightleft -ruby
              +scrollbind +signs +smartindent -sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white -tcl
              +terminfo +termresponse +textobjects +title +toolbar +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
              +vreplace +wildignore +wildmenu +windows +writebackup +X11 -xfontset +xim +xsmp_interact +xterm_clipboard -xterm_save
              system vimrc file: "/etc/vimrc"
              user vimrc file: "$HOME/.vimrc"
              user exrc file: "$HOME/.exrc"
              system gvimrc file: "/etc/gvimrc"
              user gvimrc file: "$HOME/.gvimrc"
              system menu file: "$VIMRUNTIME/menu.vim"
              fall-back for $VIM: "/usr/share/vim"
              Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/incl
              ude/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/
              freetype2 -I/usr/include/libpng12 -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buf
              fer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -I/usr/include64 -D_REENTRANT -D_GNU
              _SOURCE -Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -I/
              usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE -I/usr/include/python2.4 -pthread
              Linking: gcc -L/lib64 -L/usr/lib64 -Wl,-E -Wl,-rpath,/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE -L/usr/local/l
              ib -o vim -L/lib64 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0
              -lgmodule-2.0 -lglib-2.0 -lXt -lncurses -lselinux -lacl -lgpm -Wl,-E -Wl,-rpath,/usr/lib64/perl5/5.8.8/x86_64-linux-threa
              d-multi/CORE /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/auto/DynaLoader/DynaLoader.a -L/usr/lib64/perl5/5.8.8/x86_64-lin
              ux-thread-multi/CORE -lperl -lresolv -lutil -lc -L/usr/lib64/python2.4/config -lpython2.4 -lutil -lm -Xlinker -export-dynamic

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Christian Brabandt
              On Wed, May 8, 2013 15:18, skyworld wrote: ... 2 different GUIs. That means, specifying the font differs. See here:
              Message 6 of 12 , May 8, 2013
              • 0 Attachment
                On Wed, May 8, 2013 15:18, skyworld wrote:
                . Here is my results for gvim7.1:
                > :version
                > VIM - Vi IMproved 7.1 (2007 May 12, compiled Jun 1 2011 18:27:06)
                > Compiled by satish@gridsync4
                > Normal version with GTK GUI. Features included (+) or not (-):

                > Here is my result for gvim7.0:
                > :version
                > VIM - Vi IMproved 7.0 (2006 May 7, compiled Jun 12 2009 07:07:08)
                > Included patches: 1, 3-4, 7-9, 11, 13-17, 19-26, 29-31, 34-44, 47, 50-56,
                > 58-64, 66-73, 75, 77-92, 94-107, 109, 202, 234-237
                > Modified by <bugzilla@...>
                > Compiled by <bugzilla@...>
                > Huge version with GTK2 GUI. Features included (+) or not (-):

                2 different GUIs. That means, specifying the font differs.
                See here:
                http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI

                BTW, I would suggest getting an even newer version of vim (either compile
                your own or install a newer package or backport), since currently
                I think we are at patchlevel 7.3.925 and I am guessing a Vim 7.4 release
                probably being released within the next few months (since we are running
                out of patch numbers).

                The GTK1 GUI has been removed I think with the 7.3 release, so you might
                simply want to compile your own GTK2 build of vim 7.3 and that should
                bring you back your fonts.

                regards,
                Christian

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • skyworld
                在 2013年5月8日星期三UTC+8下午9时55分08秒,Christian Brabandt写道: ... Hi Christian, thanks for your suggestion. The tools are managed by
                Message 7 of 12 , May 8, 2013
                • 0 Attachment
                  在 2013年5月8日星期三UTC+8下午9时55分08秒,Christian Brabandt写道:
                  > On Wed, May 8, 2013 15:18, skyworld wrote: . Here is my results for gvim7.1: > :version > VIM - Vi IMproved 7.1 (2007 May 12, compiled Jun 1 2011 18:27:06) > Compiled by satish@gridsync4 > Normal version with GTK GUI. Features included (+) or not (-): > Here is my result for gvim7.0: > :version > VIM - Vi IMproved 7.0 (2006 May 7, compiled Jun 12 2009 07:07:08) > Included patches: 1, 3-4, 7-9, 11, 13-17, 19-26, 29-31, 34-44, 47, 50-56, > 58-64, 66-73, 75, 77-92, 94-107, 109, 202, 234-237 > Modified by <bugzilla@...> > Compiled by <bugzilla@...> > Huge version with GTK2 GUI. Features included (+) or not (-): 2 different GUIs. That means, specifying the font differs. See here: http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI BTW, I would suggest getting an even newer version of vim (either compile your own or install a newer package or backport), since currently I think we are at patchlevel 7.3.925 and I am guessing a Vim 7.4 release probably being released within the next few months (since we are running out of patch numbers). The GTK1 GUI has been removed I think with the 7.3 release, so you might simply want to compile your own GTK2 build of vim 7.3 and that should bring you back your fonts. regards, Christian

                  Hi Christian,

                  thanks for your suggestion. The tools are managed by administor and I don't have the right to change them, I have to live with this:-). Anyway, I tried link you provide and it is usedful, thanks.

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                Your message has been successfully submitted and would be delivered to recipients shortly.