Loading ...
Sorry, an error occurred while loading the content.

Re: head blank selected

Expand Messages
  • Chris Lott
    ... If I understand correctly, you have spaces at the beginning of the line but want to select only to the first non-space character? You could use v^ to
    Message 1 of 4 , May 2, 2013
    • 0 Attachment
      On Wed, May 1, 2013 at 6:17 PM, shada <laf163@...> wrote:
      > 1.Move the cursor to the end of the line
      > 2.Press shift + Home
      >
      > head blank selected, i don't want select head blank, how should i do?

      If I understand correctly, you have spaces at the beginning of the
      line but want to select only to the first non-space character?

      You could use v^ to select rather than the shift+home. Or look at one
      of the "smart home" scripts to change the behavior:
      http://vim.wikia.com/wiki/Smart_home

      Does that help?

      c
      --
      Chris Lott <chris@...>

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • shada
      Chris Lott, you have help me solved this problem. thank you. 2013/5/2 Chris Lott ... -- -- You received this message from the vim_use
      Message 2 of 4 , May 3, 2013
      • 0 Attachment
        Chris Lott, you have help me solved this problem.
        thank you.


        2013/5/2 Chris Lott <chris@...>
        On Wed, May 1, 2013 at 6:17 PM, shada <laf163@...> wrote:
        > 1.Move the cursor to the end of the line
        > 2.Press shift + Home
        >
        > head blank selected, i don't want select head blank, how should i do?

        If I understand correctly, you have spaces at the beginning of the
        line but want to select only to the first non-space character?

        You could use v^ to select rather than the shift+home. Or look at one
        of the "smart home" scripts to change the behavior:
        http://vim.wikia.com/wiki/Smart_home

        Does that help?

        c
        --
        Chris Lott <chris@...>

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.



        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      Your message has been successfully submitted and would be delivered to recipients shortly.