Loading ...
Sorry, an error occurred while loading the content.

:Explore shows nothing if path contains an embedded tilde (Windows)

Expand Messages
  • Dameron, Gregg
    I m running gvim 7.2 on Windows 7. If I attempt :Explore or :e . when any folder in my current working directory contains a tilde (e.g.,
    Message 1 of 3 , Apr 30 3:38 PM
    • 0 Attachment

      I’m running gvim 7.2 on Windows 7.

       

      If I attempt “:Explore” or “:e .” when any folder in my current working directory contains a tilde (e.g., “my~example_folder”), the Netrw Directory Listing buffer displays nothing below the last row of equals signs. Not even “../” is displayed. There is no netrw hiding list set, so the “a” key has no effect. Interestingly, the hyphen key still works to go up a directory level.

       

      I’m at the mercy of a commercial configuration management tool that insists on putting tildes in folder names.

       

      Is there a solution?

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Ben Fritz
      ... I assume you re running with a netrw plugin around the same age as Vim 7.2 (around 5 years old). The first thing I think you should try, if you re able, is
      Message 2 of 3 , Apr 30 3:46 PM
      • 0 Attachment
        On Tuesday, April 30, 2013 5:38:06 PM UTC-5, Dameron, Gregg wrote:
        > I’m running gvim 7.2 on Windows 7.
        >
        >  
        >
        > If I attempt “:Explore” or “:e .” when any folder in my current working directory contains a tilde (e.g., “my~example_folder”), the Netrw Directory Listing buffer displays nothing below the last row of equals signs. Not even “../” is displayed.

        I assume you're running with a netrw plugin around the same age as Vim 7.2 (around 5 years old).

        The first thing I think you should try, if you're able, is upgrading your entire Vim installation. cream.sourceforge.net has Vim installers built for Windows with fairly recent patch levels. Currently it is on 7.3.829 and the Vim source is at 7.3.918.

        If you can't upgrade the whole install, you can try downloading the latest netrw plugin and placing it in your personal Vim plugin directories. But a 7.2 executable is so old I'm not sure whether the latest netrw will even function with your current Vim.

        Vim does install to non-standard areas (like C:\Vim or C:\Users\JohnDoe\Vim) if the only problem you have with installing is write access.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Charles E Campbell
        ... Hello! Using Vista, netrw v149d, and vim 7.3.816, I had no problems with a directory called Dir~3 . I tested with: :e [path] and with :Explore [path]
        Message 3 of 3 , May 1, 2013
        • 0 Attachment
          Ben Fritz wrote:
          > On Tuesday, April 30, 2013 5:38:06 PM UTC-5, Dameron, Gregg wrote:
          >> I’m running gvim 7.2 on Windows 7.
          >>
          >>
          >>
          >> If I attempt “:Explore” or “:e .” when any folder in my current working directory contains a tilde (e.g., “my~example_folder”), the Netrw Directory Listing buffer displays nothing below the last row of equals signs. Not even “../” is displayed.
          > I assume you're running with a netrw plugin around the same age as Vim 7.2 (around 5 years old).
          >
          > The first thing I think you should try, if you're able, is upgrading your entire Vim installation. cream.sourceforge.net has Vim installers built for Windows with fairly recent patch levels. Currently it is on 7.3.829 and the Vim source is at 7.3.918.
          >
          > If you can't upgrade the whole install, you can try downloading the latest netrw plugin and placing it in your personal Vim plugin directories. But a 7.2 executable is so old I'm not sure whether the latest netrw will even function with your current Vim.
          >
          > Vim does install to non-standard areas (like C:\Vim or C:\Users\JohnDoe\Vim) if the only problem you have with installing is write access.
          >
          Hello!

          Using Vista, netrw v149d, and vim 7.3.816, I had no problems with a
          directory called "Dir~3". I tested with: :e [path] and with :Explore
          [path] variants under both cygwin and windows-style gvim.

          Regards,
          C Campbell

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.