Loading ...
Sorry, an error occurred while loading the content.
 

Re: outlookvim

Expand Messages
  • huubby zhou
    I have this same issue occasionally, only my error is, Could not create email file [C: Users xxx AppData Local Temp rad1F419.outlook] Invalid procedure call
    Message 1 of 7 , Apr 29, 2013
      I have this same issue occasionally, only my error is, "Could not create email
      file [C:\Users\xxx\AppData\Local\Temp\rad1F419.outlook] Invalid procedure call
      or argument". Don't know if it's related with email content, since it appears
      for some email, meantime, other emails are fine.


      On Mon, Apr 29, 2013 at 6:32 AM, David Fishburn <dfishburn.vim@...> wrote:
      Thanks for the email.

      Which version of OutlookVim are you using?
      :echo g:loaded_outlook


      > Note too that the user is not correctly identified in the file name and
      there is no such user on the system, but the user name identified is the
      correct name but truncated with and the case is changed, e.g., "HPOTT"
      instead of hpotter(the actual user name). There is no such user on the
      system with the name "HPOTT"

      \HPOTT~1\
      Is simply the windows short form (no spaces) for \HPOTTER\

      You can see this from a cmd prompt using a modified dir with the \X command.

      dir c:\ /X

      12/04/2013  04:17 PM    <DIR>          PROGRA~1     Program Files
      13/04/2013  10:02 AM    <DIR>          PROGRA~2     Program Files (x86)
      18/09/2012  02:36 PM    <DIR>          PROGRA~4     ProgramFiles32



      > I doubt this is related, but I should add that I know nothing about vb
      but figured out that I had to add PtrSafe to the declare statements to
      make the macro run on a64 bit os, which is odd because I didn't have to
      do this with another system with the same configurations on which
      outlookvim runs perfectly. Before this, the macro would not even run.
      I've compared the two systems and even tried copying the vb project file
      from the working system to the other. But the same error occurs.


      I am not clear on what you have done, can you give me very specific instructions.

      You can email me directly if you want.

      Thanks,
      David




      On Sun, Apr 28, 2013 at 10:28 AM, <p_s_c@...> wrote:
      Re: plugin outlookvim: Using Gim on win7 service pack1 and Outlook2010

      I get the following error:

       "Outlook Vim: Could not replace new line characters in
      file[c:\Users\HPOTT~1\Appdata\Local\Temp\radF2DBF.outlook]5:Invalid
      procedure call or argument."

      The above error occurs after clicking on the icon to run the macro. Vim
      opens a buffer not attached to a file. It's as though the ICON was a link
      to vim but does nothing else except vim also issues an error that states:

       " outlook:cannot find file name
      [c:\Users\HPOTT~1\Appdata\Local\Temp\radF2DBF.outlook]"

      Note too that the user is not correctly identified in the file name and
      there is no such user on the system, but the user name identified is the
      correct name but truncated with and the case is changed, e.g., "HPOTT"
      instead of hpotter(the actual user name). There is no such user on the
      system with the name "HPOTT"

       I doubt this is related, but I should add that I know nothing about vb
      but figured out that I had to add PtrSafe to the declare statements to
      make the macro run on a64 bit os, which is odd because I didn't have to
      do this with another system with the same configurations on which
      outlookvim runs perfectly. Before this, the macro would not even run.
      I've compared the two systems and even tried copying the vb project file
      from the working system to the other. But the same error occurs.

      Thanks




      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.



      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • David Fishburn
      ... David -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For more
      Message 2 of 7 , Apr 30, 2013



        On Tue, Apr 30, 2013 at 12:39 AM, huubby zhou <huubby1@...> wrote:
        I have this same issue occasionally, only my error is, "Could not create email
        file [C:\Users\xxx\AppData\Local\Temp\rad1F419.outlook] Invalid procedure call
        or argument". Don't know if it's related with email content, since it appears
        for some email, meantime, other emails are fine.


        Is there a chance you have unicode characters within your email body?

        David
         

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • Paul
        For me, there was unicode in the bodies of the emails I tried replying to, sometimes just a single character like this one : 𐂏 Live and learn. From:
        Message 3 of 7 , Apr 30, 2013


          For me, there was unicode in the bodies of the emails I tried replying to, sometimes just a single character like this one :
          𐂏 Live and learn.

           

          From: vim_use@... [mailto:vim_use@...] On Behalf Of David Fishburn
          Sent: April-30-13 8:51 AM
          To: vim_use
          Subject: Re: outlookvim

           

           

           

          On Tue, Apr 30, 2013 at 12:39 AM, huubby zhou <huubby1@...> wrote:

          I have this same issue occasionally, only my error is, "Could not create email

          file [C:\Users\xxx\AppData\Local\Temp\rad1F419.outlook] Invalid procedure call

          or argument". Don't know if it's related with email content, since it appears

          for some email, meantime, other emails are fine.

           

           

          Is there a chance you have unicode characters within your email body?

           

          David

           

           

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
           
          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
           
           
        • huubby zhou
          Maybe, I never check this. How can I check this and avoid the error? ... -- -- You received this message from the vim_use maillist. Do not top-post! Type
          Message 4 of 7 , Apr 30, 2013
            Maybe, I never check this. How can I check this and avoid the error?


            On Tue, Apr 30, 2013 at 8:51 PM, David Fishburn <dfishburn.vim@...> wrote:



            On Tue, Apr 30, 2013 at 12:39 AM, huubby zhou <huubby1@...> wrote:
            I have this same issue occasionally, only my error is, "Could not create email
            file [C:\Users\xxx\AppData\Local\Temp\rad1F419.outlook] Invalid procedure call
            or argument". Don't know if it's related with email content, since it appears
            for some email, meantime, other emails are fine.


            Is there a chance you have unicode characters within your email body?

            David
             

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          • Paul
            Hi, My very non-tech way is to eyeball the document looking for any characters that are not in character encoding (e,g. Latin characters--a-z, A-Z, 0-9, space,
            Message 5 of 7 , May 1, 2013

              Hi,

               

              My very non-tech way is to eyeball the document looking for any characters that are not in character encoding (e,g. Latin characters--a-z, A-Z, 0-9, space, or punctuation). So if you receive such emails let’s say with foreign language content, as I do, or other symbols, it’s likely unicode because many foreign language characters require more binary code to produce than ascii can provide. This eye ball guessing works to some degree because there are only about 128 ascii characters and the above = the majority of them. However, this is by far only guess work because, if I understand it correctly, all characters can be in unicode. I’m basing this on my moderate understanding of sql where all string data types can be written as Unicode --nchar, nvarchare. I hope this helps a little.

              From: vim_use@... [mailto:vim_use@...] On Behalf Of huubby zhou
              Sent: April-30-13 11:42 PM
              To: vim_use@...
              Subject: Re: outlookvim

               

              Maybe, I never check this. How can I check this and avoid the error?

               

              On Tue, Apr 30, 2013 at 8:51 PM, David Fishburn <dfishburn.vim@...> wrote:

               

               

              On Tue, Apr 30, 2013 at 12:39 AM, huubby zhou <huubby1@...> wrote:

              I have this same issue occasionally, only my error is, "Could not create email

              file [C:\Users\xxx\AppData\Local\Temp\rad1F419.outlook] Invalid procedure call

              or argument". Don't know if it's related with email content, since it appears

              for some email, meantime, other emails are fine.

               

               

              Is there a chance you have unicode characters within your email body?

               

              David

               

               

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
               
               

               

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
               
               

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
               
               
            Your message has been successfully submitted and would be delivered to recipients shortly.