Loading ...
Sorry, an error occurred while loading the content.

Re: Problem with opening files and directories on the command line

Expand Messages
  • Dominique PellĂ©
    ... Hi Charles I just downloaded netrw v149c. I still see what looks like a bug and which I reported earlier. Please review this patch: $ diff -c
    Message 1 of 7 , Apr 29, 2013
    • 0 Attachment
      Charles Campbell wrote:

      > Hello, Dennis:
      >
      > I'm sorry its been such an inordinate long time, but I in looking at my old
      > email I saw that the problem you'd mentioned was still outstanding -- and
      > still present. Part of the problem was that it was weird that tree listing
      > mode would have the effect it did. Anyway, I'm hoping that the current netrw
      > (v149c) addresses the issues you'd found.
      >
      > You can get a copy from my website:
      > http://www.drchip.org/astronaut/vim/index.html#NETRW .

      Hi Charles

      I just downloaded netrw v149c. I still see what looks like
      a bug and which I reported earlier. Please review this patch:

      $ diff -c autoload/netrw.vim.orig autoload/netrw.vim
      *** autoload/netrw.vim.orig 2013-04-29 23:01:56.987914815 +0200
      --- autoload/netrw.vim 2013-04-29 23:02:12.195914685 +0200
      ***************
      *** 4193,4199 ****
      let b:netrw_curdir= getcwd().'/'.prefixdir
      endif
      let dirname= substitute(dirname,'^.\{-}\(\*\*/.*\)$','\1','')
      ! let starpat= 4;
      " call Decho("(Explore) ..pwd<".getcwd()."> dirname<".dirname.">")
      " call Decho("(Explore) ..case Explore ../**/../filepat
      (starpat=".starpat.")")

      --- 4193,4199 ----
      let b:netrw_curdir= getcwd().'/'.prefixdir
      endif
      let dirname= substitute(dirname,'^.\{-}\(\*\*/.*\)$','\1','')
      ! let starpat= 4
      " call Decho("(Explore) ..pwd<".getcwd()."> dirname<".dirname.">")
      " call Decho("(Explore) ..case Explore ../**/../filepat
      (starpat=".starpat.")")

      Regards
      Dominique

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.