Loading ...
Sorry, an error occurred while loading the content.

Re: ANN: YankRing 17.0

Expand Messages
  • AK
    ... I was using 13 but now I tried with 17 and I get the same issue. ... 10 aug 15; :ver does not show me patch number. ... e.g. line: join(SITE_ROOT,
    Message 1 of 10 , Apr 28, 2013
    • 0 Attachment
      On 04/28/2013 07:47 PM, David Fishburn wrote:
      > What version of the YankRing are you using?
      > :echo g:loaded_yankring


      I was using 13 but now I tried with 17 and I get the same
      issue.

      >
      > Also, what version of Vim are you using, I am most concerned with the
      > patch numbers.
      > :ver

      '10 aug 15; :ver does not show me patch number.


      >
      > Can you give me a line of text, and the macro you recorded.
      > I don't see the problem when I record a macro with dt" with version 17.0.

      e.g. line:

      join(SITE_ROOT, "templates/forum"),

      record commands: wdt"^P
      when executing, I get "Yankring: enter character:"

      -ak

      >
      > I am using 7.3.758.
      >
      > Thanks,
      > David
      >
      >
      > On Sun, Apr 28, 2013 at 7:29 PM, AK <andrei.avk@...
      > <mailto:andrei.avk@...>> wrote:
      >
      > Hi David, one issue I've run into with yankring is
      > that if I make a recording using q command, it works
      > fine as I record it, but once I try to play it back,
      > it gets stuck on a command like dt" and yankring asks
      > for a character.
      >
      > I use Vim 7.3.
      >
      > Is there a workaround for this?
      >
      > Thanks, -ak
      >
      >
      >
      > On 04/28/2013 07:20 PM, David Fishburn wrote:
      >
      > YankRing.vim : Maintains a history of previous yanks, changes
      > and deletes
      > http://www.vim.org/scripts/__script.php?script_id=1234
      > <http://www.vim.org/scripts/script.php?script_id=1234>
      >
      > What does it do?
      >
      > Inspired by the Emacs kill ring.
      >
      > Allows you to retrieve previous yanks, deletes and changed text and
      > cycle through them choosing which item you need. It also works
      > across
      > Vim instances so they all see the same history. Useful for sharing
      > text across instances, including when using Screen in *nix.
      >
      > For a more descriptive write up, please see the web page.
      >
      > Thanks for everyone's feedback so far.
      > If you do try the plugin and find things that bother you, please
      > send
      > me an email.
      >
      >
      > What is new?
      >
      > NF: The yankring_history_dir option can now take a comma
      > separated list.
      > First valid directory found will be used (Alex Bel).
      >
      > NF: YankRing can now monitor inserted text and place it in the ring.
      > This is disabled by default, but can be enabled either through the
      > YankRing window or via your .vimrc using the new option:
      > g:yankring_record_insert = 1 (Alexandre Viau).
      >
      > BF: When g:yankring_persist = 0, the YankRing was still reading and
      > writing to the yankring file (Vladimir Marek).
      >
      > BF: The YankRing menu entry, "Replace with Next", was performing the
      > "Replace with Previous" action (Thilo Six).
      >
      >
      > As usual, feedback good and bad is always welcome.
      >
      > Enjoy.
      > David
      >
      > --
      > --
      > You received this message from the "vim_use" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.__php
      > <http://www.vim.org/maillist.php>
      >
      > ---
      > You received this message because you are subscribed to the Google
      > Groups "vim_use" group.
      > To unsubscribe from this group and stop receiving emails from
      > it, send
      > an email to vim_use+unsubscribe@__googlegroups.com
      > <mailto:vim_use%2Bunsubscribe@...>.
      > For more options, visit
      > https://groups.google.com/__groups/opt_out
      > <https://groups.google.com/groups/opt_out>.
      >
      >
      >
      > --
      > --
      > You received this message from the "vim_use" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.__php
      > <http://www.vim.org/maillist.php>
      >
      > --- You received this message because you are subscribed to the
      > Google Groups "vim_use" group.
      > To unsubscribe from this group and stop receiving emails from it,
      > send an email to vim_use+unsubscribe@__googlegroups.com
      > <mailto:vim_use%2Bunsubscribe@...>.
      > For more options, visit https://groups.google.com/__groups/opt_out
      > <https://groups.google.com/groups/opt_out>.
      >
      >
      >
      > --
      > --
      > You received this message from the "vim_use" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.php
      >
      > ---
      > You received this message because you are subscribed to the Google
      > Groups "vim_use" group.
      > To unsubscribe from this group and stop receiving emails from it, send
      > an email to vim_use+unsubscribe@....
      > For more options, visit https://groups.google.com/groups/opt_out.
      >
      >

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • BPJ
      ... Am I the only one getting an error? Vim Online Error Can t connect to local MySQL server through socket /var/lib/mysql/mysql.sock (2) /bpj -- -- You
      Message 2 of 10 , Apr 30, 2013
      • 0 Attachment
        2013-04-29 01:20, David Fishburn skrev:
        > YankRing.vim : Maintains a history of previous yanks, changes and deletes
        > http://www.vim.org/scripts/script.php?script_id=1234

        Am I the only one getting an error?

        Vim Online Error

        Can't connect to local MySQL server through socket
        '/var/lib/mysql/mysql.sock' (2)

        /bpj

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Paul
        ... Sounds like the same thing I was seeing only on a Debian system. (I ve still not had time to debug it.) -- -- You received this message from the vim_use
        Message 3 of 10 , Apr 30, 2013
        • 0 Attachment
          On Monday, 29 April, 2013 at 00:29:05 BST, AK wrote:
          >Hi David, one issue I've run into with yankring is
          >that if I make a recording using q command, it works
          >fine as I record it, but once I try to play it back,
          >it gets stuck on a command like dt" and yankring asks
          >for a character.
          >
          >I use Vim 7.3.
          >
          >Is there a workaround for this?

          Sounds like the same thing I was seeing only on a Debian system. (I've still not had time to debug it.)

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • David Fishburn
          ... one can download scripts at the moment. David -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text
          Message 4 of 10 , Apr 30, 2013
          • 0 Attachment



            On Tue, Apr 30, 2013 at 10:11 AM, BPJ <bpj@...> wrote:
            2013-04-29 01:20, David Fishburn skrev:

            YankRing.vim : Maintains a history of previous yanks, changes and deletes
            http://www.vim.org/scripts/script.php?script_id=1234

            Am I the only one getting an error?

             Vim Online Error

            Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)


            No, everyone is getting that error, the Vim MySQL database is down, so no one can download scripts at the moment.

            David
             

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
             
            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
             
             
          • David Fishburn
            ... than the 7.3.758 I am currently running. Of course I will have to reinstall somewhere to get that .exe (should have copied it first ...), but I will report
            Message 5 of 10 , Apr 30, 2013
            • 0 Attachment



              On Tue, Apr 30, 2013 at 10:22 AM, Paul <google1241@...> wrote:
              On Monday, 29 April, 2013 at 00:29:05 BST, AK wrote:
              Hi David, one issue I've run into with yankring is
              that if I make a recording using q command, it works
              fine as I record it, but once I try to play it back,
              it gets stuck on a command like dt" and yankring asks
              for a character.

              I use Vim 7.3.

              Is there a workaround for this?

              Sounds like the same thing I was seeing only on a Debian system. (I've still not had time to debug it.)


              I will try to reproduce it with an unpatched version of Vim 7.3, rather than the 7.3.758 I am currently running.
              Of course I will have to reinstall somewhere to get that .exe (should have copied it first ...), but I will report back after my tests.

              David
               

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
               
              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
               
               
            • snowman55
              Any update? I have the same problem and have to remove the plugin when I need recording. -- -- You received this message from the vim_use maillist. Do not
              Message 6 of 10 , Aug 29, 2013
              • 0 Attachment
                Any update? I have the same problem and have to remove the plugin when I need recording.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              • Nikolay Pavlov
                ... numbered ... Numbered registers are populated from deletes unless another register was specified. The help states though that one-line deletes should not
                Message 7 of 10 , Aug 30, 2013
                • 0 Attachment


                  On Aug 30, 2013 9:34 PM, "Chris Lott" <chris@...> wrote:
                  >
                  > On Thu, Aug 29, 2013 at 6:33 PM, Francis Ngoh <yfngoh@...> wrote:
                  > > Im away from my computer but I found a workaround ... ie dont use numbered
                  > > registers for the macro.
                  >
                  >
                  > Maybe I'm missing something, but I don't see how this solves the
                  > problem. dt" isn't using a numbered register, it's deleting to the
                  > character "

                  Numbered registers are populated from deletes unless another register was specified. The help states though that one-line deletes should not affect numbered registers (with some exceptions, but "t" is not the one).

                  > c
                  > --
                  > Chris Lott <chris@...>
                  >
                  > --
                  > --
                  > You received this message from the "vim_use" maillist.
                  > Do not top-post! Type your reply below the text you are replying to.
                  > For more information, visit http://www.vim.org/maillist.php
                  >
                  > ---
                  > You received this message because you are subscribed to the Google Groups "vim_use" group.
                  > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  > For more options, visit https://groups.google.com/groups/opt_out.

                  --
                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                   
                  ---
                  You received this message because you are subscribed to the Google Groups "vim_use" group.
                  To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                  For more options, visit https://groups.google.com/groups/opt_out.
                Your message has been successfully submitted and would be delivered to recipients shortly.