Loading ...
Sorry, an error occurred while loading the content.

Re: Omni completion (^O^N^P) Pattern not found

Expand Messages
  • Dirk Wallenstein
    Does easytag install its own omnifunc? What does :set omnifunc? say with and without easytags? ... -- Grüße, Dirk -- -- You received this message from the
    Message 1 of 5 , Apr 27, 2013
    • 0 Attachment
      Does easytag install its own omnifunc?  What does ':set omnifunc?' say with and without easytags?


      On Sat, Apr 27, 2013 at 5:52 PM, rlewis <rlewis1554@...> wrote:
      I recently install javacomplete[1] and easytags[2]. Its structure is as below. However, when trying completion by pressing ctrl+x ctrl+o, message bar display

          Omni completion (^O^N^P) Pattern not found

      If removing easytags, then javacomplete plugin works again. How to fix this problem? Or any other alternative suggestion?

      Thanks

      javacomplete version is 0.77.1.2
      easytags version should be 3.1.5

      autoload:
      javacomplete.vim  java_parser.vim  nerdtree.vim  Reflection.class  Reflection.java  xolox

      doc:
      easytags.txt  javacomplete.txt  NERD_tree.txt  tags

      lib:
      nerdtree

      misc:
      easytags

      nerdtree_plugin:
      exec_menuitem.vim  fs_menu.vim

      plugin:
      easytags.vim  NERD_tree.vim

      syntax:
      nerdtree.vim

      [1]. http://vim.sourceforge.net/scripts/script.php?script_id=1785
      [2]. http://www.vim.org/scripts/script.php?script_id=3114

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.





      --
      Grüße,
        Dirk

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
       
      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
       
       
    • Asis Hallab
      Dear Riewis, this might be a workaround: http://www.vim.org/scripts/script.php?script_id=3221 I use Indexer to automatically update my tag files every time I
      Message 2 of 5 , Apr 28, 2013
      • 0 Attachment
        Dear Riewis,

        this might be a workaround:
        http://www.vim.org/scripts/script.php?script_id=3221

        I use Indexer to automatically update my tag files every time I save a code file. I find it very useful, because you don't have to manually invoke the tag update. Give it a try.

        Cheers!


        2013/4/28 Dirk Wallenstein <dirk.impersonator@...>
        Does easytag install its own omnifunc?  What does ':set omnifunc?' say with and without easytags?


        On Sat, Apr 27, 2013 at 5:52 PM, rlewis <rlewis1554@...> wrote:
        I recently install javacomplete[1] and easytags[2]. Its structure is as below. However, when trying completion by pressing ctrl+x ctrl+o, message bar display

            Omni completion (^O^N^P) Pattern not found

        If removing easytags, then javacomplete plugin works again. How to fix this problem? Or any other alternative suggestion?

        Thanks

        javacomplete version is 0.77.1.2
        easytags version should be 3.1.5

        autoload:
        javacomplete.vim  java_parser.vim  nerdtree.vim  Reflection.class  Reflection.java  xolox

        doc:
        easytags.txt  javacomplete.txt  NERD_tree.txt  tags

        lib:
        nerdtree

        misc:
        easytags

        nerdtree_plugin:
        exec_menuitem.vim  fs_menu.vim

        plugin:
        easytags.vim  NERD_tree.vim

        syntax:
        nerdtree.vim

        [1]. http://vim.sourceforge.net/scripts/script.php?script_id=1785
        [2]. http://www.vim.org/scripts/script.php?script_id=3114

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.





        --
        Grüße,
          Dirk
        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • rlewis
        In vim, typing :set omnifunc returns omnifunc=javacomplete#Complete with easytags; without easytags it still shows omnifunc=javacomplete#Complete For
        Message 3 of 5 , Apr 28, 2013
        • 0 Attachment
          In vim, typing ':set omnifunc' returns

          omnifunc=javacomplete#Complete

          with easytags; without easytags it still shows

          omnifunc=javacomplete#Complete

          For configuring indexer plugin, is the file .indexer_files with content as below correct?

          .indexer_files
          [PROJECTS_PARENT]
          option:ctags_params="--language-force=java"

          /path/to/vim-plugin-test

          The structure of the project (in vim-plugin-test) looks like

          pom.xml src .indexer_files target

          With above structure, opening the file e.g.
          vi src/main/java/com/company/app/Test.java

          Then at the point of the function e.g. abc(), pressing ctrl+] vim throws

          E426: tag not found

          tags is set with

          :set tags=/path/to/tags

          What steps may be missing?

          Thanks



          rlewis於 2013年4月27日星期六UTC+8下午11時52分40秒寫道:
          > I recently install javacomplete[1] and easytags[2]. Its structure is as below. However, when trying completion by pressing ctrl+x ctrl+o, message bar display
          >
          > Omni completion (^O^N^P) Pattern not found
          >
          > If removing easytags, then javacomplete plugin works again. How to fix this problem? Or any other alternative suggestion?
          >
          > Thanks
          >
          > javacomplete version is 0.77.1.2
          > easytags version should be 3.1.5
          >
          > autoload:
          > javacomplete.vim java_parser.vim nerdtree.vim Reflection.class Reflection.java xolox
          >
          > doc:
          > easytags.txt javacomplete.txt NERD_tree.txt tags
          >
          > lib:
          > nerdtree
          >
          > misc:
          > easytags
          >
          > nerdtree_plugin:
          > exec_menuitem.vim fs_menu.vim
          >
          > plugin:
          > easytags.vim NERD_tree.vim
          >
          > syntax:
          > nerdtree.vim
          >
          > [1]. http://vim.sourceforge.net/scripts/script.php?script_id=1785
          > [2]. http://www.vim.org/scripts/script.php?script_id=3114

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • rlewis
          Ok. Get Indexer working now, but not with javacomplete. Same problem (E426: Pattern not found) when activating javacomplete with easytages/ indexer. Indexer
          Message 4 of 5 , Apr 30, 2013
          • 0 Attachment
            Ok. Get Indexer working now, but not with javacomplete. Same problem (E426: Pattern not found) when activating javacomplete with easytages/ indexer.

            Indexer will function with following steps:

            1. copy all files to ~/.vim (including dependencies like vimprj and DfrankUtil)

            2. edit ~/.indexer_files with following content (content varies with corresponded user project)

            [vim-plugin-test]
            option:ctags_params = "--language-force=<language-name>"
            /path/to/vim-plugin-test


            Thanks for help.


            rlewis於 2013年4月27日星期六UTC+8下午11時52分40秒寫道:
            > I recently install javacomplete[1] and easytags[2]. Its structure is as below. However, when trying completion by pressing ctrl+x ctrl+o, message bar display
            >
            > Omni completion (^O^N^P) Pattern not found
            >
            > If removing easytags, then javacomplete plugin works again. How to fix this problem? Or any other alternative suggestion?
            >
            > Thanks
            >
            > javacomplete version is 0.77.1.2
            > easytags version should be 3.1.5
            >
            > autoload:
            > javacomplete.vim java_parser.vim nerdtree.vim Reflection.class Reflection.java xolox
            >
            > doc:
            > easytags.txt javacomplete.txt NERD_tree.txt tags
            >
            > lib:
            > nerdtree
            >
            > misc:
            > easytags
            >
            > nerdtree_plugin:
            > exec_menuitem.vim fs_menu.vim
            >
            > plugin:
            > easytags.vim NERD_tree.vim
            >
            > syntax:
            > nerdtree.vim
            >
            > [1]. http://vim.sourceforge.net/scripts/script.php?script_id=1785
            > [2]. http://www.vim.org/scripts/script.php?script_id=3114

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.