Loading ...
Sorry, an error occurred while loading the content.

vi defaults to dos line endings for new .gitignore file

Expand Messages
  • Andrew Pennebaker
    I ve put set fileformat=unix in my ~/.vimrc and ~/_vimrc, but when I vi .gitignore , it defaults to dos line endings. Can someone help me correct this
    Message 1 of 2 , Apr 24 12:38 PM
    • 0 Attachment
      I've put "set fileformat=unix" in my ~/.vimrc and ~/_vimrc, but when I "vi .gitignore", it defaults to dos line endings. Can someone help me correct this behavior?

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... See :help fileformats (note the trailing s character). Also see http://vim.wikia.com/wiki/File_format -- -- You received this message from the
      Message 2 of 2 , Apr 24 3:07 PM
      • 0 Attachment
        On Wednesday, April 24, 2013 2:38:33 PM UTC-5, Andrew Pennebaker wrote:
        > I've put "set fileformat=unix" in my ~/.vimrc and ~/_vimrc, but when I "vi .gitignore", it defaults to dos line endings. Can someone help me correct this behavior?

        See :help 'fileformats' (note the trailing 's' character).

        Also see http://vim.wikia.com/wiki/File_format

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.