Loading ...
Sorry, an error occurred while loading the content.

c auto comments

Expand Messages
  • sinbad
    the following are the comments and formatoptions comments=sO:* -,mO:* ,exO:*/,s1:/*,mb:*,ex:*/,:// formatoptions=croql iab com /* */ when i type
    Message 1 of 4 , Apr 23, 2013
    • 0 Attachment
      the following are the comments and formatoptions

      comments=sO:* -,mO:* ,exO:*/,s1:/*,mb:*,ex:*/,://
      formatoptions=croql


      iab com /*<CR><CR>*/<Up>

      when i type com, i was expecting

      /*
      *
      */

      but i'm getting

      /*
      *
      * */

      how to fix this.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... Because you have the x in your comment string ex parts, you can end a comment by typing only the last character on the new line as the first action.
      Message 2 of 4 , Apr 23, 2013
      • 0 Attachment
        On Tuesday, April 23, 2013 8:40:51 AM UTC-5, sinbad wrote:
        > the following are the comments and formatoptions
        >
        > comments=sO:* -,mO:* ,exO:*/,s1:/*,mb:*,ex:*/,://
        > formatoptions=croql
        >
        >
        > iab com /*<CR><CR>*/<Up>
        >
        > when i type com, i was expecting
        >
        > /*
        > *
        > */
        >
        > but i'm getting
        >
        > /*
        > *
        > * */
        >
        > how to fix this.

        Because you have the 'x' in your comment string "ex" parts, you can end a comment by typing only the last character on the new line as the first action. See :help format-comments.

        Specifically, your abbreviation should not be:

        /*<CR><CR>*/

        It should instead be:

        /*<CR><CR>/

        Because Vim will automatically end the comment on pressing '/' but will insert the text literally if you press */ instead.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • sheetal
        ... This is interesting, I want to know more on this, could give some pointers. other than :help format-comments which is picked from Ben s reply. -- -- You
        Message 3 of 4 , Apr 23, 2013
        • 0 Attachment
          On Tuesday, April 23, 2013 7:10:51 PM UTC+5:30, sinbad wrote:
          > the following are the comments and formatoptions
          >
          > comments=sO:* -,mO:* ,exO:*/,s1:/*,mb:*,ex:*/,://
          > formatoptions=croql
          >
          >
          > iab com /*<CR><CR>*/<Up>
          >
          > when i type com, i was expecting
          >
          > /*
          > *
          > */
          >
          > but i'm getting
          >
          > /*
          > *
          > * */
          >
          > how to fix this.

          This is interesting, I want to know more on this, could give some pointers. other than :help format-comments which is picked from Ben's reply.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Ben Fritz
          ... [Snip] ... When c is in the formatoptions option, comment leaders are inserted automatically when formatting comment lines to textwidth characters.
          Message 4 of 4 , Apr 24, 2013
          • 0 Attachment
            On Wednesday, April 24, 2013 1:59:30 AM UTC-5, sheetal wrote:
            > On Tuesday, April 23, 2013 7:10:51 PM UTC+5:30, sinbad wrote:
            > > the following are the comments and formatoptions
            > >
            > > comments=sO:* -,mO:* ,exO:*/,s1:/*,mb:*,ex:*/,://
            > > formatoptions=croql
            > >
            [Snip]
            >
            > This is interesting, I want to know more on this, could give some pointers. other than :help format-comments which is picked from Ben's reply.

            When 'c' is in the 'formatoptions' option, comment leaders are inserted automatically when formatting comment lines to 'textwidth' characters. When 'r' or 'o' is in 'formatoptions' as well, starting new lines manually also will insert the comment leader.

            Comment leaders are defined by the 'comments' option.

            The format of 'formatoptions' is given by :help fo-table. The format of 'comments' is given by :help format-comments.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.