Loading ...
Sorry, an error occurred while loading the content.

Re: gVim stripping diacritics not in keyboard charset

Expand Messages
  • Tuetschek
    ... I have finally solved the problem ... and it s kinda strange. I just downloaded Vim sources and built them using Visual Studio C++ Express 2010 according
    Message 1 of 8 , Apr 22 2:22 PM
    • 0 Attachment
      On Tuesday, March 30, 2010 9:01:36 PM UTC+2, Tuetschek wrote:
      > Thanks, but I'm sorry, your suggestions didn't help ... it really
      > doesn't matter which terminal or file encoding I have set, my font is
      > capable of displaying such characters (I can paste a "ř"' through
      > clipboard or open any file that contains it all right) and that
      > character is present in my locale "Czech_Republic.1250".
      >
      > I think it's got something to do with the way Vim handles Windows
      > input messages (since the console Windows version works OK).

      I have finally solved the problem ... and it's kinda strange. I just downloaded Vim sources and built them using Visual Studio C++ Express 2010 according to the instructions at http://vim.wikia.com/wiki/Build_Vim_in_Windows_with_Visual_Studio . I was planning to have closer look at the problem, put some debug mesagges in etc., but it dissapeared by itself after the first build.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tony Mechelynck
      ... Well, I m happy to know you finally got rid of the problem. I suppose we ll never know if the cure was due to a different procedure used to build Vim, or
      Message 2 of 8 , Apr 22 9:26 PM
      • 0 Attachment
        On 22/04/13 23:22, Tuetschek wrote:
        > On Tuesday, March 30, 2010 9:01:36 PM UTC+2, Tuetschek wrote:
        >> Thanks, but I'm sorry, your suggestions didn't help ... it really
        >> doesn't matter which terminal or file encoding I have set, my font is
        >> capable of displaying such characters (I can paste a "ř"' through
        >> clipboard or open any file that contains it all right) and that
        >> character is present in my locale "Czech_Republic.1250".
        >>
        >> I think it's got something to do with the way Vim handles Windows
        >> input messages (since the console Windows version works OK).
        >
        > I have finally solved the problem ... and it's kinda strange. I just downloaded Vim sources and built them using Visual Studio C++ Express 2010 according to the instructions at http://vim.wikia.com/wiki/Build_Vim_in_Windows_with_Visual_Studio . I was planning to have closer look at the problem, put some debug mesagges in etc., but it dissapeared by itself after the first build.
        >

        Well, I'm happy to know you finally got rid of the problem. I suppose
        we'll never know if the cure was due to a different procedure used to
        build Vim, or to one of the many bugfixes which happened in the three
        years (and almost a month) since then.

        For people who want to see the begin of this thread (e.g. if, like me,
        they read this by POP rather than on the Google Groups web interface),
        it is at
        https://groups.google.com/group/vim_use/browse_frm/thread/8ee40c183ebf4d27/


        Happy Vimming!
        Tony.
        --
        Due to circumstances beyond your control, you are master of your fate
        and captain of your soul.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.