Loading ...
Sorry, an error occurred while loading the content.

Re: syntax.vim: filetypedetect BufRead

Expand Messages
  • Ben Fritz
    ... I never set my runtimepath manually. Why do you need to? I note that mine is set (by default) to include /usr/local/share/vim/vim73 but not
    Message 1 of 6 , Apr 21, 2013
    • 0 Attachment
      On Sunday, April 21, 2013 7:02:13 AM UTC-5, xeon123 wrote:
      > I found my problem.
      >
      >
      > In my case I have declared wrong in the runtimepath in my ~/.vimrc "/usr/share/vim/vim72", and it must be "/usr/share/vim/vim73". After this change it works fine. 
      >
      >
      >
      >
      > Check you ":set runtimepath" directories to see if they are correct.
      >

      I never set my runtimepath manually.

      Why do you need to?

      I note that mine is set (by default) to include /usr/local/share/vim/vim73 but not /usr/share/vim/vim73.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tony Mechelynck
      ... When you compile Vim yourself on Unix-like systems, it will normally install under /usr/local/: executable in /usr/local/bin/ runtime files (for Vim 7.3)
      Message 2 of 6 , Apr 21, 2013
      • 0 Attachment
        On 21/04/13 18:37, Ben Fritz wrote:
        > On Sunday, April 21, 2013 7:02:13 AM UTC-5, xeon123 wrote:
        >> I found my problem.
        >>
        >>
        >> In my case I have declared wrong in the runtimepath in my ~/.vimrc "/usr/share/vim/vim72", and it must be "/usr/share/vim/vim73". After this change it works fine.
        >>
        >>
        >>
        >>
        >> Check you ":set runtimepath" directories to see if they are correct.
        >>
        >
        > I never set my runtimepath manually.
        >
        > Why do you need to?
        >
        > I note that mine is set (by default) to include /usr/local/share/vim/vim73 but not /usr/share/vim/vim73.
        >

        When you compile Vim yourself on Unix-like systems, it will normally
        install under /usr/local/:

        executable in /usr/local/bin/
        runtime files (for Vim 7.3) in /usr/local/share/vim/vim73/
        system vimrc (not always present) is looked for at /usr/local/vim/vimrc
        etc.

        When you get a Vim package from a Linux distro, the paths are different:

        executable in /usr/bin/
        runtime files (for Vim 7.3) in /usr/share/vim/vim/73/
        system vimrc (not always present) is looked for at (e.g.) /etc/vimrc
        etc.

        This avoids conflicts if you have both; and, since /usr/local/bin comes
        before /usr/bin in the $PATH, invoking vim without a path will get you
        the one you compiled yourself.


        Best regards,
        Tony.
        --
        Support bacteria -- it's the only culture some people have!

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.