Loading ...
Sorry, an error occurred while loading the content.

Re: syntax.vim: filetypedetect BufRead

Expand Messages
  • Tony Mechelynck
    ... I have the same (bracketed by :if !s:did_ft), and in addition, at lines 21 sqq I see: Load the FileType autocommands if not done yet. if
    Message 1 of 6 , Apr 20, 2013
    • 0 Attachment
      On 20/04/13 18:15, Ben Fritz wrote:
      > On Saturday, April 20, 2013 7:54:50 AM UTC-5, xeon123 wrote:
      >> The syntax highlight in vim 7.3 doesn't work. I get the following error. How can I fix that?
      >>
      >> Error detected while processing /usr/share/vim/vim73/syntax/syntax.vim:
      >> line 42:
      >> E216: No such group or event: filetypedetect BufRead
      >>
      >> I'm using Debian 7.0.
      >>
      >> Thanks,
      >
      > Works fine for me. Maybe you're using a "tiny" Vim or something? What are the first few lines of your :version output?
      >
      > The line 42 in my /usr/share/vim/vim73/syntax/syntax.vim is:
      >
      > doautoall filetypedetect BufRead
      >
      > Maybe you need to turn on filetype detection prior to turning on syntax highlight? I seem to remember someone on this list saying that "syntax on" automatically implies filetype detection, but it's worth a shot to put "filetype on" before "syntax on" in your .vimrc.
      >
      > This could also be "filetype plugin on", "filetype indent on", or "filetype indent plugin on" for more features.
      >

      I have the same (bracketed by :if !s:did_ft), and in addition, at lines
      21 sqq I see:

      " Load the FileType autocommands if not done yet.
      if exists("did_load_filetypes")
      let s:did_ft = 1
      else
      filetype on
      let s:did_ft = 0
      endif

      so by the time the doautoall line is reached, filetype detection should
      already be on.

      Of course I use Bram's original sources, downloaded from
      https://vim.googlecode.com/hg/ (with no Debian “improvements”), and the
      openSUSE system vimrc (if any) is at /etc/vimrc which is not where this
      Vim build looks for it (at $VIM/vimrc i.e. /usr/local/share/vim/vimrc).


      Best regards,
      Tony.
      --
      "If God lived on Earth, people would knock out all His windows."
      -- Yiddish saying

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Pedro Sá da Costa
      I found my problem. In my case I have declared wrong in the runtimepath in my ~/.vimrc /usr/share/vim/vim72 , and it must be /usr/share/vim/vim73 . After
      Message 2 of 6 , Apr 21, 2013
      • 0 Attachment
        I found my problem.

        In my case I have declared wrong in the runtimepath in my ~/.vimrc "/usr/share/vim/vim72", and it must be "/usr/share/vim/vim73". After this change it works fine. 

        Check you ":set runtimepath" directories to see if they are correct.




        On 21 April 2013 02:59, Tony Mechelynck <antoine.mechelynck@...> wrote:
        On 20/04/13 18:15, Ben Fritz wrote:
        On Saturday, April 20, 2013 7:54:50 AM UTC-5, xeon123 wrote:
        The syntax highlight in vim 7.3 doesn't work. I get the following error. How can I fix that?

        Error detected while processing /usr/share/vim/vim73/syntax/syntax.vim:
        line   42:
        E216: No such group or event: filetypedetect BufRead

        I'm using Debian 7.0.

        Thanks,

        Works fine for me. Maybe you're using a "tiny" Vim or something? What are the first few lines of your :version output?

        The line 42 in my /usr/share/vim/vim73/syntax/syntax.vim is:

           doautoall filetypedetect BufRead

        Maybe you need to turn on filetype detection prior to turning on syntax highlight? I seem to remember someone on this list saying that "syntax on" automatically implies filetype detection, but it's worth a shot to put "filetype on" before "syntax on" in your .vimrc.

        This could also be "filetype plugin on", "filetype indent on", or "filetype indent plugin on" for more features.


        I have the same (bracketed by :if !s:did_ft), and in addition, at lines 21 sqq I see:

        " Load the FileType autocommands if not done yet.
        if exists("did_load_filetypes")
          let s:did_ft = 1
        else
          filetype on
          let s:did_ft = 0
        endif

        so by the time the doautoall line is reached, filetype detection should already be on.

        Of course I use Bram's original sources, downloaded from https://vim.googlecode.com/hg/ (with no Debian “improvements”), and the openSUSE system vimrc (if any) is at /etc/vimrc which is not where this Vim build looks for it (at $VIM/vimrc i.e. /usr/local/share/vim/vimrc).


        Best regards,
        Tony.
        --
        "If God lived on Earth, people would knock out all His windows."
                        -- Yiddish saying


        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        --- You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@googlegroups.com.
        For more options, visit https://groups.google.com/groups/opt_out.





        --
        Best regards,

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
         
        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
         
         
      • Ben Fritz
        ... I never set my runtimepath manually. Why do you need to? I note that mine is set (by default) to include /usr/local/share/vim/vim73 but not
        Message 3 of 6 , Apr 21, 2013
        • 0 Attachment
          On Sunday, April 21, 2013 7:02:13 AM UTC-5, xeon123 wrote:
          > I found my problem.
          >
          >
          > In my case I have declared wrong in the runtimepath in my ~/.vimrc "/usr/share/vim/vim72", and it must be "/usr/share/vim/vim73". After this change it works fine. 
          >
          >
          >
          >
          > Check you ":set runtimepath" directories to see if they are correct.
          >

          I never set my runtimepath manually.

          Why do you need to?

          I note that mine is set (by default) to include /usr/local/share/vim/vim73 but not /usr/share/vim/vim73.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Tony Mechelynck
          ... When you compile Vim yourself on Unix-like systems, it will normally install under /usr/local/: executable in /usr/local/bin/ runtime files (for Vim 7.3)
          Message 4 of 6 , Apr 21, 2013
          • 0 Attachment
            On 21/04/13 18:37, Ben Fritz wrote:
            > On Sunday, April 21, 2013 7:02:13 AM UTC-5, xeon123 wrote:
            >> I found my problem.
            >>
            >>
            >> In my case I have declared wrong in the runtimepath in my ~/.vimrc "/usr/share/vim/vim72", and it must be "/usr/share/vim/vim73". After this change it works fine.
            >>
            >>
            >>
            >>
            >> Check you ":set runtimepath" directories to see if they are correct.
            >>
            >
            > I never set my runtimepath manually.
            >
            > Why do you need to?
            >
            > I note that mine is set (by default) to include /usr/local/share/vim/vim73 but not /usr/share/vim/vim73.
            >

            When you compile Vim yourself on Unix-like systems, it will normally
            install under /usr/local/:

            executable in /usr/local/bin/
            runtime files (for Vim 7.3) in /usr/local/share/vim/vim73/
            system vimrc (not always present) is looked for at /usr/local/vim/vimrc
            etc.

            When you get a Vim package from a Linux distro, the paths are different:

            executable in /usr/bin/
            runtime files (for Vim 7.3) in /usr/share/vim/vim/73/
            system vimrc (not always present) is looked for at (e.g.) /etc/vimrc
            etc.

            This avoids conflicts if you have both; and, since /usr/local/bin comes
            before /usr/bin in the $PATH, invoking vim without a path will get you
            the one you compiled yourself.


            Best regards,
            Tony.
            --
            Support bacteria -- it's the only culture some people have!

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.