Loading ...
Sorry, an error occurred while loading the content.

Re: Broken undo?

Expand Messages
  • Mime Čuvalo
    Hello, I see this thread is a bit old (and that no bug was filed :P) but was wondering: - did this ever get resolved? - or, is there a workaround? For me the
    Message 1 of 11 , Apr 20, 2013
    • 0 Attachment
      Hello,
      I see this thread is a bit old (and that no bug was filed :P) but was wondering:
      - did this ever get resolved?
      - or, is there a workaround?

      For me the issue arises in usage of the delimitMate plugin (related bug: https://github.com/Raimondi/delimitMate/issues/114 )

      Cheers!
      Mime


      On Friday, May 14, 2010 11:44:40 AM UTC+2, Bram Moolenaar wrote:
      > Israel Chauca wrote:
      >
      >
      >
      > > On May 13, 2010, at 3:56 PM, Bram Moolenaar wrote:
      >
      > > >
      >
      > > >
      >
      > > >>> That indeed looks like a bug.
      >
      > > >>
      >
      > > >> Good to know. Should I write a ticket for this bug somewhere or do
      >
      > > >> something else?
      >
      > > >
      >
      > > > No need. Storing bugs in a dusty database won't help getting them
      >
      > > > solved.
      >
      > >
      >
      > > Noted.
      >
      > >
      >
      > > >>>> If I undo again, I get the original empty window.
      >
      > > >>>>
      >
      > > >>>> If I start in the second step, I can't undo to the empty window, I'm
      >
      > > >>>> left with two lines but I can exit vim as if the buffer was in its
      >
      > > >>>> original state.
      >
      > > >>>
      >
      > > >>> I don't see this problem.
      >
      > > >>
      >
      > > >> I can reproduce it in the default vim for MacOS X 10.6 and MacVim, but
      >
      > > >> neither of them are the latest version, when I can compile vim in my
      >
      > > >> Mac I'll try again.
      >
      > > >
      >
      > > > Perhaps you need to explain more cleary what you do exactly.
      >
      > >
      >
      > > The next steps are are just one insert:
      >
      > > 1. Insert 1.
      >
      > > 2. Now <C-R>=setline('.','12')<CR>
      >
      > > 3. Insert <CR>
      >
      > > 4. Exit insert mode and undo (u).
      >
      > >
      >
      > > The buffer should be empty but it has two lines, the first one is
      >
      > > empty and the second one has the number 2 in it. Since the buffer
      >
      > > isn't empty, I should get E37 when I :quit, instead vim exits without
      >
      > > any message.
      >
      > >
      >
      > > Let's see if that works.
      >
      >
      >
      > I see it. It's the same problem as the first one in a different form.
      >
      >
      >
      > --
      >
      > hundred-and-one symptoms of being an internet addict:
      >
      > 34. You laugh at people with 14400 baud modems.
      >
      >
      >
      > /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      >
      > /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      >
      > \\\ download, build and distribute -- http://www.A-A-P.org ///
      >
      > \\\ help me help AIDS victims -- http://ICCF-Holland.org ///
      >
      >
      >
      > --
      >
      > You received this message from the "vim_use" maillist.
      >
      > Do not top-post! Type your reply below the text you are replying to.
      >
      > For more information, visit http://www.vim.org/maillist.php

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Bram Moolenaar
      ... The issue is still in the todo list. That list is rather long... -- hundred-and-one symptoms of being an internet addict: 200. You really believe in the
      Message 2 of 11 , Apr 21, 2013
      • 0 Attachment
        Israel Chauca wrote:

        > Hello,
        > I see this thread is a bit old (and that no bug was filed :P) but was
        > wondering:
        > - did this ever get resolved?
        > - or, is there a workaround?
        >
        > For me the issue arises in usage of the delimitMate plugin (related
        > bug: https://github.com/Raimondi/delimitMate/issues/114 )

        The issue is still in the todo list. That list is rather long...

        --
        hundred-and-one symptoms of being an internet addict:
        200. You really believe in the concept of a "paperless" office.

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ an exciting new programming language -- http://www.Zimbu.org ///
        \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christian Brabandt
        Hi Mime! ... Can you check, if this patch fixes it for you? https://groups.google.com/d/msg/vim_use/Rw637BtyIWs/WSWPdp4jW2oJ Mit freundlichen Grüßen
        Message 3 of 11 , Apr 21, 2013
        • 0 Attachment
          Hi Mime!

          On Sa, 20 Apr 2013, Mime Čuvalo wrote:

          > Hello,
          > I see this thread is a bit old (and that no bug was filed :P) but was wondering:
          > - did this ever get resolved?
          > - or, is there a workaround?
          >
          > For me the issue arises in usage of the delimitMate plugin (related bug: https://github.com/Raimondi/delimitMate/issues/114 )

          Can you check, if this patch fixes it for you?
          https://groups.google.com/d/msg/vim_use/Rw637BtyIWs/WSWPdp4jW2oJ

          Mit freundlichen Grüßen
          Christian
          --
          Wenn der Kernel keinen Treiber für das ATAPI-CDROM hat,
          wie soll er dann dafür eine SCSI-Emulation machen?
          Merke: erst denken, dann posten.
          -- Felix von Leitner

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.