Loading ...
Sorry, an error occurred while loading the content.

Re: Using same font looks bad in different computers / configurations

Expand Messages
  • Tony Mechelynck
    On 17/04/13 22:45, skeept wrote: [...] ... When I still was on Windows, I never tried to use gvim for Cygwin X11; instead I used a Console Vim as available
    Message 1 of 3 , Apr 17, 2013
    • 0 Attachment
      On 17/04/13 22:45, skeept wrote:
      [...]
      > Hi Tony,
      >
      > I know the basics of changing the font, the issue here is that I believe there is a bug or an issue when vim is configured with
      > --enable-gui=auto or --enable-gui=gtk2
      >
      > After I wrote this email I tried configuring with
      > --enable-gui=motif
      > and in that case the fonts look good. So in the same machine, using the same font I have one that looks quite good and another that looks quite bad (this is in unix, I don't know if this is also the case in cygwin).
      >
      > I also tried configuring with
      > --enable-gui=gnome2
      > and the configure finished fine but then when compiling I have the error
      >
      > gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/openwin/include -I/usr/sfw/include -I/usr/sfw/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DORBIT2=1 -mt -I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/libbonoboui-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/include/pango-1.0 -I/usr/sfw/include/freetype2 -I/usr/sfw/include -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/openwin/include -I/usr/include/libxml2 -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -o objects/buffer.o buffer.c
      >
      > gcc: error: unrecognized command line option '-mt'
      >
      >
      > Best Regards,
      >
      > Jorge
      >
      When I still was on Windows, I never tried to use gvim for Cygwin X11;
      instead I used a Console Vim as available from Cygwin, and both vim.exe
      and gvim.exe for Native-Windows (similar to the "Vim without Cream"
      packages now regularly published by Steve Hall). I don't know where this
      -mt option comes from.


      Best regards,
      Tony.
      --
      (letter from Mark to Mike, about the film's probale certificate)
      I would like to get back to the Censor and agree to lose the
      shits, take
      the odd Jesus Christ out and lose Oh fuck off, but to retain 'fart in
      your general direction', 'castanets of your testicles' and 'oral sex'
      and ask him for an 'A' rating on that basis.
      "Monty Python and the Holy Grail" PYTHON (MONTY)
      PICTURES LTD

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.