Loading ...
Sorry, an error occurred while loading the content.

Re: Using same font looks bad in different computers / configurations

Expand Messages
  • Tony Mechelynck
    ... When using Vim in a console (be it Windows cmd.exe, Cygwin bash, the Linux text console, Mac Terminal, or any of a number of emulators displaying through
    Message 1 of 3 , Apr 17 1:05 PM
    • 0 Attachment
      On 16/04/13 16:53, skeept wrote:
      > Hi,
      >
      > when using vim in cygwin the font looks really bad when compared when the windows version.
      >
      > I also compiled vim in sunos 5.9 and 5.10. The gvim version in the 5.9 looks much better.
      >
      > Can anyone give me hints on how to configure vim to have the font look better on sunos 5.10?
      >
      > Regards,
      >
      > Jorge
      >

      When using Vim in a console (be it Windows cmd.exe, Cygwin bash, the
      Linux text console, Mac Terminal, or any of a number of emulators
      displaying through X11 such as xterm, mlterm, konsole, gnome-terminal,
      etc., Vim has no knowledge of the font face, the terminal does it all.

      When using gvim (the Vim GUI), it can use any monospace (i.e.
      fixed-width) font installed on your computer (GVIM for GTK2 GUI can
      actually use any installed font at all but if you try to use a
      non-monospace font the result will be ugly anyway.) You can set the font
      face, the character size, and sometimes some other attributes, by means
      of the 'guifont' aka 'gfn' option. For details, see
      http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI

      If you want to use a different font on different operating systems, you
      can do it by setting 'guifont' in various branches of an :if … :elseif …
      :elseif … :else … :endif statement block; the above wiki page has an
      example of that.


      Best regards,
      Tony.
      --
      Hacker's Law:
      The belief that enhanced understanding will necessarily stir a
      nation to action is one of mankind's oldest illusions.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • skeept
      ... Hi Tony, I know the basics of changing the font, the issue here is that I believe there is a bug or an issue when vim is configured with --enable-gui=auto
      Message 2 of 3 , Apr 17 1:45 PM
      • 0 Attachment
        >
        > When using Vim in a console (be it Windows cmd.exe, Cygwin bash, the
        >
        > Linux text console, Mac Terminal, or any of a number of emulators
        >
        > displaying through X11 such as xterm, mlterm, konsole, gnome-terminal,
        >
        > etc., Vim has no knowledge of the font face, the terminal does it all.
        >
        >
        >
        > When using gvim (the Vim GUI), it can use any monospace (i.e.
        >
        > fixed-width) font installed on your computer (GVIM for GTK2 GUI can
        >
        > actually use any installed font at all but if you try to use a
        >
        > non-monospace font the result will be ugly anyway.) You can set the font
        >
        > face, the character size, and sometimes some other attributes, by means
        >
        > of the 'guifont' aka 'gfn' option. For details, see
        >
        > http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI
        >
        >
        >
        > If you want to use a different font on different operating systems, you
        >
        > can do it by setting 'guifont' in various branches of an :if … :elseif …
        >
        > :elseif … :else … :endif statement block; the above wiki page has an
        >
        > example of that.
        >
        >
        >
        >
        >
        > Best regards,
        >
        > Tony.
        >
        > --
        >
        > Hacker's Law:
        >
        > The belief that enhanced understanding will necessarily stir a
        >
        > nation to action is one of mankind's oldest illusions.

        Hi Tony,

        I know the basics of changing the font, the issue here is that I believe there is a bug or an issue when vim is configured with
        --enable-gui=auto or --enable-gui=gtk2

        After I wrote this email I tried configuring with
        --enable-gui=motif
        and in that case the fonts look good. So in the same machine, using the same font I have one that looks quite good and another that looks quite bad (this is in unix, I don't know if this is also the case in cygwin).

        I also tried configuring with
        --enable-gui=gnome2
        and the configure finished fine but then when compiling I have the error

        gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/openwin/include -I/usr/sfw/include -I/usr/sfw/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DORBIT2=1 -mt -I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/libbonoboui-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/include/pango-1.0 -I/usr/sfw/include/freetype2 -I/usr/sfw/include -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/openwin/include -I/usr/include/libxml2 -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -o objects/buffer.o buffer.c

        gcc: error: unrecognized command line option '-mt'


        Best Regards,

        Jorge

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Tony Mechelynck
        On 17/04/13 22:45, skeept wrote: [...] ... When I still was on Windows, I never tried to use gvim for Cygwin X11; instead I used a Console Vim as available
        Message 3 of 3 , Apr 17 2:03 PM
        • 0 Attachment
          On 17/04/13 22:45, skeept wrote:
          [...]
          > Hi Tony,
          >
          > I know the basics of changing the font, the issue here is that I believe there is a bug or an issue when vim is configured with
          > --enable-gui=auto or --enable-gui=gtk2
          >
          > After I wrote this email I tried configuring with
          > --enable-gui=motif
          > and in that case the fonts look good. So in the same machine, using the same font I have one that looks quite good and another that looks quite bad (this is in unix, I don't know if this is also the case in cygwin).
          >
          > I also tried configuring with
          > --enable-gui=gnome2
          > and the configure finished fine but then when compiling I have the error
          >
          > gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/openwin/include -I/usr/sfw/include -I/usr/sfw/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DORBIT2=1 -mt -I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gtk-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2 -I/usr/include/libbonoboui-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/orbit-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/include/pango-1.0 -I/usr/sfw/include/freetype2 -I/usr/sfw/include -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/openwin/include -I/usr/include/libxml2 -g -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1 -o objects/buffer.o buffer.c
          >
          > gcc: error: unrecognized command line option '-mt'
          >
          >
          > Best Regards,
          >
          > Jorge
          >
          When I still was on Windows, I never tried to use gvim for Cygwin X11;
          instead I used a Console Vim as available from Cygwin, and both vim.exe
          and gvim.exe for Native-Windows (similar to the "Vim without Cream"
          packages now regularly published by Steve Hall). I don't know where this
          -mt option comes from.


          Best regards,
          Tony.
          --
          (letter from Mark to Mike, about the film's probale certificate)
          I would like to get back to the Censor and agree to lose the
          shits, take
          the odd Jesus Christ out and lose Oh fuck off, but to retain 'fart in
          your general direction', 'castanets of your testicles' and 'oral sex'
          and ask him for an 'A' rating on that basis.
          "Monty Python and the Holy Grail" PYTHON (MONTY)
          PICTURES LTD

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.