Loading ...
Sorry, an error occurred while loading the content.

Any way to disable plugins for finding a problem?

Expand Messages
  • Niels Kobschätzki
    Hi, when I open a tex-file vim suddenly uses more than 100% CPU and freezes (when I use MacVim it usually freezes the moment I switch away from the
    Message 1 of 3 , Apr 16, 2013
    • 0 Attachment
      Hi,

      when I open a tex-file vim suddenly uses more than 100% CPU and freezes
      (when I use MacVim it usually freezes the moment I switch away from the
      MacVim-window).

      Is there an easy way to disable plugins, so that I can find out which
      one the problematic one is? I don't want to uninstall all (not that hard
      since I am using vundle) and install them one-by-one but I'd like to
      disable them and then enable one by one to see where the problem is.

      Thanks,

      Niels

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Ben Fritz
      ... You can disable all of them with the --no-plugin switch when launching Vim. To re-enable one by one, you COULD combine that with a runtime
      Message 2 of 3 , Apr 16, 2013
      • 0 Attachment
        On Tuesday, April 16, 2013 8:24:34 AM UTC-5, Niels Kobschätzki wrote:
        > Hi,
        >
        >
        >
        > when I open a tex-file vim suddenly uses more than 100% CPU and freezes
        >
        > (when I use MacVim it usually freezes the moment I switch away from the
        >
        > MacVim-window).
        >
        >
        >
        > Is there an easy way to disable plugins, so that I can find out which
        >
        > one the problematic one is? I don't want to uninstall all (not that hard
        >
        > since I am using vundle) and install them one-by-one but I'd like to
        >
        > disable them and then enable one by one to see where the problem is.
        >

        You can disable all of them with the --no-plugin switch when launching Vim.

        To re-enable one by one, you COULD combine that with a "runtime plugin/someplugin.vim" to enable a specific plugin after load. But this would be probably even more onerous than removing plugins in vundle and putting them back in one by one.

        Alternatively, *most* plugins have a load guard like:

        if exists('g:loaded_someplugin')
        finish
        endif
        let g:loaded_someplugin = 1

        For any such plugins you can simply put "let g:loaded_someplugin = 'skip'" into your .vimrc, and remove that line and restart Vim to re-enable the plugin.

        I think I remember at least one of VAM and vundle also claim to support enabling/disabling plugins while Vim is still running, but I don't remember which does this, and I didn't see that mentioned in the brief glance at each github page. Perhaps I'm misremembering.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Niels Kobschätzki
        ... Ok, that s not really easy as well…I went the uninstall-way with vundle and found the incompatability (which got confirmed by some more googling).
        Message 3 of 3 , Apr 16, 2013
        • 0 Attachment
          On 16 Apr 2013, at 17:46, Ben Fritz wrote:

          > On Tuesday, April 16, 2013 8:24:34 AM UTC-5, Niels Kobschätzki wrote:
          >> Hi,
          >>
          >>
          >>
          >> when I open a tex-file vim suddenly uses more than 100% CPU and
          >> freezes
          >>
          >> (when I use MacVim it usually freezes the moment I switch away from
          >> the
          >>
          >> MacVim-window).
          >>
          >>
          >>
          >> Is there an easy way to disable plugins, so that I can find out which
          >>
          >> one the problematic one is? I don't want to uninstall all (not that
          >> hard
          >>
          >> since I am using vundle) and install them one-by-one but I'd like to
          >>
          >> disable them and then enable one by one to see where the problem is.
          >>
          >
          > You can disable all of them with the --no-plugin switch when launching
          > Vim.
          >
          > To re-enable one by one, you COULD combine that with a "runtime
          > plugin/someplugin.vim" to enable a specific
          > plugin after load. But this would be probably even more onerous than
          > removing plugins in vundle and putting them back in one by one.
          >
          > Alternatively, *most* plugins have a load guard like:
          >
          > if exists('g:loaded_someplugin')
          > finish
          > endif
          > let g:loaded_someplugin = 1
          >
          > For any such plugins you can simply put "let g:loaded_someplugin =
          > 'skip'" into your .vimrc, and remove that line and restart Vim to
          > re-enable the plugin.
          >
          > I think I remember at least one of VAM and vundle also claim to
          > support enabling/disabling plugins while Vim is still running, but I
          > don't remember which does this, and I didn't see that mentioned in the
          > brief glance at each
          > github page. Perhaps I'm misremembering.

          Ok, that's not really easy as well…I went the uninstall-way with
          vundle and found the incompatability (which got confirmed by some more
          googling).

          Thanks,

          Niels

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.