Loading ...
Sorry, an error occurred while loading the content.

how to restore the terminal after quit vim

Expand Messages
  • lidaweitz@...
    Hi Everyone, I just installed macvim in my mac pro 13 and I met a problem that when I quit vim, it does not restore the previous commands I typed in terminal.
    Message 1 of 3 , Apr 12, 2013
    • 0 Attachment
      Hi Everyone,

      I just installed macvim in my mac pro 13 and I met a problem that when I quit vim, it does not restore the previous commands I typed in terminal.

      For example,

      $ls
      a.data b.data
      $vim a.data

      this is a story

      Then I quit a.data, it still shows:

      this is a story
      $

      How should I change settings so the previous commands like "ls" will restore?

      Thanks,
      David


      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tim Chase
      ... This may depend on your termcap for terminal. By default, I believe Vim does this if it knows how. You can read up at ... the behavior of which is
      Message 2 of 3 , Apr 12, 2013
      • 0 Attachment
        On 2013-04-12 08:50, lidaweitz@... wrote:
        > I just installed macvim in my mac pro 13 and I met a problem that
        > when I quit vim, it does not restore the previous commands I typed
        > in terminal.
        >
        > For example,
        >
        > $ls
        > a.data b.data
        > $vim a.data
        >
        > this is a story
        >
        > Then I quit a.data, it still shows:
        >
        > this is a story
        > $
        >
        > How should I change settings so the previous commands like "ls"
        > will restore?

        This may depend on your termcap for terminal. By default, I believe
        Vim does this if it knows how. You can read up at

        :help xterm-screens

        the behavior of which is controlled by the 't_ti' and 't_te'
        settings. They're likely blank. If so, and your terminal supports
        swapping banked screens, you set the corresponding escape-sequences
        in your vimrc (perhaps wrapped in an if...endif block to detect your
        particular environment). Alternatively, perhaps at one point you set
        these to blank values in your vimrc, and you can just remove the
        overriding lines to restore factory behavior.

        -tim



        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • lidaweitz@...
        ... Thanks Tim. I have just reinstalled vim with homebrew and it is working properly now. -- -- You received this message from the vim_use maillist. Do not
        Message 3 of 3 , Apr 12, 2013
        • 0 Attachment
          On Friday, April 12, 2013 12:55:11 PM UTC-4, Tim Chase wrote:
          >
          > > I just installed macvim in my mac pro 13 and I met a problem that
          >
          > > when I quit vim, it does not restore the previous commands I typed
          >
          > > in terminal.
          >
          > >
          >
          > > For example,
          >
          > >
          >
          > > $ls
          >
          > > a.data b.data
          >
          > > $vim a.data
          >
          > >
          >
          > > this is a story
          >
          > >
          >
          > > Then I quit a.data, it still shows:
          >
          > >
          >
          > > this is a story
          >
          > > $
          >
          > >
          >
          > > How should I change settings so the previous commands like "ls"
          >
          > > will restore?
          >
          >
          >
          > This may depend on your termcap for terminal. By default, I believe
          >
          > Vim does this if it knows how. You can read up at
          >
          >
          >
          > :help xterm-screens
          >
          >
          >
          > the behavior of which is controlled by the 't_ti' and 't_te'
          >
          > settings. They're likely blank. If so, and your terminal supports
          >
          > swapping banked screens, you set the corresponding escape-sequences
          >
          > in your vimrc (perhaps wrapped in an if...endif block to detect your
          >
          > particular environment). Alternatively, perhaps at one point you set
          >
          > these to blank values in your vimrc, and you can just remove the
          >
          > overriding lines to restore factory behavior.
          >
          >
          >
          > -tim

          Thanks Tim. I have just reinstalled vim with homebrew and it is working properly now.

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.