Loading ...
Sorry, an error occurred while loading the content.
 

Re: What character is this?

Expand Messages
  • Christian Brabandt
    Hi Ben! ... characterize doesn t work with combining chars. regards, Christian -- Es ist nichts so allgemein, als falsche Worte in gutem Schein. -- Sprichwort
    Message 1 of 11 , Apr 10, 2013
      Hi Ben!

      On Mi, 10 Apr 2013, Ben Fritz wrote:

      > You might want to update the documentation at
      > http://www.vim.org/scripts/script.php?script_id=2822 to mention
      > :UnicodeName, I didn't realize this was a feature of the plugin when I
      > was looking for a way to get the name and digraph of characters I
      > already had. I ended up installing characterize instead (
      > http://www.vim.org/scripts/script.php?script_id=4410 ) which is
      > actually a better match for me but others might miss the feature, too.

      characterize doesn't work with combining chars.

      regards,
      Christian
      --
      Es ist nichts so allgemein, als falsche Worte in gutem Schein.
      -- Sprichwort

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Tony Mechelynck
      ... ah, nice plugin; and the first time it fetches the UnicodeData.txt file from the Unicode Consortium s site. :-) After some playing with it, I notice that
      Message 2 of 11 , Apr 10, 2013
        On 10/04/13 21:27, Christian Brabandt wrote:
        > Hi stosss!
        >
        > On Mi, 10 Apr 2013, stosss wrote:
        >
        >> This single character unit is showing up in a text file ^F the cursor only
        >> stops on the ^ portion of it and never on the F portion. It shows up in the
        >> middle of words only.
        >>
        >> What can I type in the search or search and replace so I can quickly find
        >> and remove all of them? Searching for ^F or ^ or F doesn't work. pressing
        >> CTRL f after / brought up the search history.
        >
        > This is probably ctrl-f. if you want to search for it, you need to
        > insert it literally, e.g. type Ctrl-V Ctrl-F (see :h i_CTRL-V)
        >
        > BTW: You can use the unicode.vim plugin, to find the name of a
        > character. E.g. Put the cursor on the char and enter :UnicodeName
        >
        > regards,
        > Christian
        >

        ah, nice plugin; and the first time it fetches the UnicodeData.txt file
        from the Unicode Consortium's site. :-)

        After some playing with it, I notice that characters not in the list
        (e.g. U+3102) give errors:

        Error detected while processing function unicode#GetUniChar:
        line 38:
        E118: Too many arguments for function: add
        line 47:
        E684: list index out of range: 0
        E116: invalid arguments for function printf("'%s' U+%04X %s %s %s",
        glyph, values(dict)[0], keys(dict)[0], dchar, html))
        E116: Invalid arguments for function add

        All in all, I like it, in spite of these errors.


        Best regards,
        Tony.
        --
        Truth will be out this morning. (Which may really mess things up.)

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Christian Brabandt
        Hi Tony! ... I think, this error is fixed in the latest development version on github. Can you please try with that version? If you find more errors, please
        Message 3 of 11 , Apr 10, 2013
          Hi Tony!

          On Do, 11 Apr 2013, Tony Mechelynck wrote:

          > ah, nice plugin; and the first time it fetches the UnicodeData.txt
          > file from the Unicode Consortium's site. :-)
          >
          > After some playing with it, I notice that characters not in the list
          > (e.g. U+3102) give errors:
          >
          > Error detected while processing function unicode#GetUniChar:
          > line 38:
          > E118: Too many arguments for function: add
          > line 47:
          > E684: list index out of range: 0
          > E116: invalid arguments for function printf("'%s' U+%04X %s %s %s",
          > glyph, values(dict)[0], keys(dict)[0], dchar, html))
          > E116: Invalid arguments for function add
          >
          > All in all, I like it, in spite of these errors.

          I think, this error is fixed in the latest development version on
          github. Can you please try with that version? If you find more errors,
          please tell me and I'll fix those.

          regards,
          Christian
          --

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • Tony Mechelynck
          ... After git clone, make vimball, updating manually (because I place that plugin in $VIM/vimfiles, not ~/.vim), removing the BOM from the helpfile (I have
          Message 4 of 11 , Apr 11, 2013
            On 11/04/13 07:40, Christian Brabandt wrote:
            > Hi Tony!
            >
            > On Do, 11 Apr 2013, Tony Mechelynck wrote:
            >
            >> ah, nice plugin; and the first time it fetches the UnicodeData.txt
            >> file from the Unicode Consortium's site. :-)
            >>
            >> After some playing with it, I notice that characters not in the list
            >> (e.g. U+3102) give errors:
            >>
            >> Error detected while processing function unicode#GetUniChar:
            >> line 38:
            >> E118: Too many arguments for function: add
            >> line 47:
            >> E684: list index out of range: 0
            >> E116: invalid arguments for function printf("'%s' U+%04X %s %s %s",
            >> glyph, values(dict)[0], keys(dict)[0], dchar, html))
            >> E116: Invalid arguments for function add
            >>
            >> All in all, I like it, in spite of these errors.
            >
            > I think, this error is fixed in the latest development version on
            > github. Can you please try with that version? If you find more errors,
            > please tell me and I'll fix those.
            >
            > regards,
            > Christian
            >

            After git clone, make vimball, updating manually (because I place that
            plugin in $VIM/vimfiles, not ~/.vim), removing the BOM from the helpfile
            (I have 'bomb' on by default and :helptags doesn't like it), ":helptags
            $VIM/vimfiles/doc" and finally (very important) restarting Vim, the
            error has disappeared: I get just "Character ' ' U+3102 not found" in
            magenta on the message line (with a hollow box and subscript 3102
            starting between the quotes and extending rightwards over U+).

            *unicode.txt* A completion plugin for Unicode glyphs

            Author: Christian Brabandt <cb@...>
            Version: 0.17 Thu, 11 Apr 2013 14:17:13 +0200

            Best regards,
            Tony.
            --
            You can't judge a book by the way it wears its hair.

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Christian Brabandt
            Hi Tony! ... I believe, that is correct. There is no entry for U+3102 in UnicodeData.txt so the plugin can t display more information. regards, Christian -- Es
            Message 5 of 11 , Apr 11, 2013
              Hi Tony!

              On Do, 11 Apr 2013, Tony Mechelynck wrote:

              > restarting Vim, the error has disappeared: I get just "Character ' '
              > U+3102 not found" in magenta on the message line (with a hollow box
              > and subscript 3102 starting between the quotes and extending
              > rightwards over U+).

              I believe, that is correct. There is no entry for U+3102 in
              UnicodeData.txt so the plugin can't display more information.

              regards,
              Christian
              --
              Es sollten sich die leichenblassen Frauen das Haar nicht bleichen lassen.

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • Tony Mechelynck
              ... So do I. Thanks for the prompt reaction. Best regards, Tony. -- Hackers do it with bugs. -- -- You received this message from the vim_use maillist. Do
              Message 6 of 11 , Apr 11, 2013
                On 11/04/13 15:15, Christian Brabandt wrote:
                > Hi Tony!
                >
                > On Do, 11 Apr 2013, Tony Mechelynck wrote:
                >
                >> restarting Vim, the error has disappeared: I get just "Character ' '
                >> U+3102 not found" in magenta on the message line (with a hollow box
                >> and subscript 3102 starting between the quotes and extending
                >> rightwards over U+).
                >
                > I believe, that is correct. There is no entry for U+3102 in
                > UnicodeData.txt so the plugin can't display more information.
                >
                > regards,
                > Christian
                >
                So do I. Thanks for the prompt reaction.

                Best regards,
                Tony.
                --
                Hackers do it with bugs.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.