Loading ...
Sorry, an error occurred while loading the content.
 

Re: How to set up Outlook 2010 / Vim 7.3 to have OutlookVim with Unicode (UTF-8) support?

Expand Messages
  • aswna2010@...
    As I mentioned in the other thread [Re: UFT-8/16 help needed (How to set up Outlook 2010 / Vim 7.3 to have OutlookVim with Unicode (UTF-8) support?)], I have
    Message 1 of 6 , Apr 9 11:50 PM
      As I mentioned in the other thread [Re: UFT-8/16 help needed (How to set up Outlook 2010 / Vim 7.3 to have OutlookVim with Unicode (UTF-8) support?)], I have experimented some more with the plugin.

      The solution what works for me can be seen with the help of the following diff.

      diff -b original_OutlookVim.bas working_OutlookVim.bas
      201c201
      < unicode = False
      ---
      > 'unicode = False
      289c289
      < vimKeys = vimKeys & "utf-16"
      ---
      > vimKeys = vimKeys & "utf-16le"

      I am not sure how would you fix this, if at all.

      Now, it really produces the expected characters, the hexdump also confirms this.
      0000000 feff 0151 0171 000a
      0000008

      Thanks for your help,
      AndrĂ¡s

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.