Loading ...
Sorry, an error occurred while loading the content.
 

How to unmap all combinations that begin with ?

Expand Messages
  • Thiago Padilha
    I found these default mappings after typing :imap i [6~ i [5~ i OF i OH i
    Message 1 of 3 , Apr 8, 2013
      I found these default mappings after typing :imap

      i <Esc>[6~ <PageDown>
      i <Esc>[5~ <PageUp>
      i <Esc>OF <End>
      i <Esc>OH <Home>
      i <Esc>OD <Left>
      i <Esc>OC <Right>
      i <Esc>OB <Down>
      i <Esc>OA <Up>

      I want to get rid of all these mappings in my vimrc, so I can properly
      map key sequences that begin with escape without having vim wait to
      leav insert mode. I have tried to put the following in my vimrc:

      iunmap <Esc>[6~
      iunmap <Esc>[5~
      iunmap <Esc>OF
      iunmap <Esc>OH
      iunmap <Esc>OD
      iunmap <Esc>OC
      iunmap <Esc>OB
      iunmap <Esc>OA

      But it doesn't work and vim complains with messages of 'no such mappings'

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Gary Johnson
      ... If you didn t set those mappings in your ~/.vimrc, then they were probably set in a plugin. You can find out by executing ... If they were set in a
      Message 2 of 3 , Apr 8, 2013
        On 2013-04-08, Thiago Padilha wrote:
        > I found these default mappings after typing :imap
        >
        > i <Esc>[6~ <PageDown>
        > i <Esc>[5~ <PageUp>
        > i <Esc>OF <End>
        > i <Esc>OH <Home>
        > i <Esc>OD <Left>
        > i <Esc>OC <Right>
        > i <Esc>OB <Down>
        > i <Esc>OA <Up>
        >
        > I want to get rid of all these mappings in my vimrc, so I can properly
        > map key sequences that begin with escape without having vim wait to
        > leav insert mode. I have tried to put the following in my vimrc:
        >
        > iunmap <Esc>[6~
        > iunmap <Esc>[5~
        > iunmap <Esc>OF
        > iunmap <Esc>OH
        > iunmap <Esc>OD
        > iunmap <Esc>OC
        > iunmap <Esc>OB
        > iunmap <Esc>OA
        >
        > But it doesn't work and vim complains with messages of 'no such mappings'

        If you didn't set those mappings in your ~/.vimrc, then they were
        probably set in a plugin. You can find out by executing

        :verbose imap

        If they were set in a plugin, then they were set after your ~/.vimrc
        was read. Since the mappings were not defined when your iunmap
        commands were executed, there were 'no such mappings' to unmap.

        Assuming that that is the problem, then one solution would be
        to create a file named ~/.vim/after/plugin/<plugin> where <plugin>
        is the name of the plugin file in which those mappings are defined,
        and put your iunmap commands in that file.

        HTH,
        Gary

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Thiago Padilha
        Thank you so much, this was anoying me a lot. The plugin was vim-autoclose so I removed it and actually found a better alternative:
        Message 3 of 3 , Apr 8, 2013
          Thank you so much, this was anoying me a lot. The plugin was
          vim-autoclose so I removed it and actually found a better alternative:
          git://github.com/Raimondi/delimitMate.git



          On Mon, Apr 8, 2013 at 4:08 PM, Gary Johnson <garyjohn@...> wrote:
          > On 2013-04-08, Thiago Padilha wrote:
          >> I found these default mappings after typing :imap
          >>
          >> i <Esc>[6~ <PageDown>
          >> i <Esc>[5~ <PageUp>
          >> i <Esc>OF <End>
          >> i <Esc>OH <Home>
          >> i <Esc>OD <Left>
          >> i <Esc>OC <Right>
          >> i <Esc>OB <Down>
          >> i <Esc>OA <Up>
          >>
          >> I want to get rid of all these mappings in my vimrc, so I can properly
          >> map key sequences that begin with escape without having vim wait to
          >> leav insert mode. I have tried to put the following in my vimrc:
          >>
          >> iunmap <Esc>[6~
          >> iunmap <Esc>[5~
          >> iunmap <Esc>OF
          >> iunmap <Esc>OH
          >> iunmap <Esc>OD
          >> iunmap <Esc>OC
          >> iunmap <Esc>OB
          >> iunmap <Esc>OA
          >>
          >> But it doesn't work and vim complains with messages of 'no such mappings'
          >
          > If you didn't set those mappings in your ~/.vimrc, then they were
          > probably set in a plugin. You can find out by executing
          >
          > :verbose imap
          >
          > If they were set in a plugin, then they were set after your ~/.vimrc
          > was read. Since the mappings were not defined when your iunmap
          > commands were executed, there were 'no such mappings' to unmap.
          >
          > Assuming that that is the problem, then one solution would be
          > to create a file named ~/.vim/after/plugin/<plugin> where <plugin>
          > is the name of the plugin file in which those mappings are defined,
          > and put your iunmap commands in that file.
          >
          > HTH,
          > Gary
          >
          > --
          > --
          > You received this message from the "vim_use" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >
          > ---
          > You received this message because you are subscribed to the Google Groups "vim_use" group.
          > To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          > For more options, visit https://groups.google.com/groups/opt_out.
          >
          >

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.