Loading ...
Sorry, an error occurred while loading the content.

Update on inability to copy marked files, netrw 147j

Expand Messages
  • Paul
    My first attempt at this was last weekend, http://groups.google.com/group/vim_use/browse_frm/thread/61fc0c9f19333354. This weekend, I had a chance to install
    Message 1 of 3 , Apr 7, 2013
    • 0 Attachment
      My first attempt at this was last weekend,
      http://groups.google.com/group/vim_use/browse_frm/thread/61fc0c9f19333354.

      This weekend, I had a chance to install the gvim 7.3.829 today, then
      install
      netrw 147j into "c:/Program Files (x86)/vim/vimfiles". A strange
      behaviour of
      this version is that there are 2 parent directories ("../") shown.
      I'm not
      sure if that is relevant problem, and I simply proceeded with
      testing. This
      meant marking a target directory, marking some files, and issuing
      "mc". The
      files still did not get copied, but I got a message:

      **warning** (netrw) consider setting g:netrw_localcopycmd<cmd /c copy>
      to something that works

      Now, cmd and copy both are valid, recognized commands in Windows 7
      when issued from the Start button. I also found a related thread at
      http://www.mail-archive.com/vim_dev@.../msg16959.html.
      So I checked that &g:shell='C:\windows\system32\cmd.exe' and confirmed
      that the full path does launch a Windows command shell when issued
      from the Start button. I also confirmed that, regardless of whether I
      started a shell using 'cmd' or 'C:\windows\system32\cmd.exe', both
      accept and execute commands in the form 'cmd /c blah' (I used 'dir'
      for 'blah').

      However, I also tried modifying g:netrw_localcopycmd from 'cmd /c
      copy' to just 'copy'. I got this idea from the fact that
      g:netrw_localcopycmd='cp' in the cygwin X11 gvim; that is, there were
      no prefix words that explicitly specify the shell. When I tried this
      on the Windows gvim, I got the error message:

      **error** (netrw) g:netrw_localcopycmd<copy> not executable on your
      system, aborting

      Thanks for any further suggestions or confirmation of this behaviour.

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Charles E Campbell
      ... Try putting the full path into your g:netrw_localcopycmd; presumably, that would be let g:netrw_localcopycmd= c: windows system32 cmd /c copy I ve been
      Message 2 of 3 , Apr 8, 2013
      • 0 Attachment
        Paul wrote:
        > My first attempt at this was last weekend,
        > http://groups.google.com/group/vim_use/browse_frm/thread/61fc0c9f19333354.
        >
        > This weekend, I had a chance to install the gvim 7.3.829 today, then
        > install
        > netrw 147j into "c:/Program Files (x86)/vim/vimfiles". A strange
        > behaviour of
        > this version is that there are 2 parent directories ("../") shown.
        > I'm not
        > sure if that is relevant problem, and I simply proceeded with
        > testing. This
        > meant marking a target directory, marking some files, and issuing
        > "mc". The
        > files still did not get copied, but I got a message:
        >
        > **warning** (netrw) consider setting g:netrw_localcopycmd<cmd /c copy>
        > to something that works
        >
        > Now, cmd and copy both are valid, recognized commands in Windows 7
        > when issued from the Start button. I also found a related thread at
        > http://www.mail-archive.com/vim_dev@.../msg16959.html.
        > So I checked that &g:shell='C:\windows\system32\cmd.exe' and confirmed
        > that the full path does launch a Windows command shell when issued
        > from the Start button. I also confirmed that, regardless of whether I
        > started a shell using 'cmd' or 'C:\windows\system32\cmd.exe', both
        > accept and execute commands in the form 'cmd /c blah' (I used 'dir'
        > for 'blah').
        >
        > However, I also tried modifying g:netrw_localcopycmd from 'cmd /c
        > copy' to just 'copy'. I got this idea from the fact that
        > g:netrw_localcopycmd='cp' in the cygwin X11 gvim; that is, there were
        > no prefix words that explicitly specify the shell. When I tried this
        > on the Windows gvim, I got the error message:
        >
        > **error** (netrw) g:netrw_localcopycmd<copy> not executable on your
        > system, aborting
        >
        > Thanks for any further suggestions or confirmation of this behaviour.
        >
        Try putting the full path into your g:netrw_localcopycmd; presumably,
        that would be

        let g:netrw_localcopycmd= 'c:\windows\system32\cmd /c copy'

        I've been using Vista with just 'cmd /c copy' and that's worked for me,
        though.

        Regards,
        C Campbell

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Paul
        On Apr 8, 9:56 am, Charles E Campbell ... Just tried it. I get: **error** (netrw) g:netrw_localcopycmd
        Message 3 of 3 , Apr 8, 2013
        • 0 Attachment
          On Apr 8, 9:56 am, Charles E Campbell <drc...@...>
          wrote:
          > Try putting the full path into your g:netrw_localcopycmd;
          > presumably, that would be
          >
          > let g:netrw_localcopycmd= 'c:\windows\system32\cmd /c copy'
          >
          > I've been using Vista with just 'cmd /c copy' and that's worked for
          > me, though.

          Just tried it. I get:

          **error** (netrw) g:netrw_localcopycmd<c:\windows\system32\cmd /c
          copy> not executable on your system, aborting

          From a DOS shell, I confirmed that the following works:

          c:\windows\system32\cmd /c "copy someFile someDir"

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.