Loading ...
Sorry, an error occurred while loading the content.

Re: correctly setting terminal in SunOS for vim

Expand Messages
  • skeept
    For anyone interested the way I solved this was the following: I noticed that the linking step when compiling was done with: cc -o screen screen.o ansi.o
    Message 1 of 4 , Apr 3, 2013
    • 0 Attachment
      For anyone interested the way I solved this was the following:

      I noticed that the linking step when compiling was done with:

      cc -o screen screen.o ansi.o fileio.o mark.o misc.o resize.o socket.o search.o tty.o term.o window.o utmp.o loadav.o putenv.o help.o termcap.o input.o attacher.o pty.o process.o display.o comm.o kmapdef.o acls.o braille.o braille_tsi.o logfile.o layer.o sched.o teln.o nethack.o encoding.o -lcurses -lelf -lsocket -lnsl -lkstat -lcrypt

      I simply replaced -lcurses by -lncurses and now I have nice colors in vim :)

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    Your message has been successfully submitted and would be delivered to recipients shortly.