Loading ...
Sorry, an error occurred while loading the content.

Re: Setting the TEXINPUTS and BIBINPUTS varibles for latex inside vim/gVim

Expand Messages
  • Christoph Wiesmeyr
    ... Setting the variables in ~/.profile solved the problem for me, now everything works like a charm. Thank you very much for your detailed explanation, I
    Message 1 of 13 , Apr 3, 2013
    • 0 Attachment
      > Despite what you read on the web, ~/.bashrc is not the right place
      >
      > to set environment variables. For one thing, they won't be
      >
      > available to programs launched from Vim with ":!command". For
      >
      > another, they won't be available to programs started from your
      >
      > window manager, as gvim often is.
      >
      >
      >
      > Where you _should_ put environment variables is changing. In the
      >
      > beginning, personal environment variables were set in ~/.profile.
      >
      > Period. Then bash came along and offered ~/.bash_profile as an
      >
      > alternative. Now I understand that Ubuntu recommends putting them
      >
      > in ~/.environment. I believe that other desktop environments have
      >
      > their own pet places. For the time being, however, I think that
      >
      > ~/.profile or ~/.bash_profile will still be sourced when you log in
      >
      > and before your window manager is launched, which is when you want
      >
      > them set so that they are available to programs such as gvim.
      >

      Setting the variables in ~/.profile solved the problem for me, now everything works like a charm. Thank you very much for your detailed explanation, I really appreciate this.



      Best regards,
      Christoph

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Jaime A Millan Quijano
      I apologise if my question seems a bit naive, but what do you mean by setting the variables in ~/.profile . When I open my .profile I only see the following
      Message 2 of 13 , Mar 25
      • 0 Attachment
        I apologise if my question seems a bit naive, but what do you mean by "setting the variables in ~/.profile".

        When I open my .profile I only see the following line "export PATH="/opt/local/bin:/opt/local/sbin:$PATH""

        Do I just add the line and save?
        let g:Tex_TEXINPUTS = '/usr/local ..."

        Thanks a lot
        J

        On Wednesday, April 3, 2013 at 9:39:09 PM UTC+2, Christoph Wiesmeyr wrote:
        > > Despite what you read on the web, ~/.bashrc is not the right place
        > >
        > > to set environment variables. For one thing, they won't be
        > >
        > > available to programs launched from Vim with ":!command". For
        > >
        > > another, they won't be available to programs started from your
        > >
        > > window manager, as gvim often is.
        > >
        > >
        > >
        > > Where you _should_ put environment variables is changing. In the
        > >
        > > beginning, personal environment variables were set in ~/.profile.
        > >
        > > Period. Then bash came along and offered ~/.bash_profile as an
        > >
        > > alternative. Now I understand that Ubuntu recommends putting them
        > >
        > > in ~/.environment. I believe that other desktop environments have
        > >
        > > their own pet places. For the time being, however, I think that
        > >
        > > ~/.profile or ~/.bash_profile will still be sourced when you log in
        > >
        > > and before your window manager is launched, which is when you want
        > >
        > > them set so that they are available to programs such as gvim.
        > >
        >
        > Setting the variables in ~/.profile solved the problem for me, now everything works like a charm. Thank you very much for your detailed explanation, I really appreciate this.
        >
        >
        >
        > Best regards,
        > Christoph

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/d/optout.
      • Christian Brabandt
        Hi Jaime! ... .profile is for your shell environment. You need to put vim specific configuration into ~/.vimrc Best Christian -- Ironie ist der Weg und Übung
        Message 3 of 13 , Mar 25
        • 0 Attachment
          Hi Jaime!

          On Mi, 25 Mär 2015, Jaime A Millan Quijano wrote:

          > I apologise if my question seems a bit naive, but what do you mean by "setting the variables in ~/.profile".
          >
          > When I open my .profile I only see the following line "export PATH="/opt/local/bin:/opt/local/sbin:$PATH""
          >
          > Do I just add the line and save?
          > let g:Tex_TEXINPUTS = '/usr/local ..."
          >
          > Thanks a lot

          .profile is for your shell environment. You need to put vim specific
          configuration into ~/.vimrc

          Best
          Christian
          --
          Ironie ist der Weg und Übung zur Laune.
          -- Jean Paul

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/d/optout.
        • Jaime A Millan Quijano
          ... Hi Christian, thanks for your reply I wrote the following line on my .vimrc let g:Tex_TEXINPUTS = /usr/local/texlive/2014/texmf-dist/tex/**,./** But I
          Message 4 of 13 , Mar 26
          • 0 Attachment
            On Wednesday, March 25, 2015 at 9:40:35 PM UTC+1, Christian Brabandt wrote:
            > Hi Jaime!
            >
            > On Mi, 25 Mär 2015, Jaime A Millan Quijano wrote:
            >
            > > I apologise if my question seems a bit naive, but what do you mean by "setting the variables in ~/.profile".
            > >
            > > When I open my .profile I only see the following line "export PATH="/opt/local/bin:/opt/local/sbin:$PATH""
            > >
            > > Do I just add the line and save?
            > > let g:Tex_TEXINPUTS = '/usr/local ..."
            > >
            > > Thanks a lot
            >
            > .profile is for your shell environment. You need to put vim specific
            > configuration into ~/.vimrc
            >
            > Best
            > Christian
            > --
            > Ironie ist der Weg und Übung zur Laune.
            > -- Jean Paul

            Hi Christian, thanks for your reply

            I wrote the following line on my .vimrc
            let g:Tex_TEXINPUTS = '/usr/local/texlive/2014/texmf-dist/tex/**,./**'

            But I still get the same mistake:
            ! LaTeX Error: File `url.sty' not found.

            I know that the package url is in the folder above.
            Any help would be very welcome.
            Thanks a lot in advance,
            J

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/d/optout.
          Your message has been successfully submitted and would be delivered to recipients shortly.