Loading ...
Sorry, an error occurred while loading the content.

correctly setting terminal in SunOS for vim

Expand Messages
  • skeept
    I am trying to use vim in a computer sunos computer uname -a: SunOS cmc01 5.10 Generic_142910-17 i86pc i386 i86pc At this point I was able to compile ncurses,
    Message 1 of 4 , Apr 2, 2013
    • 0 Attachment
      I am trying to use vim in a computer sunos computer
      uname -a:
      SunOS cmc01 5.10 Generic_142910-17 i86pc i386 i86pc

      At this point I was able to compile ncurses, screen and vim.
      I can only login to the machine from the work laptop.

      If ssh into the machine and use vim with the vim setting t_Co=256 then the colors
      are good.

      If when on the machine I start screen then after starting vim I cannot see anything. If unset t_Co in my .vimrc then I can see but with no colors.
      I also set the variable
      export TERMINFO=~/scratch/packages2/lib/terminfo
      (I have the packages installed under scratch/packages2/).

      I understand that this is not a vim problem since as I mentioned I can use nice colors if I am not inside screen, but I really like to use it with conjunction with screen.
      If someone has any ideas on how to fix that please let me know.

      Regards,
      Jorge

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Thomas E. Dickey
      ... bash works for the ~ expansion - but it depends on the shell whether that works. Also, it s possible that screen is linked to the legacy termcap library
      Message 2 of 4 , Apr 3, 2013
      • 0 Attachment
        On Wednesday, April 3, 2013 12:51:57 AM UTC-4, skeept wrote:
        > I am trying to use vim in a computer sunos computer
        > uname -a:
        > SunOS cmc01 5.10 Generic_142910-17 i86pc i386 i86pc
        >
        > At this point I was able to compile ncurses, screen and vim.
        > I can only login to the machine from the work laptop.
        >
        > If ssh into the machine and use vim with the vim setting t_Co=256 then the colors
        > are good.
        >
        > If when on the machine I start screen then after starting vim I cannot see anything. If unset t_Co in my .vimrc then I can see but with no colors.
        > I also set the variable
        > export TERMINFO=~/scratch/packages2/lib/terminfo
        > (I have the packages installed under scratch/packages2/).
        >
        > I understand that this is not a vim problem since as I mentioned I can use nice colors if I am not inside screen, but I really like to use it with conjunction with screen.
        > If someone has any ideas on how to fix that please let me know.

        bash works for the "~" expansion - but it depends on the shell whether that works.

        Also, it's possible that screen is linked to the legacy termcap library on
        Solaris rather than /usr/lib/termcap (which sym-links to libcurses). You
        can check that using ldd. If it's linked to the legacy termcap library,
        you can't use TERMINFO to fix it.

        In screen (unless you have overridden TERM), env will show the TERMCAP
        variable, which gives screen's notion of whatever (termcap or terminfo)
        it is using.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • skeept
        ... Thanks for the info. ldd screen shows libcurses.so.1 = /lib/libcurses.so.1 also each new screen session I start has the TERMCAP variable defined to
        Message 3 of 4 , Apr 3, 2013
        • 0 Attachment
          >
          > Also, it's possible that screen is linked to the legacy termcap library on
          > Solaris rather than /usr/lib/termcap (which sym-links to libcurses). You
          > can check that using ldd. If it's linked to the legacy termcap library,
          > you can't use TERMINFO to fix it.
          >

          Thanks for the info.

          ldd screen shows
          libcurses.so.1 => /lib/libcurses.so.1

          also each new screen session I start has the TERMCAP variable defined to
          TERMCAP=SC|vt100|VT 100/ANSI X3.64 virtual terminal:\
          :hs:ts=\E_:fs=\E\\:ds=\E_\E\\:\
          :DO=\E[%dB:LE=\E[%dD:RI=\E[%dC:UP=\E[%dA:bs:bt=\E[Z:\
          :cd=\E[J:ce=\E[K:cl=\E[H\E[J:cm=\E[%i%d;%dH:ct=\E[3g:\
          :do=^J:nd=\E[C:pt:rc=\E8:rs=\Ec:sc=\E7:st=\EH:up=\EM:\
          :le=^H:bl=^G:cr=^M:it#8:ho=\E[H:nw=\EE:ta=^I:is=\E)0:\
          :li#73:co#80:am:xn:xv:LP:sr=\EM:al=\E[L:AL=\E[%dL:\
          :cs=\E[%i%d;%dr:dl=\E[M:DL=\E[%dM:dc=\E[P:DC=\E[%dP:\
          :im=\E[4h:ei=\E[4l:mi:IC=\E[%d@:ks=\E[?1h\E=:\
          :ke=\E[?1l\E>:vi=\E[?25l:ve=\E[34h\E[?25h:vs=\E[34l:\
          :ti=\E[?1049h:te=\E[?1049l:us=\E[4m:ue=\E[24m:so=\E[3m:\
          :se=\E[23m:mb=\E[5m:md=\E[1m:mr=\E[7m:me=\E[m:ms:\
          :Co#8:pa#64:AF=\E[3%dm:AB=\E[4%dm:op=\E[39;49m:AX:G0:\
          :as=\E(0:ae=\E(B:\
          :ac=\140\140aaffggjjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~..--++,,hhII00:\
          :Z0=\E[?3h:Z1=\E[?3l:k0=\E[10~:k1=\EOP:k2=\EOQ:k3=\EOR:\
          :k4=\EOS:k5=\E[15~:k6=\E[17~:k7=\E[18~:k8=\E[19~:\
          :k9=\E[20~:k;=\E[21~:F2=\E[24~:kb=^H:K1=\EOq:K2=\EOr:\
          :K3=\EOs:K4=\EOp:K5=\EOn:kh=\E[1~:@1=\E[1~:kH=\E[4~:\
          :@7=\E[4~:kN=\E[6~:kP=\E[5~:kI=\E[2~:kD=\E[3~:ku=\EOA:\
          :kd=\EOB:kr=\EOC:kl=\EOD:km:


          based on this any suggestions on how I can configure it correctly or how I can tell it to give me better capabilities?

          Thanks!

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • skeept
          For anyone interested the way I solved this was the following: I noticed that the linking step when compiling was done with: cc -o screen screen.o ansi.o
          Message 4 of 4 , Apr 3, 2013
          • 0 Attachment
            For anyone interested the way I solved this was the following:

            I noticed that the linking step when compiling was done with:

            cc -o screen screen.o ansi.o fileio.o mark.o misc.o resize.o socket.o search.o tty.o term.o window.o utmp.o loadav.o putenv.o help.o termcap.o input.o attacher.o pty.o process.o display.o comm.o kmapdef.o acls.o braille.o braille_tsi.o logfile.o layer.o sched.o teln.o nethack.o encoding.o -lcurses -lelf -lsocket -lnsl -lkstat -lcrypt

            I simply replaced -lcurses by -lncurses and now I have nice colors in vim :)

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          Your message has been successfully submitted and would be delivered to recipients shortly.