Loading ...
Sorry, an error occurred while loading the content.

Re: Get netrw to ignore executability of file

Expand Messages
  • Christian Brabandt
    Hi Tony! ... On windows, there is no executable bit and is actually not needed, because only certain file types are executable. So in principle is should be
    Message 1 of 9 , Mar 31, 2013
    • 0 Attachment
      Hi Tony!

      On Sa, 30 Mär 2013, Tony Mechelynck wrote:

      > On 30/03/13 20:46, AndyHancock wrote:
      > >For netrw 140, one of the differences between the Windows gvim and
      > >Cygwin/X11 gvim is that the Cygwin/X11 version will show the
      > >executable files with "highlight netrwExe" which is linked to
      > >"highlight Preproc". This does not happen with the Windows version,
      > >even netrwExe is also linked to PreProc. I assume that it is because
      > >the executability of each file is not conveyed to gvim and/or netrw,
      > >or because it is not *properly* conveyed.
      > >
      > >I actually prefer the behaviour without special highlighting of
      > >executable files because in Windows, files seem to be marked
      > >executable in a random manner (at least as viewed using "ls -l" in
      > >Cygwin's bash). So the highlighting is random and is the source of
      > >cognitive noise. Furthermore, even if that was not the case, I rarely
      > >make use of the information about a file's executability. True binary
      > >executables are always collected away in their own directories and are
      > >rarely mixed with other file types, so there is no need to highlight
      > >them and distinguigh them from brethren files. As well, for my
      > >purposes, the notion of executables have blurred e.g. vim files,
      > >matlab files, bash files, perl file, etc.. Particularly in Windows,
      > >it doesn't matter much whether one launches an app by double-clicking
      > >on the binary executable or by double-clicking a file with an
      > >extension that invokes a particular app.
      > >
      > >I tried to get rid of netrwExe highlighting by linking it to Normal.
      > >This was OK, but the asterisk that immediately follows the filename to
      > >indicate executability still there, and is definitely not Normal. It
      > >is still loudly pronouncing itself in netrwExe highlighting. Is there
      > >a way to get rid of the distinction of executability all together?
      > >
      >
      > FAT filesystems have no built-in executable bit. I'm less sure about
      > NTFS filesystems. OTOH POSIX-compatible filesystems typically have

      On windows, there is no executable bit and is actually not needed,
      because only certain file types are executable.
      So in principle is should be possible to simply highlight .exe .bat .cmd
      .com files as executable on Windows.

      regards,
      Christian
      --
      Frage an Radio Eriwan: "Stimmt es, daß in den USA jeder ein Auto hat?"
      Antwort: "Im Prinzip ja, aber bei uns hat dafür jeder einen Parkplatz."

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • AndyHancock
      ... Hi, Christian, I would say that you re right in principle. However, cygwin seems to use a different scheme to determine whether the executable bit is set.
      Message 2 of 9 , Mar 31, 2013
      • 0 Attachment
        On Mar 31, 6:46 am, Christian Brabandt wrote:
        > On windows, there is no executable bit and is actually not needed,
        > because only certain file types are executable. So in principle is
        > should be possible to simply highlight .exe .bat .cmd .com files as
        > executable on Windows.

        Hi, Christian,

        I would say that you're right in principle. However, cygwin seems to
        use a different scheme to determine whether the executable bit is
        set. I haven't yet figured out exactly what the scheme is.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Charles Campbell
        ... However, under cygwin, under windows, plus NTFS, there is an executable bit and it does affect whether cygwin may try to execute that file or not
        Message 3 of 9 , Apr 1, 2013
        • 0 Attachment
          Christian Brabandt wrote:
          > On windows, there is no executable bit and is actually not needed,
          > because only certain file types are executable. So in principle is
          > should be possible to simply highlight .exe .bat .cmd .com files as
          > executable on Windows. regards, Christian
          However, under cygwin, under windows, plus NTFS, there is an executable
          bit and it does affect whether cygwin may try to execute that file or
          not (especially scripts). There's also ACLs, which may also cause files
          to be considered executable. Again, see (using cygwin)\:

          man getfacl
          man setfacl

          Regards,
          C Campbell

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.