Loading ...
Sorry, an error occurred while loading the content.

Re: "hi netrwCopyTgt" doesn't bold netrw's target directory for copy

Expand Messages
  • Tony Mechelynck
    ... There was a spurious linebreak in the email. nextgroup=netrwList should either have been at the end of the previous :syn match line, or else have a
    Message 1 of 6 , Mar 31, 2013
    • 0 Attachment
      On 31/03/13 09:16, AndyHancock wrote:
      > On Mar 30, 7:20 pm, Charles E Campbell wrote:
      >> AndyHancock wrote:
      >>> I am trying to get my netrw marked files to show up as yellow, and
      >>> the target directory for copying marked files to show up as bolded
      >>> cyan. In my vimrc, I have:
      >>>
      >>> syntax on
      >>> color mine
      >>>
      >>> I deliberately stuck "syntax on" as a precaution because the
      >>> highlight groups netrwMarkFile and netrwCopyTgt don't exist without
      >>> "syntax on". Without it, the "color mine" seems to have no effect
      >>> in netrw.
      >>> [snip]
      >>> The Cyan for Directory works. The yellow for netrwMarkFile works.
      >>> But the netrwCopyTgt doesn't work (neither bold nor yellow)
      >>
      >> The netrwCopyTgt syntax is transparent. You need to get rid of that
      >> modifier. So, put in your .vim/after/syntax/netrw.vim file:
      >>
      >> syn clear netrwCopyTgt
      >> syn match netrwCopyTgt "Copy/Move Tgt:" contained skipwhite
      >> nextgroup=netrwList
      >> hi link netrwCopyTgt Unique
      >>
      >> where Unique is whatever color you want (or, instead of hi link ...,
      >> use hi and fg= bg= etc specifications).
      >
      > Hi Charles,
      >
      > I put the lines into cygwin's /usr/share/vim/vimfiles/after/syntax/
      > netrw.vim. In place of "hi link netrwCopyTgt Unique", I put
      >
      > hi netrwCopyTgt term=bold cterm=11 gui=bold guifg=yellow
      >
      > When I editted a directory path and netrw is invoked, I pressed "a" to
      > cycle through the hiding list modes until nothing was hidden. I got
      > the error:
      >
      > Error detected while processing
      > /usr/share/vim/vimfiles/after/syntax/netrw.vim:
      > line 5:
      > E492: Not an editor command: nextgroup=netrwList
      >
      > I then commented that line out. The effect of netrw's "mt" was to
      > highlight the words "Copy/Move Tgt:" in the header. The target file
      > itself was not highlighted. Is that what the commented line should
      > have done?
      >

      There was a spurious linebreak in the email. "nextgroup=netrwList"
      should either have been at the end of the previous :syn match line, or
      else have a backslash at the start to mark it as a continuation line.

      Best regards,
      Tony.
      --
      ... the privileged being which we call human is distinguished from
      other animals only by certain double-edged manifestations which in
      charity we can only call "inhuman."
      -- R. A. Lafferty

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • AndyHancock
      ... Thanks Tony. Appending nextgroup=netrwList to the end of syn match netrwCopyTgt Copy/Move Tgt: contained skipwhite eliminates the error message, but the
      Message 2 of 6 , Mar 31, 2013
      • 0 Attachment
        On Mar 31, 3:32 am, Tony Mechelynck wrote:
        >On 31/03/13 09:16, AndyHancock wrote:
        >>On Mar 30, 7:20 pm, Charles E Campbell wrote:
        >>>AndyHancock wrote:
        >>>> I am trying to get my netrw marked files to show up as yellow,
        >>>> and the target directory for copying marked files to show up as
        >>>> bolded
        >>>> <...snip...>
        >>> The netrwCopyTgt syntax is transparent. You need to get rid of
        >>> that modifier. So, put in your .vim/after/syntax/netrw.vim file:
        >>>
        >>> syn clear netrwCopyTgt
        >>> syn match netrwCopyTgt "Copy/Move Tgt:" contained skipwhite
        >>> nextgroup=netrwList
        >>> hi link netrwCopyTgt Unique
        >>>
        >>> where Unique is whatever color you want (or, instead of hi link
        >>> ..., use hi and fg= bg= etc specifications).
        >>
        >> I put the lines into cygwin's /usr/share/vim/vimfiles/after/syntax/
        >> netrw.vim. In place of "hi link netrwCopyTgt Unique", I put
        >>
        >> hi netrwCopyTgt term=bold cterm=11 gui=bold guifg=yellow
        >>
        >> When I editted a directory path and netrw is invoked, I pressed "a"
        >> to cycle through the hiding list modes until nothing was hidden. I
        >> got the error:
        >>
        >> Error detected while processing
        >> /usr/share/vim/vimfiles/after/syntax/netrw.vim:
        >> line 5:
        >> E492: Not an editor command: nextgroup=netrwList
        >>
        >> I then commented that line out. The effect of netrw's "mt" was to
        >> highlight the words "Copy/Move Tgt:" in the header. The target
        >> file itself was not highlighted. Is that what the commented line
        >> should have done?
        >
        > There was a spurious linebreak in the email. "nextgroup=netrwList"
        > should either have been at the end of the previous :syn match line,
        > or else have a backslash at the start to mark it as a continuation
        > line.

        Thanks Tony. Appending

        nextgroup=netrwList

        to the end of

        syn match netrwCopyTgt "Copy/Move Tgt:" contained skipwhite

        eliminates the error message, but the text that is highlighted by

        hi netrwCopyTgt term=bold cterm=11 gui=bold guifg=yellow

        is still only the text "Copy/Move Tgt:" in the header region of the
        netrw window. The occurance of the directory name itself in the file
        listing part of the netrw window is not highlighted.

        This is better than it was before, though. Thanks again, Tony,
        Charles.

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.