Loading ...
Sorry, an error occurred while loading the content.

"hi netrwCopyTgt" doesn't bold netrw's target directory for copy

Expand Messages
  • AndyHancock
    I am trying to get my netrw marked files to show up as yellow, and the target directory for copying marked files to show up as bolded cyan. In my vimrc, I
    Message 1 of 6 , Mar 30 1:33 AM
    • 0 Attachment
      I am trying to get my netrw marked files to show up as yellow, and the
      target directory for copying marked files to show up as bolded cyan.
      In my vimrc, I have:

      syntax on
      color mine

      I deliberately stuck "syntax on" as a precaution because the highlight
      groups netrwMarkFile and netrwCopyTgt don't exist without "syntax
      on". Without it, the "color mine" seems to have no effect in netrw.

      I issued :highlight and extracted the following relevant lines. I
      also indicate the lines that result from my color scheme.

      " Default:
      "----------
      Directory term=bold ctermfg=11 guifg=Cyan

      netrwDir links to Directory


      " My color scheme:
      " The #80FFFF is very similar to Cyan if not the same
      "-----------------------------------------------------
      Identifier term=underline cterm=bold ctermfg=7 guifg=#80FFFF

      netrwCopyTgt term=bold ctermfg=11 gui=bold guifg=yellow
      " This is "cleared" by default.
      " Use yellow as a test.
      " Will change to Cyan once I get bold working.

      netrwMarkFile term=underline cterm=bold ctermfg=7 guifg=yellow

      I included Identifier because the default is for netrwMarkFile to link
      to Identifier.

      I do not have a gvimrc.

      The Cyan for Directory works. The yellow for netrwMarkFile works.
      But the netrwCopyTgt doesn't work (neither bold nor yellow)

      The scheme doesn't *appear* to be all that complicated, but I'm not
      all that familiar with the inner workings of syntax and color
      schemes. Can anyone suggest a way to make it work, or identify what
      is preventing it from working?

      --
      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_use" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • AndyHancock
      In case it wasn t obvious (and it might not be), the following post was with regards gvim, not vim. The same behaviour is observed on the Windows binary as
      Message 2 of 6 , Mar 30 12:22 PM
      • 0 Attachment
        In case it wasn't obvious (and it might not be), the following post
        was with regards gvim, not vim. The same behaviour is observed on the
        Windows binary as well as the cygwin/X-windows version. The netrw
        version is 140. I add gvim :ver information at the bottom.

        ---------- Original message ----------
        Date: Mar 30, 4:33 am

        I am trying to get my netrw marked files to show up as yellow, and the
        target directory for copying marked files to show up as bolded cyan.
        In my vimrc, I have:

        syntax on
        color mine

        I deliberately stuck "syntax on" as a precaution because the highlight
        groups netrwMarkFile and netrwCopyTgt don't exist without "syntax
        on". Without it, the "color mine" seems to have no effect in netrw.

        I issued :highlight and extracted the following relevant lines. I
        also indicate the lines that result from my color scheme.

        " Default:
        "----------
        Directory term=bold ctermfg=11 guifg=Cyan

        netrwDir links to Directory

        " My color scheme:
        " The #80FFFF is very similar to Cyan if not the same
        "-----------------------------------------------------
        Identifier term=underline cterm=bold ctermfg=7 guifg=#80FFFF

        netrwCopyTgt term=bold ctermfg=11 gui=bold guifg=yellow
        " This is "cleared" by default.
        " Use yellow as a test.
        " Will change to Cyan once I get bold working.

        netrwMarkFile term=underline cterm=bold ctermfg=7 guifg=yellow

        I included Identifier because the default is for netrwMarkFile to link
        to Identifier.

        I do not have a gvimrc.

        The Cyan for Directory works. The yellow for netrwMarkFile works.
        But the netrwCopyTgt doesn't work (neither bold nor yellow)

        The scheme doesn't *appear* to be all that complicated, but I'm not
        all that familiar with the inner workings of syntax and color
        schemes. Can anyone suggest a way to make it work, or identify what
        is preventing it from working?

        ---------- End original message ----------

        The :ver info is:

        VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Oct 27 2010 17:59:02)
        MS-Windows 32-bit GUI version with OLE support
        Included patches: 1-46
        Compiled by Bram@KIBAALE
        Big version with GUI. Features included (+) or not (-):
        +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset
        +cindent
        +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
        +comments
        +conceal +cryptv +cscope +cursorbind +cursorshape +dialog_con_gui
        +diff
        +digraphs -dnd -ebcdic +emacs_tags +eval +ex_extra +extra_search
        +farsi
        +file_in_path +find_in_path +float +folding -footer +gettext/dyn -
        hangul_input
        +iconv/dyn +insert_expand +jumplist +keymap +langmap +libcall
        +linebreak
        +lispindent +listcmds +localmap -lua +menu +mksession +modify_fname
        +mouse
        +mouseshape +multi_byte_ime/dyn +multi_lang -mzscheme +netbeans_intg
        +ole
        -osfiletype +path_extra +perl/dyn +persistent_undo -postscript
        +printer
        -profile +python/dyn +python3/dyn +quickfix +reltime +rightleft +ruby/
        dyn
        +scrollbind +signs +smartindent -sniff +startuptime +statusline -
        sun_workshop
        +syntax +tag_binary +tag_old_static -tag_any_white +tcl/dyn -tgetent
        -termresponse +textobjects +title +toolbar +user_commands +vertsplit
        +virtualedit +visual +visualextra +viminfo +vreplace +wildignore
        +wildmenu
        +windows +writebackup -xfontset -xim -xterm_save +xpm_w32
        system vimrc file: "$VIM\vimrc"
        user vimrc file: "$HOME\_vimrc"
        2nd user vimrc file: "$VIM\_vimrc"
        user exrc file: "$HOME\_exrc"
        2nd user exrc file: "$VIM\_exrc"
        system gvimrc file: "$VIM\gvimrc"
        user gvimrc file: "$HOME\_gvimrc"
        2nd user gvimrc file: "$VIM\_gvimrc"
        system menu file: "$VIMRUNTIME\menu.vim"
        Compilation: cl -c /W3 /nologo -I. -Iproto -DHAVE_PATHDEF -DWIN32 -
        DFEAT_CSCOPE -DFEAT_NETBEANS_INTG -DFEAT_XPM_W32 -DWINVER=0x0400 -
        D_WIN32_WINNT=0x0400 /Fo.\ObjGOLYHTR/ /Ox /GL -DNDEBUG /Zl /MT -
        DFEAT_OLE -DFEAT_MBYTE_IME -DDYNAMIC_IME -DFEAT_GUI_W32 -
        DDYNAMIC_ICONV -DDYNAMIC_GETTEXT -DFEAT_TCL -DDYNAMIC_TCL -
        DDYNAMIC_TCL_DLL=\"tcl83.dll\" -DDYNAMIC_TCL_VER=\"8.3\" -DFEAT_PYTHON
        -DDYNAMIC_PYTHON -DDYNAMIC_PYTHON_DLL=\"python27.dll\" -DFEAT_PYTHON3 -
        DDYNAMIC_PYTHON3 -DDYNAMIC_PYTHON3_DLL=\"python31.dll\" -DFEAT_PERL -
        DDYNAMIC_PERL -DDYNAMIC_PERL_DLL=\"perl512.dll\" -DFEAT_RUBY -
        DDYNAMIC_RUBY -DDYNAMIC_RUBY_VER=191 -DDYNAMIC_RUBY_DLL=\"msvcrt-
        ruby191.dll\" -DFEAT_BIG /Fd.\ObjGOLYHTR/ /Zi
        Linking: link /RELEASE /nologo /subsystem:windows /LTCG:STATUS
        oldnames.lib kernel32.lib advapi32.lib shell32.lib gdi32.lib
        comdlg32.lib ole32.lib uuid.lib /machine:i386 /nodefaultlib gdi32.lib
        version.lib winspool.lib comctl32.lib advapi32.lib shell32.lib /
        machine:i386 /nodefaultlib libcmt.lib oleaut32.lib user32.lib /
        nodefaultlib:python27.lib /nodefaultlib:python31.lib e:\tcl\lib
        \tclstub83.lib WSock32.lib e:\xpm\lib\libXpm.lib /PDB:gvim.pdb -debug

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • Charles E Campbell
        ... [snip] The netrwCopyTgt syntax is transparent. You need to get rid of that modifier. So, put in your .vim/after/syntax/netrw.vim file: syn clear
        Message 3 of 6 , Mar 30 4:20 PM
        • 0 Attachment
          AndyHancock wrote:
          > I am trying to get my netrw marked files to show up as yellow, and the
          > target directory for copying marked files to show up as bolded cyan.
          > In my vimrc, I have:
          >
          > syntax on
          > color mine
          >
          > I deliberately stuck "syntax on" as a precaution because the highlight
          > groups netrwMarkFile and netrwCopyTgt don't exist without "syntax
          > on". Without it, the "color mine" seems to have no effect in netrw.
          > [snip]
          > The Cyan for Directory works. The yellow for netrwMarkFile works.
          > But the netrwCopyTgt doesn't work (neither bold nor yellow)
          >
          [snip]

          The netrwCopyTgt syntax is transparent. You need to get rid of that
          modifier. So, put in your .vim/after/syntax/netrw.vim file:

          syn clear netrwCopyTgt
          syn match netrwCopyTgt "Copy/Move Tgt:" contained skipwhite
          nextgroup=netrwList
          hi link netrwCopyTgt Unique

          where Unique is whatever color you want (or, instead of hi link ..., use
          hi and fg= bg= etc specifications).

          C Campbell


          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        • AndyHancock
          ... Hi Charles, I put the lines into cygwin s /usr/share/vim/vimfiles/after/syntax/ netrw.vim. In place of hi link netrwCopyTgt Unique , I put hi
          Message 4 of 6 , Mar 31 12:16 AM
          • 0 Attachment
            On Mar 30, 7:20 pm, Charles E Campbell wrote:
            >AndyHancock wrote:
            >> I am trying to get my netrw marked files to show up as yellow, and
            >> the target directory for copying marked files to show up as bolded
            >> cyan. In my vimrc, I have:
            >>
            >> syntax on
            >> color mine
            >>
            >> I deliberately stuck "syntax on" as a precaution because the
            >> highlight groups netrwMarkFile and netrwCopyTgt don't exist without
            >> "syntax on". Without it, the "color mine" seems to have no effect
            >> in netrw.
            >> [snip]
            >> The Cyan for Directory works. The yellow for netrwMarkFile works.
            >> But the netrwCopyTgt doesn't work (neither bold nor yellow)
            >
            > The netrwCopyTgt syntax is transparent. You need to get rid of that
            > modifier. So, put in your .vim/after/syntax/netrw.vim file:
            >
            > syn clear netrwCopyTgt
            > syn match netrwCopyTgt "Copy/Move Tgt:" contained skipwhite
            > nextgroup=netrwList
            > hi link netrwCopyTgt Unique
            >
            > where Unique is whatever color you want (or, instead of hi link ...,
            > use hi and fg= bg= etc specifications).

            Hi Charles,

            I put the lines into cygwin's /usr/share/vim/vimfiles/after/syntax/
            netrw.vim. In place of "hi link netrwCopyTgt Unique", I put

            hi netrwCopyTgt term=bold cterm=11 gui=bold guifg=yellow

            When I editted a directory path and netrw is invoked, I pressed "a" to
            cycle through the hiding list modes until nothing was hidden. I got
            the error:

            Error detected while processing
            /usr/share/vim/vimfiles/after/syntax/netrw.vim:
            line 5:
            E492: Not an editor command: nextgroup=netrwList

            I then commented that line out. The effect of netrw's "mt" was to
            highlight the words "Copy/Move Tgt:" in the header. The target file
            itself was not highlighted. Is that what the commented line should
            have done?

            --
            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            ---
            You received this message because you are subscribed to the Google Groups "vim_use" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
            For more options, visit https://groups.google.com/groups/opt_out.
          • Tony Mechelynck
            ... There was a spurious linebreak in the email. nextgroup=netrwList should either have been at the end of the previous :syn match line, or else have a
            Message 5 of 6 , Mar 31 12:32 AM
            • 0 Attachment
              On 31/03/13 09:16, AndyHancock wrote:
              > On Mar 30, 7:20 pm, Charles E Campbell wrote:
              >> AndyHancock wrote:
              >>> I am trying to get my netrw marked files to show up as yellow, and
              >>> the target directory for copying marked files to show up as bolded
              >>> cyan. In my vimrc, I have:
              >>>
              >>> syntax on
              >>> color mine
              >>>
              >>> I deliberately stuck "syntax on" as a precaution because the
              >>> highlight groups netrwMarkFile and netrwCopyTgt don't exist without
              >>> "syntax on". Without it, the "color mine" seems to have no effect
              >>> in netrw.
              >>> [snip]
              >>> The Cyan for Directory works. The yellow for netrwMarkFile works.
              >>> But the netrwCopyTgt doesn't work (neither bold nor yellow)
              >>
              >> The netrwCopyTgt syntax is transparent. You need to get rid of that
              >> modifier. So, put in your .vim/after/syntax/netrw.vim file:
              >>
              >> syn clear netrwCopyTgt
              >> syn match netrwCopyTgt "Copy/Move Tgt:" contained skipwhite
              >> nextgroup=netrwList
              >> hi link netrwCopyTgt Unique
              >>
              >> where Unique is whatever color you want (or, instead of hi link ...,
              >> use hi and fg= bg= etc specifications).
              >
              > Hi Charles,
              >
              > I put the lines into cygwin's /usr/share/vim/vimfiles/after/syntax/
              > netrw.vim. In place of "hi link netrwCopyTgt Unique", I put
              >
              > hi netrwCopyTgt term=bold cterm=11 gui=bold guifg=yellow
              >
              > When I editted a directory path and netrw is invoked, I pressed "a" to
              > cycle through the hiding list modes until nothing was hidden. I got
              > the error:
              >
              > Error detected while processing
              > /usr/share/vim/vimfiles/after/syntax/netrw.vim:
              > line 5:
              > E492: Not an editor command: nextgroup=netrwList
              >
              > I then commented that line out. The effect of netrw's "mt" was to
              > highlight the words "Copy/Move Tgt:" in the header. The target file
              > itself was not highlighted. Is that what the commented line should
              > have done?
              >

              There was a spurious linebreak in the email. "nextgroup=netrwList"
              should either have been at the end of the previous :syn match line, or
              else have a backslash at the start to mark it as a continuation line.

              Best regards,
              Tony.
              --
              ... the privileged being which we call human is distinguished from
              other animals only by certain double-edged manifestations which in
              charity we can only call "inhuman."
              -- R. A. Lafferty

              --
              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php

              ---
              You received this message because you are subscribed to the Google Groups "vim_use" group.
              To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
              For more options, visit https://groups.google.com/groups/opt_out.
            • AndyHancock
              ... Thanks Tony. Appending nextgroup=netrwList to the end of syn match netrwCopyTgt Copy/Move Tgt: contained skipwhite eliminates the error message, but the
              Message 6 of 6 , Mar 31 1:29 PM
              • 0 Attachment
                On Mar 31, 3:32 am, Tony Mechelynck wrote:
                >On 31/03/13 09:16, AndyHancock wrote:
                >>On Mar 30, 7:20 pm, Charles E Campbell wrote:
                >>>AndyHancock wrote:
                >>>> I am trying to get my netrw marked files to show up as yellow,
                >>>> and the target directory for copying marked files to show up as
                >>>> bolded
                >>>> <...snip...>
                >>> The netrwCopyTgt syntax is transparent. You need to get rid of
                >>> that modifier. So, put in your .vim/after/syntax/netrw.vim file:
                >>>
                >>> syn clear netrwCopyTgt
                >>> syn match netrwCopyTgt "Copy/Move Tgt:" contained skipwhite
                >>> nextgroup=netrwList
                >>> hi link netrwCopyTgt Unique
                >>>
                >>> where Unique is whatever color you want (or, instead of hi link
                >>> ..., use hi and fg= bg= etc specifications).
                >>
                >> I put the lines into cygwin's /usr/share/vim/vimfiles/after/syntax/
                >> netrw.vim. In place of "hi link netrwCopyTgt Unique", I put
                >>
                >> hi netrwCopyTgt term=bold cterm=11 gui=bold guifg=yellow
                >>
                >> When I editted a directory path and netrw is invoked, I pressed "a"
                >> to cycle through the hiding list modes until nothing was hidden. I
                >> got the error:
                >>
                >> Error detected while processing
                >> /usr/share/vim/vimfiles/after/syntax/netrw.vim:
                >> line 5:
                >> E492: Not an editor command: nextgroup=netrwList
                >>
                >> I then commented that line out. The effect of netrw's "mt" was to
                >> highlight the words "Copy/Move Tgt:" in the header. The target
                >> file itself was not highlighted. Is that what the commented line
                >> should have done?
                >
                > There was a spurious linebreak in the email. "nextgroup=netrwList"
                > should either have been at the end of the previous :syn match line,
                > or else have a backslash at the start to mark it as a continuation
                > line.

                Thanks Tony. Appending

                nextgroup=netrwList

                to the end of

                syn match netrwCopyTgt "Copy/Move Tgt:" contained skipwhite

                eliminates the error message, but the text that is highlighted by

                hi netrwCopyTgt term=bold cterm=11 gui=bold guifg=yellow

                is still only the text "Copy/Move Tgt:" in the header region of the
                netrw window. The occurance of the directory name itself in the file
                listing part of the netrw window is not highlighted.

                This is better than it was before, though. Thanks again, Tony,
                Charles.

                --
                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                ---
                You received this message because you are subscribed to the Google Groups "vim_use" group.
                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                For more options, visit https://groups.google.com/groups/opt_out.
              Your message has been successfully submitted and would be delivered to recipients shortly.